• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Python API compatibility and or downgrading

New Here ,
Oct 23, 2022 Oct 23, 2022

Copy link to clipboard

Copied

The most recent version of  photoshop, 24.0 is no longer compatible with the popular python library of automating mundane tasks.

 

error when working with photoshop since version 23.5 · Issue #195 · loonghao/photoshop-python-api (g...

 

Does anyone know of a potential work around? 

Is there a trvial method to downgrade my version from 24 back to versions that worked, presumably 22.x?

I've dozens of scripts performing a wide range of tedius and time consuming tasks, and this "upgrade" is not helping. Last question, any ideas how / if possible to deactive auto-upgrade so I can avoid dealing with versions which haven't matured well enough to avoid bugs?

TOPICS
Actions and scripting

Views

28

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2022 Oct 23, 2022

Copy link to clipboard

Copied

LATEST

I found Turning off auto-upgrade here: Install previous versions of your Creative Cloud apps (adobe.com)
Creative Cloud -> preferences -> Apps -> Auto-update

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines