"Could not fill because there are not enough opaque source pixels" - not solved by any other thread

New Here ,
Jul 05, 2013 Jul 05, 2013

Copy link to clipboard

Copied

I'm getting the error posted in this thread's title and I have no idea why.  I am working with an image that is NOT transparent in any way. Everything is 100% opacity.  In fact, it doesn't matter what I work with, every time I try to fill any selection on any layer in any doc, I get this error.  Ideas???  Thanks

Scott

Views

95.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Jul 06, 2013 Jul 06, 2013

Hello,

sounds like you have "Content Aware" selected under the Fill options. if you have a selection and your active layer is empty, Content Aware will give you that error. As it needs 'opaque source pixels (in your current layer)' to work. For solid colors, switch from Content Aware to one of the other modes.

please post back if this doesn't fix things for you.

Likes

Translate

Translate
LEGEND ,
Jul 05, 2013 Jul 05, 2013

Copy link to clipboard

Copied

Probably would help to see a screen shot of photoshop with the layers panel open.

At this point the only guess I can make is the wrong layer is selected, but once I see the screen, then something else may pop out at me, or anybody else reading this thread.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 06, 2013 Jul 06, 2013

Copy link to clipboard

Copied

Hello,

sounds like you have "Content Aware" selected under the Fill options. if you have a selection and your active layer is empty, Content Aware will give you that error. As it needs 'opaque source pixels (in your current layer)' to work. For solid colors, switch from Content Aware to one of the other modes.

please post back if this doesn't fix things for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jul 08, 2013 Jul 08, 2013

Copy link to clipboard

Copied

Hi trimbal,

Have you tried cagiali's suggestion? It does sound like you were trying to fill using content-aware.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2013 Jul 08, 2013

Copy link to clipboard

Copied

Cagiali had it exactly right, i had content aware selected in fill options.  Thanks a lot!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jul 08, 2013 Jul 08, 2013

Copy link to clipboard

Copied

Glad to help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2015 Jan 22, 2015

Copy link to clipboard

Copied

I had the same problem, but I'm trying to just use the blemish remover. I've been trying for the past hour and a half to get it to finally let me use content-aware just so I could remove the blemishes, and once it finally let me use it, it gave me the "Could not fill because there are not enough opaque source pixels" message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2016 Mar 08, 2016

Copy link to clipboard

Copied

Content-aware fill also  gave me the "Could not fill because there are not enough opaque source pixels" message. Tried CMYK and RGB, checked active layer etc. The active layer did not appear to have any transparency. I managed to get the Content-aware fill working by using "Flatten image". By curiosity I also testet merging the affected layer with a solid white layer. That also solved the problem.

[edit] It seems like if the entire target layer is just a little bit transparent (not even visible to the eye), the Content-aware fill does not work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Is it possible the layer is a smart object?

For anyone that still has an issue could you capture your entire screen with the layers panel open and any collapsed layers - expand them so we can see them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 31, 2022 Jul 31, 2022

Copy link to clipboard

Copied

LATEST

I've done it myself and found out that I was working on the WRONG LAYER. If this doesn't fix your prob, skip my comment.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

I still don't understand could you explain it easier or show me some how

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2018 Mar 30, 2018

Copy link to clipboard

Copied

Hello everyone,

I would also love some help with this. I'm trying to remove an object using the laso tool, when I go to fill, I get the same error comment.

I'm using "content aware" in the fill options because I want to I want to remove the object. Can I get some help?

Thanks guys.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 10, 2018 Apr 10, 2018

Copy link to clipboard

Copied

Hi I had same issue and forgot to make a copy of background layer then it work as before

drag layer to create a new layer  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

I'm having the same  problem but it is intermittent and the above replies did not help. Attached is a screenshot of the active layer and dialog box The bird has been  selected

 

Untitled.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Were you able to solve it then?

Rozema

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Yes, but but I don't remeber what I was doing wrong or how I solved it. I must being doing it correctly now as I don't have the problem anymore.

 

Thanks 

Ray

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines