Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Select and Mask mode not working

Community Beginner ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

I've been struggling with this all weekend. Not sure if it's a performance issue. However when i go into select and mask mode. Everything seems fine. I lassoed the background out and ready to go in there and get the fine details out of the model off the background. The one thing is the brushes doent respond at all. I can move them over and nothing happens. I just end up clicking ok and nothing happens. Not sure what is. Please help. Here is what I have.Screen Shot 2017-05-08 at 2.44.52 PM.png

Views

13.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 08, 2017 May 08, 2017
HiIf you can't use any tools in Select and Mask and cannot use refine edge either, using the method I described, I would reset your preferences.Go to Preferences > General and click Reset Preferences on Quit. Click OK then close and restart PhotoshopDave

Likes

Translate

Translate
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Hi

Can I check whether you are using select and mask in onion skin mode on a duplicate layer?

If so then S&M can appear to do nothing as it masks areas and the layer below (which is the same) , shows through.

Just to test, try using it on a single layer image with onion skin enabled and transparency at 50%

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Hello,

No I did check. I usually use overlay in select and mask mode. It shows all red and then I try to brush over the fine hairs and it does nothing. Then just click ok to get out of select and mask mode and it just does nothing after you hit ok. Screen Shot 2017-05-08 at 3.15.39 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Have you tried resetting select and mask ? (in select and mask go to the workspace dropdown at the top right and choose Reset Select and Mask)

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Yeah I just tried it. Did nothing. Still the same thing? I think it may be a performance issue. My comptuer is mac 2012 not sure if it's my graphics card?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

I've only seen one reference to it doing nothing at all and that was also a MAC user (on Sierra).

Select and mask tool not working CC2017

In the meantime - the old refine edge is still available. With a selection made, go to the Select menu and hold down the shift key whilst clicking on Select and Mask in that menu. Note - it has to be from the menu not the S&M button in the options bar.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

That doesnt even work I can select stuff but it goes to SM area and I cant use any of the tools they dont do anything and then I hit ok and it wont even cut out the rough selection that I used. So not sure what to do. I can't even call support to find out what the issues are.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Hi

If you can't use any tools in Select and Mask and cannot use refine edge either, using the method I described, I would reset your preferences.

Go to Preferences > General and click Reset Preferences on Quit. Click OK then close and restart Photoshop

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

OMG! It worked!!! finally not sure why! Man thank you. Something easy as resetting hahaha

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2017 May 08, 2017

Copy link to clipboard

Copied

Glad to help

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

I think I am having the same issue as stated above. I have been resetting my photoshop but are there any solutions besides resetting it? Because it is getting too often. And what are the reason(s) behind it? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

I have update my Photoshop 2021 to 22.4.1 and I have the above mentioned problem. I have resetted preferences and restarted, it did not work. Still the tools in Select & Mask are not working. But I followed the advice above to go to menu, hold shift and choose Select and mask to get the old Refine edge tool. That one works and finally I can edit my selection, although I would be glad to use the new tool (tutorials I follow uses the new one). Anyone have any idea how to fix it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

I'm also having this issue, it seems that something is happening because if I click okay the edits appear on the layer.  But while in "select and mask" nothing is updating.  I'm not on onion layer, just white.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

@Jonas5CCB  @kenneths56276931 

The issue you are seeing sounds different to the one in this old post, but may be related to a preview issue linked below. If the symptoms match that, then you may want to add your comments to the bug report.

 

https://feedback.photoshop.com/conversations/photoshop/photoshop-v224-select-and-mask-workspace-prev...

 

On my system S&M preview works when I enter select and mask with or without a selection but not if I enter it by double clicking a layer mask

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Hi, that is my experience as well now when I test, windows 10. When I create layer mask, after selection, and use Select & Mask button under properties (above layers), then tools are not working. If I instead select and choose Select & Mask from Select menu in top, then it works. So after refinement I can create my Layer mask. Problem is that if I want to correct my layer mask afterwards, I get the same problem. If using the Overlay view, it seems to work though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

@Jonas5CCB Thanks for confirming. Adding comments to the bug report I linked will raise its profile with teh developers

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

LATEST

Actually, the solution might seems very fake but that's the go you've been looking for. When you find yourself struggling in a situation like this,

 

Screenshot 2021-11-23 at 12.02.23 AM.png

 

Just press the letter Q, This simply enables/dissables Quick mask mode, Once you have dissabled the same you're good to go... As simple as that.... I hope this works for you....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines