Serious Graphical Issues recently

New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

Photoshop 23.3.2
Windows 10

I have been using Photoshop, and other Adobe products for years.
I have a computer that has been running Adobe software for 10+ years.
It is not the highest end machine, but it has always worked before.


Recently, within the last month or so, something changed and now Photoshop is almost completely unusable.

The first thing I noticed was that everything started taking longer to open and scroll/zoom. 
I am a game developer, so I do a lot (but not exclusively) of pixel art - so I am working with images that are small and very zoomed in.

Whenever I use the mouse wheel to scroll (horizontally or vertically), or use the zoom tool to zoom in/out via clicking with the mouse, I have to wait a LONG time for each 'step' to render... or something... before the controls become responsive again.

Next, I noticed that when I did zoom in, the Pixel Grid was no longer showing up. 
I posted about it, but no one had any answers: https://community.adobe.com/t5/photoshop-ecosystem-discussions/pixel-grid-disappears-after-enabling-...

 

I narrowed it down to: if I reset ALL of my options, exit and re-launch Photoshop, the Pixel Grid is there until I turn on the Custom grid lines, and then it goes away COMPLETELY - it is no longer an option ANYWHERE to turn it back on, even if I turn off the custom grid and restart the application. I have to reset the options again.

This is obviously less than ideal since I am often working with sprite sheets where I want the pixel grid visible AND the Custom Grid at the same time - and this USED to work just fine...

NEXT I started noticing... I don't know what to call it... screen-tearing? Screen drawing issues? I don't know... I would be trying to work on one part of an image, zoom or scroll and a huge chunk of the screen would not be updated... and would be split from the rest of the image.
This issue in particular has made it next to impossible to work on anything lately. It has severly impacted my ability to do even the simplest of tasks.

It's hard to reproduce this last issue on cue. It just sort of happens. I can be working with a file that is 1000x1000 pixels and it will start happening, or a file that is 32x32 pixels and it will start happening.

bug_mockup.png
(This is a mock-up since I couldn't get it to happen again while I was typing this out - but it would look something like this)

I have made no changes to my system in about 2 years, and this was not happening only a few months ago.
I have all the latest Windows Updates, Updates to my graphics card drivers, and updates to Photoshop/Creative Cloud.

I have been reluctantly fine with spending the exorbitant subscription fees for Adobe products because I considered them to best be able to fit my needs and my familiarity with them allowed me to work efficiantly with any workflow I needed, but these issues are making me want to consider replacing all of my Adobe applications with something else that has a reasonable cost and actually works.

I've heard good things about Affinity.

Play my games: https://axolstudio.com
TOPICS
Windows

Views

47

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

More and more functionality in Adobe products is moving to the GPU in update after update. So try disabling GPU in the Preferences (Performance tab). Any better?

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. Also see: https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

Turning off the GPU does not make any noticible difference.

I've triple-checked that everything is up-to-date with my drivers and everything and I checked the GPU Compatibility Check:

gpu_report.png

Play my games: https://axolstudio.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

Maybe try this : Go to Preferences >Technology Previews and check Deactivate Native Canvas. Then quit and restart Photoshop; any better? 


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

That option is already disabled.
I tried enabling it, and suddenly I can have the Pixel Grid and the Custom grid visible at the same time!!

Scrolling/Zooming performance is suddenly much better now, too...

Not sure about the tearing issue - it hasn't happened again YET...

I'm not sure how that option was disabled, but enabling is seems to have fixed most of my issues... Thanks!

Play my games: https://axolstudio.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

LATEST

Let me clarify, because I read that comment backwards (double negatives!)

The option "Deactivate Native Canvas" was Unchecked, meaning Native Canvas was Active.
I checked on the option, as suggested, which Deactivated the Native Canvas and fixed one of my issues for sure, seems to have improved one of the others, and, so-far, the third issue has not happned again, yet.

Play my games: https://axolstudio.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines