• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Spot healing brush tool no longer works correctly

Participant ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

for about a week now anytime I try the spot healing brush tool it no longer works like it used to... no matter what I try (changing the hardness, changing the layer I'm sampling from, changing the size of the brush) nothing helps now that the tool isn't working. What I'm seeing is ring around every retouch that is obvious and not seamless like the tool used to do. Imagine one retouch that looks wrong now being in place of every single retouch you try, even ones that used to be , and should be, seamless... but no... you get a big, ugly,  discolored line around the outside of the brush click....

nothing like being on a time crunch and then finding that the Adobe product you depend on just isn't working properly anymore.

Views

40.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Oct 12, 2018 Oct 12, 2018

Sometimes tool settings get changed around and yet there is a way back to defaults.

Right click on the tool and select "Reset Tool"  I try this before trying a preference reset because I have to restore some items a preference reset takes away. It does reset the brush as well, but if the brush settings were thrown off, it will fix that as well. Tools and Dialog boxes have their own resets and should be the first thing to try.

Screen Shot 2018-10-12 at 7.16.59 PM.png

And you should see this:

Screen Shot 2018-10-12 at 7.17.25 PM.png

Likes

Translate

Translate
Community Beginner , Oct 11, 2019 Oct 11, 2019

None of the above advice helped me, but after I closed and reopened the file the Spot Healing Brush started working.

Likes

Translate

Translate
Adobe Employee ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Hi Dukeeastwood,

 

Sorry to hear about the spot healing tool not working properly, could you please let us know which exact version of Photoshop you're working on and which operating system are you using?

 

Could you please try resetting the preferences of Photoshop and let us know if it helps with the issue?

Preferences Reset Photoshop - Preferences

 

Make sure that you backup customer presets, actions and brushes before restoring the preferences to default.

 

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

I reset Preference Reset Photoshop by following the link and than used 

Using the Preferences dialog

That reset all my prefrences but it worked

Thanks

Bruce

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

In the Option bar,  is the Mode set to Normal and the type  Content-aware ?

spot.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Thanks, this guided me to the solution. I just had to make sure my tool was "sampling all layers." 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Sometimes tool settings get changed around and yet there is a way back to defaults.

Right click on the tool and select "Reset Tool"  I try this before trying a preference reset because I have to restore some items a preference reset takes away. It does reset the brush as well, but if the brush settings were thrown off, it will fix that as well. Tools and Dialog boxes have their own resets and should be the first thing to try.

Screen Shot 2018-10-12 at 7.16.59 PM.png

And you should see this:

Screen Shot 2018-10-12 at 7.17.25 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Tried this, all settings match the screenshots above and the tool just paints black on the canvas it never manipulated the image or object no matter what layer you have selected. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 08, 2022 May 08, 2022

Copy link to clipboard

Copied

Thank you - worked for me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 13, 2018 Oct 13, 2018

Copy link to clipboard

Copied

This happens because the default setting for Spot healing is Content Aware - which generally works better. However older versions of PS used Proximity Match as a default (I think, off the top of my head!) so try switching to that or Create Texture, to see if you can replicate the old behaviour.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 11, 2019 Oct 11, 2019

Copy link to clipboard

Copied

None of the above advice helped me, but after I closed and reopened the file the Spot Healing Brush started working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 05, 2019 Nov 05, 2019

Copy link to clipboard

Copied

Well that should really be our default answer for everything! 😉 nine times out of ten it fixes the issue. Thanks for letting us know 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Unfortunately, restarting didn't resolve the issue for me.

I have the same problem, and switching from content aware to proximity match didn't help either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Same here!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

Unfortunately these suggestions didn't work for me either.

Restarting PS worked, but only briefly. ALL TOOLS were rendered useless again after I used lasso/content aware fill combo. And reseting the tools doesn't seem to fix the problem.

So I said screw it, I'll just continue using the lasso/fill, but even the that won't work after its first use. Even after reopening.

Bummer. These wedding photos will be taking much longer than I expected lol.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

Try opening a new document, see if the brush works there. If it does, try copy pasting all the layers, channels, etc, from the old one to the new one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

Make sure that "sample all layers" is selected. The setting should be:

Mode: Normal

Type: Content Aware

Check the box for Sample All Layers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

Thank you, did the trick for me. Have a good day!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2021 Oct 17, 2021

Copy link to clipboard

Copied

 it works for me, thank you very much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2022 Oct 04, 2022

Copy link to clipboard

Copied

LATEST

Nothing worked for me. My Healing brush just puts a copy of my image on top of my image and then when I Alt click and my cursor hits the image it locks on and moves to image around. I have done resets on tools and preferences to no avail. Tried opening a new image and shutting down and reopening Ps but nothing works.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

I have had the same problem and what I found is that if I used the spot healing it would select the object but see to hang at that moment.  If I scroll the image (forcing a screen refresh) the healing brush did actually work.  I suspect this is something to do with my graphics card & or it's driver.  (my graphics card is about 8 years old now and I am seeing some issues like this in Photoshop CC and ON1 Photo Raw)  The difference is ON1 seems to be able to fix these issues rather quickly.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Photoshop update 23.1 fixed my screen refresh problem. Spot healing works properly now. It also fixed several other small glitches. Photoshop does not recognize my graphics card but at least now when I run the graphics card test, the program does not crash.
Thanks for the update 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

Finally, I've found a solution to this issue. Has only happened recently, possibly after my graphics card updated itself.
Thanks for the solution
Cheers 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines