Updated Nvidia Graphics Processor STILL Incompatible

Explorer ,
May 29, 2022 May 29, 2022

Copy link to clipboard

Copied

Hello,

 

I've looked through all the previous posts for this isuue, and they don't seem to apply. I pulled my Dell XPS 1550 out after 8 months because I had an unexpected trip out of the country (US) for a death in the family. I updated all the firmware and software. The graphics card is a GeForce; I went to the NVidia site to download a fresh driver. The studio version would not install but the gaming version did.

 

Photoshop is still crashing most of the time, but when it does actually open I keep getting the same compatibility error (even after lots of re-boots). I've tried downloading an older version of Photoshop because I know it used to work with my graphics card...but not anymore. For the record, I have 41% of my hard drive space free.

 

I'm under a tight deadline and, as I said, out of the country due to a death in my family. So I'm a bit desperate here, and I hope someone is familiar with the problem, since none of the solutions I've found work for me.

 

Thanks in advance.

 

 

 

 

TOPICS
Windows

Views

84

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 06, 2022 Jun 06, 2022
I found out how to disable the driver in Device Manager. First I tried disabling the (updated) Intel processor, and that was sort of a disaster, so I enabled it again and disabled the Nvidia one, and it now works fine, depressingly (since I paid extra for the Nvidia). At least, Photoshop opens without the error message, and the 4K screen images look sharp. So I guess the 2022 Nvidia driver update isn't such a great update after all.  And I think I'm good to go. Thank you, everyone.

Likes

Translate

Translate
Adobe Community Professional ,
May 29, 2022 May 29, 2022

Copy link to clipboard

Copied

Did you try disabling GPU completely in preferences?


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2022 May 29, 2022

Copy link to clipboard

Copied

If there is an integrated Intel GPU in addition to the NVidia - there usually is in laptops - you may need to completely disable it. See section 7 and 8 here:

https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html 

 

Dual GPUs is fine for simple apps that only send data downstream, but Photoshop uses the GPU for actual data processing, and the result returned to Photoshop for further processing. There can only be one GPU in that equation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

Thank you for answering. I've tried many times to disable my GPU, but here is a screenshot (actually, a phone pic since the omputer froze) of what I get, below. I'd been using this computer with PS, Illustrator, and Sketchup with no problems until about a year ago, so this issue of dual GPUs makes no sense to me.

 

And as you can see, there isn't a way to disable the GPU, at least that I can see. I've tried several times with the same result (to reference Einstein).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

You have to disable it outside of Photoshop, so PS does t see it, and picks up the useful GPU. You could also make sure to update drivers for the Intel GPU, since that's the one PS is seeing. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

Ah, I'll try disabling it, thank you. Updating the Intel processor didn't work, maybe the Nvidia one was overriding it.

 

Can you tell me the best way to disable it, other rhan uninstalling it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

LATEST

I found out how to disable the driver in Device Manager. First I tried disabling the (updated) Intel processor, and that was sort of a disaster, so I enabled it again and disabled the Nvidia one, and it now works fine, depressingly (since I paid extra for the Nvidia). At least, Photoshop opens without the error message, and the 4K screen images look sharp. So I guess the 2022 Nvidia driver update isn't such a great update after all.  And I think I'm good to go.

 

Thank you, everyone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines