• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Why is my brush looking pixelated & dithered over transparent background?

New Here ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

This just started happening an hour ago and I'm pretty sure I must have done something to cause it, but for the life of me can't figure out how I did it. Can't seem to find a problem like this online either, all of them are usually solved by switching to the correct brush / changing blending mode.

 

Here's the gist: when drawing with a soft brush, or erasing with a soft eraser over a transparent background, the color appears to be distorted and edges pixelated. It looks just fine over a background, though.

 

Screenshot of the effect:

Captur23465ePHOTOSHOP.PNG

Video can be seen here.

 

Things I have tried: updated the drivers, checked & unchecked GPU acceleration, all to no avail, the issue persists. The files display fine in other programs, so it must be some view issue in Photoshop itself.

 

All help is greatly appreciated.

TOPICS
Windows

Views

599

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 06, 2022 Jun 06, 2022

It is just a preview rendering artifact, and has been that way for years. It does not affect your actual image.

Put a temporary solid layer at the bottom of the layer stack then remove it, or turn off visibility, before exporting/saving.

 

Dave

Likes

Translate

Translate
New Here ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

Here's another example where dithering and hard edges are clearly visible.

The image below was drawn with soft brushes and is almost entirely black:

jagged_edges.png

However, this is what it looks like in Photoshop:

jagged_edges_screenshot.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

that's just the weird rendering that happens over the transparent grid pattern. You can disable the grid in Prefs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2022 Feb 24, 2022

Copy link to clipboard

Copied

I'm having the exact same issue!!!! And you seem to be the only person on Earth who has experienced it too. 

 

Did you ever find a solution for this please?!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

Having the exact same problem. Will report back if I find a soluion.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

It is just a preview rendering artifact, and has been that way for years. It does not affect your actual image.

Put a temporary solid layer at the bottom of the layer stack then remove it, or turn off visibility, before exporting/saving.

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

Great thanks, think I maxed out my GPU today. I noticed once I imported the .psd into After Effects I did not see the artifacting. Thanks so much, good to know!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

This has to do with blend gamma - the transparency "curve" from fully opaque to fully transparent.

 

There is a checkbox in Color Settings to "blend RGB using gamma x.x", and if you check this (default value 1.0), you get the same appearance whther transparent or white background. Unfortunately, you then get the "bad" appearance in both cases.

 

Photoshop uses a custom blend gamma value that will most closely correspond to how ink behaves on paper. I think it's somewhere around 1.5.

 

I don't know enough about the technical background here, but apparently blend gamma only applies when there is actually something to blend with - either a background color or an underlying layer.

 

In other words, I don't think there's an easy way around this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

LATEST

any solution found? I think I tried everything

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines