Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Why is the "Quick Selection Tool" working so slowly? - Photoshop CC in Windows 7

Community Beginner ,
Dec 30, 2013 Dec 30, 2013

Copy link to clipboard

Copied

Every time I try to use the Quick selection tool, it takes a REALLY long time to select. I had CS5 and it was super fast, even with large RAW files. Now with CC, it takes at least 20 minutes to select a person out of a photo.

I already tried "resetting" the tool - that did not work at all.

Please help!

Views

26.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Jan 14, 2014 Jan 14, 2014
Hey! I had the SAME problem... solved in 30 minutes because I had put CC on my laptop and the Quick Selection tool is fast, but on my Mega-fast desktop (16gb, 4.2Ghz, blah, blah) Photoshop CC was DRAGGING BUTT. The difference is I loaded the desktop from scratch. The Laptop had CS5 prviously, and PS copied the settings from Edit/Preferences/Performance that existed in CS5... it was all about the History & Cache section. Hit "Big and Flat" for the 1024K cache tile size, and it set the cache state...

Likes

Translate

Translate
Adobe Community Professional ,
Dec 30, 2013 Dec 30, 2013

Copy link to clipboard

Copied

What operating system?   My laptop slowed to a crawl after it updated from Windows 8 to 8.1.  When I checked Preferenes > Performance, I found that GPU Acceleration was no longer ticked, but a visit to the nVidea driver site fixed it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2014 Jan 03, 2014

Copy link to clipboard

Copied

Thanks Trevor (sorry for the late response!)

Actually, I'm still using Windows 7, and it's not the computer that's slow - only that one tool. It's really weird!! I checked my video card and it seems to be set up fine...

Thanks for the advice, though!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 03, 2014 Jan 03, 2014

Copy link to clipboard

Copied

Do you have the latest drivers for the video card?  Just becasue it worked in CS5 is no guarantee it will work in CC as that program puts a much heaver load on the gpu.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 03, 2014 Jan 03, 2014

Copy link to clipboard

Copied

Update from makers site, not MS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2014 Jan 07, 2014

Copy link to clipboard

Copied

Thanks Curt,

I went ahead and updated my drivers again, but it did not help at all. (Radeon HD 5800) The tool is SO slow that it's pretty much useless. It was one of the reasons I wanted CC. That and Content Aware - which works fine. I'm thinking there's some setting somewhere that makes it slow?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 08, 2014 Jan 08, 2014

Copy link to clipboard

Copied

Just to clarify things a bit: Is it slow while you are painting with the tool or after you release the mouse button? Is it significantly faster if you work with low-res files or is it the same?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2014 Jan 08, 2014

Copy link to clipboard

Copied

Thanks Sulaco,

When I hold the mouse button and drag it is as slow as just clicking and letting go. The longer I hold and drag, the longer it has to process once I let go. The smaller the file, the faster it works, but it didn't used to be like that.

PS Your screen name is awesome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 08, 2014 Jan 08, 2014

Copy link to clipboard

Copied

I am asking just to try and figure out if its related to GPU acceleration or not. I think that once you release the mouse button the ordinary CPU takes over to fix the selection. So your reply would suggest that it's not related to your GPU, at least I think that's a reasonable assumption. I suppose you could try and play around with the GPU acceleration settings under Edit/Preferences/Performance/

The tool is quite slow. Where I teach, we have PS CS6 running on pretty slow computers and the tool is a pain to use at higher resolutions, so I always make sure to use low-res images when showing how it works.

What are your computer specs? I assume you have disabled "Sample All Layers" and "Auto-Enhance" in the tool settings? Because these will slow it down even further. I suppose you could try and reset the PS preferences (this will also reset your personal preferences!). Hold down Ctrl + Option + Shift while starting up Photoshop. A dialog box will appear asking if you wish to delete the preferences/settings file.

Other than that I can't come up with anything else at the moment. If you are unlucky it might just be that the tool is more demanding in CC on your computer. But let us know if my suggestions made any difference.

Thanks! I am surprised that the username wasn't already taken!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2014 Jan 08, 2014

Copy link to clipboard

Copied

I mentioned working on my laptop without GPU acceleration, and how much it slowed everything down, but Quick Select was still laggy after the driver updated and GPU acceleration restored.  This is a reasonable laptop with i7, 16Gb and GTX680. Thankfully, I got my main system back yesterday, and Quick select is pretty much instant.

But there shouldn't be that much difference.  The big box has six core running at 4.2Ghz (under load) 32GB and GTX570, so while it is certainly more powerful, the difference in performance in respect to Quick Select is not proportional.   I've just tried reducing cache levels on the big box from the '6' it usually runs at right down to 2, but it still responds instantly even with large files.  I have GPU set to Advanced, and tile size to 128 on both systems.

Another odd thing is that I only have 1GB vRAM with the GTX570, where the GTX680 has 4Gb of faster vRAM.  But maybe Quick select is not a big user of GPU acceleration. 

So no real help I am afraid.  I have looked through the GPU FAQ, but nothing helpful there. OK,  I have just found a more detailed article on GPU acceleration, and it mentions a lot of features, but not Quick Select, so it could be that GPU is irrelevant.   The laptop is Windows 8.1 as opposed win 7 for the big box, if that makes a difference.  Can you correlate anything between our systems?  I hate to post this without any suggestions, but I'm stumped. 

There are tricks to aid Quick select. 

  1. Make a copy of the layer, and apply Curves and/or Levels directly to the layer, and try to increase contrast between the subject and background.  Use this layer to make the selection, then switch back to the normal layer to use the selection.
  2. I don’t know if this will work as I have just thought of it.  Copy the layer, and Free Transform it to a smaller size.  It will be image dependant, but Quick Select is much faster with images below about 1500 pixels wide. Use Quick select on the smaller image layer, and copy the selection to a new layer. FT it back up to size, and it should fit.  This would only be useful if you are going to use Refine Edge right after, and will have obvious limitations.

Make sure you report back if you find a solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2014 Jan 14, 2014

Copy link to clipboard

Copied

Hey! I had the SAME problem... solved in 30 minutes because I had put CC on my laptop and the Quick Selection tool is fast, but on my Mega-fast desktop (16gb, 4.2Ghz, blah, blah) Photoshop CC was DRAGGING BUTT.
The difference is I loaded the desktop from scratch. The Laptop had CS5 prviously, and PS copied the settings from Edit/Preferences/Performance that existed in CS5... it was all about the History & Cache section. Hit "Big and Flat" for the 1024K cache tile size, and it set the cache states to 6. I backed that up to 4... eh whatever

You are welcomed
(I was about to uninstall the PS CC! It's all good now... BTW - I even yanked out the Nvidia GTS450 thinking it was a driver issue, but there was no difference with the onboard Intel HD Haswell i5 4th gen graphics... so, don't do that!)

[edited] I just did some experimenting, 8 levels with a small cache size works too... so, just get out of the 2 levels at 128k if that is what you are set at. I am at Big and Flat which is 6 levels/1024K.

Tim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2014 Jan 15, 2014

Copy link to clipboard

Copied

Sulaco: Thanks for your help! I run a 16gb RAM desktop that my husband is jealous of and says I could use it for gaming, so I wouldn't expect it to be slow. I tried resetting the specs and made sure the tool settings were as you described and it didn't help much. I started working with the low res images until that last poster came up with the solution.

Trevor.Dennis: I appreciate all the time you took to try and figure out the problem! And coming up with the work around. It is much appreciated!! I tried the cache levels you recommended and it was just as slow. I used your workaround until the solution got posted:

Shootmyphoto.com: THANK YOU SO MUCH!! I would not have expected lowering the cache states to make it work faster! Once I changed the cache states down to 4 and tile size to 1024K it went back to normal!!

And, I would like to add, you solved an additional problem I was too busy to post about - when I opened a file that was shot at ISO 400+, the photo looked extremely grainy/noisy in photoshop CC, but completely normal in any other program or online. Now after I changed those settings, the photos look normal again!! THANK YOU!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 15, 2014 Jan 15, 2014

Copy link to clipboard

Copied

Cool to hear that you solved the problem! Also nice to learn something new, thanks shootmyphoto! I have never fully understood how cache levels and tile size works! Mine is set to 4 and 1024K also ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2014 Jan 21, 2014

Copy link to clipboard

Copied

Thanks Tim!!! You sugestion worked like a charm!

Mark

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2014 Feb 25, 2014

Copy link to clipboard

Copied

Trevor's answer worked for me AFTER I remembered to restart PS after making the prefernces changes.

Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2014 Feb 25, 2014

Copy link to clipboard

Copied

One of the biggies with Preferences > Performance — supposing GPU accelleration is enabled — is making sure Cache levels are set to something other than 1.  In fact there is a warning against this at the bottom of the History and Cache area.

Cache Levels.jpg

[EDIT]  Incidentally, my primary Scratch disk overflowed recently with four separate temp files.  One of them did have an old date on it, so would have been orphaned off by Photoshop shutting down unexpectedly.  I'm not even sure why I am using it, but is just old habbit of bumping old drives when upgrading, so the 😧 drive is a single 300Gb Velociraptor (2nd gen ?).  The E: drive has a pair of 1Tb 6th Gen V'Raptors, which tested at >350Mb/s so I should probably use that as Primary Scratch.  Just not sure what I'd use the 300Gb drive for.   When I get round to bumping my boot drive with a pair of 250Gb Samsung EVOs, I will need another mainboard SATA header, so probably just trash the 300Gb drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2014 Feb 26, 2014

Copy link to clipboard

Copied

Trevor Dennis wrote:

Cache Levels.jpg

So did nobody notice my special Preferences?     It is sooo lame when you have to point stuff out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 12, 2015 Aug 12, 2015

Copy link to clipboard

Copied

Thank you this worked for me, I have been tearing my hair out with it.

Your suggestions have been gratefully appreciated THANKYOU

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2015 Jun 09, 2015

Copy link to clipboard

Copied

Tims suggestion worked like a charm for me. The tool works instantly now. I changed to big and flat (which initially changed the tile to 128k) then I changed that to 1024k, set my cache level and history state to 6, restarted photoshop, and it worked.

Now if I can just get lightroom cc 2015 to stop crashing I'll be set. Looking into this on other forums. Thanks guys!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2016 Apr 06, 2016

Copy link to clipboard

Copied

Thank you, Tim, this worked perfectly for me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 16, 2014 May 16, 2014

Copy link to clipboard

Copied

Hi Everybody,

up till yesterday everything worked fine on my copy of Ps CC. Then I encountered "all of the sudden" the same issue as described in the original post. Glad, the solution offered to the original poster works, but it didn't work for me and as I read, I am not the only one. And apart from that, I suffered crashes as well ...

I looked at the performance settings in my copy of Ps CS6 (in which the quick selection tool works fine) and they were exactly the same as in Ps CC. But I oversaw the amount of RAM appointed to Ps ... Then I recollected, that I had changed this setting in Ps CC the day before. Because I have 24 Gig of RAM, I put up the slider there to the max Ps recommends. (i.e. appr. 15 Gig). I put the slider back a little (appr. 13 Gig) and everything worked fine again ...

So, no driver updates, no cache level or graph card resettings necessary here. Just try this simple solution ....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2014 Sep 13, 2014

Copy link to clipboard

Copied

You're my hero!!! This solved the problem on windows 7 with 12gb of ram and Adobe Phtoshop CC 2014.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 19, 2014 Oct 19, 2014

Copy link to clipboard

Copied

Im sorry to bring this topic up again. But none of the above suggestions work for me. Quick selection too is getting slower the more area I select. Any ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2014 Nov 21, 2014

Copy link to clipboard

Copied

I'm using PS CC 2014. After updating I noticed that quick selection was unuseably slow. I went to Edit / Preferences / Performance and noticed that cache levels was set to 1. Increased it to 4 and the problem was solved. Notice that is necessary to exit and restart PS for the modifications to be effective.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 31, 2014 Dec 31, 2014

Copy link to clipboard

Copied

Just one more advice if you are having this issue.

1) i set as ppl told here the chacle levels to 8 and cache tile to 1024

2) i set the scratch disk to only my fast SSD HD

3) MOST IMPORTANT ---> Changes only did effect after i closed and restarted the Photoshop CC.

I hope this help someone !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2