No Plugins/Extensions for PS running natively on Apple Silicon

0 Votes
Community Beginner ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

It's great that PS now runs native on Apple Silicon--but they need to integrate plugins. I can't use the native version because it doesn't allow key plugins(formerly extensions) essential to my workflow. This is not dependent on developers, this is the responsibility of Adobe.

Idea No status
TOPICS
macOS

Views

22

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
2 Comments
LEGEND ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

Sadly, no. What you say is quite reasonable, and quite impossible. Plug-ins become part of the app, so if you have an M1 app, you need a plug-in that is built for M1. This is how the system works. So if you have essential plug-ins that are Intel you face stark choices, just as surely as if you had an app that only ran on Mac G4.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

LATEST

You can run the native M1 photoshop 20 such as ver 23.4.1 using Rosetta to run older plugins and extensions.

 

https://helpx.adobe.com/photoshop/kb/photoshop-for-apple-silicon.html

 

ex.jpg

Votes

Translate

Translate

Report

Report