Photoshop Elements 2021 Editor does not launch anymore

Community Beginner ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

After successfully using PSE 2021 for a few weeks, not the Editor doesn't launch anymore. 

Any idea how to fix this? 

 

Thank you  very much for your help. 

 

I use a Macbook Pro 2018 with macOS Mojave, 10.14.6 (18G7016)

TOPICS
Mac , Problem or error

Views

3.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 07, 2021 Jan 07, 2021
I fixed it by uninstalling and reinstalling the program. 

Likes

Translate

Translate
Community Beginner ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

I fixed it by uninstalling and reinstalling the program. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Could you please confirm the below details:

1. Is your Product Activated?

2. Do you see the Blue Color Splash Screen when you try to launch the Editor?

3. Have you tried launching it from Inside the Applications Folder -> Photoshop Elements 2021 -> Adobe Photoshop Elements Editor

4. Have you tried rebooting your system?

5. Please check if Adobe Photoshop Elements Editor is already running in Activity Monitor, if Yes -> Please kill it and then try again.

 

Regards

Vipin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

1.2.3.4.5. - yes to all your questions. Like I mentioned above, 

only uninstall and reinstall fixed it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

@VipinGupta 

See also:

https://feedback.photoshop.com/conversations/photoshop-elements/photoshop-elements-2021-editor-doesn...

 

I think you should rather suspect an issue linked with the new feature to use the Creative Cloud desktop in PSE2021.

In my case, I aldready have a subscription. The first time the editor refused to open, the Creative Cloud also refused with an error. Rebooting enabled me to log in again. However I had to uninstal and reinstal PSE like @heloado .

I would not be surprised if other PSE2021 users did uninstall the Creative Cloud desktop. There does not seem to be a difference between Win or Mac.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 30, 2021 Oct 30, 2021

Copy link to clipboard

Copied

For me, PSE 2021 worked fine with Big Sur but will open in Monterey only after I restart my iMac (the latest Intel machine). PSE then appears to work until I exit Editor or Organizer, at which time any attempt to restart either Organizer or Editor does nothing and I get a not responding message. I'm guessing that Adobe and Apple don't communicate very well when either company releases an update.This isn't the first time I have had problems upgrading PSE without any resolution by Adobe. I will certainly not try PSE 2022 until this is resolved. Maybe it's time to try another photo editor made by a company that cares.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

Hi,

 

This issue might be specific to your machine, as this has been working and we have not heard many customers reporting the same issue. One possible resolution could be to try uninstalling and reinstalling the application, Please remember to keep your preferences while removing the app, so you dont have to again set your preferences.

 

The installer can be downloaded from here if required: https://helpx.adobe.com/download-install/kb/photoshop-elements-downloads.html

 

Please let me know if the issue still persists.

 

Thanks

Vipin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

Thanks, Vipin. I tried uninstalling and reinstalling PSE Editor without success. I am hesitant to uninstall both Organizer and Editor (i.e., the whole suite) because the last time I had to do that when moving from PSE 2019 in High Sierra to PSE 2021 in Big Sur, I lost the connections between hundreds of edited photos and their originals and  gothundreds of incorrect connections when I tried to repair the catalog (maybe because several cameras over the years put identical photo names on pictures taken years apart). It took me months to fix the connection problems. If I uninstall and reinstall everything, will the catalog disappear as well even if I save the preferences? If I save a catalog, will it kee the proper connections? In any case, if past experience means anything, this almost seems like a corrupt preferences file is acting up. Since many people in the Community have reported the same problem I have had (that is, works once, then requires computer reboot to work again in both PSE 2021 and PSE 2022), it seems to me that a fix should come from Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

If you have only PSE installed and not PRE, and if you have already tried Uninstalling, it would have uninstalled EO as well and then again should have installed on reinstalling PSE.

The designed behaviour is that when you uninstall PSE, it will also uninstall EO along with it, if you do not have PRE also installed.

 

Could you confirm the steps that you followed to uninstall?

 

Just to ensure, the app needs to be uninstalled using the below button present inside Adobe Photoshop Elements 2021 -> Support Files. Please ignore the version 2022 here, as I have 2022 installed. The same would be available for 2021 also.

 

Screenshot 2021-11-02 at 9.11.22 AM.png

 

Thanks

Vipin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Thanks again Vipin. I also have PRE 2021, so Organizer stayed installed. I can uninstall everything next time. Again, though, will uninstalling PSE affect the catalog, especially the connections I asked about?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Completely uninstalling PSE (except for preferences) and PRE, followed by reinstalling PSE 2021, did not resolve problem. I still get only one chance to use PSE before I have to reboot iMac. Since I am using the latest Intel iMac and the latest macOS Monterey, this seems to be a problem for Adobe and Apple to work out TOGETHER.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Thanks for confirming, we are looking into this problem and confirm if there is a temporary workaround.

meanwhile, please try to keep the macOS updated with the latest updates available.

 

Thanks

Vipin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Same problem with PSE 2021 under Monterey on iMac M1.

Adobe Photoshop Elements 2021 starts, but Adobe Photoshop Elements Editor does not. It only bounces in the dock abd i need to force quit it. I have unistalled totally PSE 2021, download and reinstall. It works several times and freeze again. Under Big Sur, it was ok ! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

And now ... Adobe Photoshop Elements 2021 does not start ... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Me again ... after restarting my iMac M1 under Monterey, both Adobe Phtoshop Elements 2021 and Adobe Photoshop Elements launch. But this is not a solution if we need to restart the mac after using PSE .... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Ditto!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

I do have the same problem with PSE 2021 and Monterey (Imac 18.2). It has been working properly under Big Sur but not with Monterey anymore. Organizer starts, but Editor does not. Afer new installing PSE 2021 it works fine for just one time and the problem occurs as it was before. 

Many thanks for any solution or just a usefull workaround!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

I have the same problem with PSE 2022 and Windows 10. Unfortunately I installed 2022 because my 13 copy, clearly a bit old, was falling down all over the place. I also have managed to get the Editor to start twice, but cannot get the thing to run at all now. Possibly Adobe staff responding to this should remember we paid for the software.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

I actually have the same problem:  elements 2021 will not open since the Mac Monterey system was downloaded.  This really sucks.

J.  Scott

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Sorry to contradict you, Vipin, but I'm having the same exact issue as relhender.  PSE perfectly fine under Big Sur, not fine under Monterey.  Icon bounces but program doesn't load.  Sometimes doing a Force Quit and then restarting program it will load, but usually only a reboot will fix it...until the next time.  Not good.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

I am not very sure about the problem causing this issue, but if we are saying that a reboot solves the problem, I would like to recommend to check that even after closing the program - does it keep running in background in Activity Monitor?

 

If it does, that will prevent the next launch as the OS will detect an already running instance and would ignore the fresh launch request. 

 

If the above does hold true, Please kill the process from Activity Monitor and then try to launch.

 

Regards

Vipin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Hi again -

 

I ran Activity Monitor and saw PSE 2021 appear as it launched.  I then quit PSE, saw it go away in AM, tried to launch PSE again and got the bouncing icon.  PSE did, though, show up in AM but never fully launched.  Tried to do a Quit from AM but the only way out was to do a Force Quit with the bouncing icon.  There was a least one reboot in this troubleshooting.  

 

Hope this all makes sense.

 

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

When you face this issue, could you please try the below steps:

 

1. Go to folder: /Applications/Adobe Photoshop Elements 2022/Support Files/Adobe Photoshop Elements Editor.app/Contents/MacOS

2. There is an executable inside this folder named: Adobe Photoshop Elements Editor

3. Double click this executable to launch Editor

4. This should launch a terminal window and write launch logs in it while trying to launch the Editor.

 

Wait for the session to terminate and then copy and share those logs please, would be helpful to check the issue.

 

Thanks,

Vipin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Vipin - In PSE 21, the Editor file in the Spolrt Files folder must be opened using a right click to get to the Clontents folder. When I clicked the executable file, terminal opened and eventually reported the following. (I repalced my computer name with the text in all caps within brackets.) I don't know if it completed but nothing more happened after another 15 minutes or so. Hope this helps.

 

Last login: Wed Nov 10 21:36:56 on console

/Applications/Adobe\ Photoshop\ Elements\ 2021/Support\ Files/Adobe\ Photoshop\ Elements\ Editor.app/Contents/MacOS/Adobe\ Photoshop\ Elements\ Editor ; exit;

[MY COMPUTER NAME]@[MY NAMEs]-iMac-292 ~ % /Applications/Adobe\ Photoshop\ Elements\ 2021/Support\ Files/Adobe\ Photoshop\ Elements\ Editor.app/Contents/MacOS/Adobe\ Photoshop\ Elements\ Editor ; exit;

2021-11-11 22:50:55.075 Adobe Photoshop Elements Editor[9549:787443] (CEM): Initializing CEM framework...

2021-11-11 22:50:55.075 Adobe Photoshop Elements Editor[9549:787443] (CEM): Initializing Browser framework

2021-11-11 22:50:55.075 Adobe Photoshop Elements Editor[9549:787443] (CEM): Initializing Browser framework complete

2021-11-11 22:50:55.076 Adobe Photoshop Elements Editor[9549:787443] (CEM): Default configuration file URL is: file:///Applications/Adobe%20Photoshop%20Elements%202021/Support%20Files/Adobe%20Photoshop%20Elements%20Editor.app/Contents/Required/CEMConfig.xml, path is /Applications/Adobe Photoshop Elements 2021/Support Files/Adobe Photoshop Elements Editor.app/Contents/Required/CEMConfig.xml

2021-11-11 22:50:55.076 Adobe Photoshop Elements Editor[9549:787443] (CEM): Reading settings existing preference: on https://www.adobe.com/go/elements_live_18 http://www.live-elements.com

2021-11-11 22:50:55.076 Adobe Photoshop Elements Editor[9549:787443] (CEM): Parameters: Kill Switch is on and URL is https://www.adobe.com/go/elements_live_18 and ServerURL is http://www.live-elements.com

2021-11-11 22:50:55.076 Adobe Photoshop Elements Editor[9549:787443] (CEM): Scheduled config fetch task from server...

2021-11-11 22:50:55.076 Adobe Photoshop Elements Editor[9549:787473] (CEM): Starting config fetch task from url: http://static.photoshop.com/elements-content/19.0/elive/CEMConfig.xml

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Thanks for Sharing the logs, I upgraded one of my macbook to macOS 12 and started facing the same issue.

But I am able to launch the editor once in two attempts using the Executable file inside the package contents.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines