Problem opening PDF files in Elements 19 (and Elements 14!)

New Here ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

This issue is slowly driving me insane.

 

I'm on a desktop iMac running Mojave right now, using Elements 19, but this issue has been around ever since I upgraded to Elements 14 from Elements 10.

 

Sometimes--not always, but sometimes--I cannot open a random PDF properly. The first stage always seems fine:

 

Screen Shot 2021-04-20 at 7.55.47 AM.jpg

You can see the image just fine, so all seems well. But then I click on "OK" and get this:

 

Screen Shot 2021-04-20 at 7.56.26 AM.jpg

Nothing there...completely blank.

 

The kicker is that I then open Elements 10 and do the same thing, and THE FILE OPENS JUST FINE. So it is not an issue with the file itself. It's something about Elements 14/19.

 

Is anyone else seeing this issue??? Is there any solution other than enshrining Elements 10 on every future computer I own???

 

Thanks!

TOPICS
Bug, Import and export, Mac, Performance, Problem or error

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

Unfortunately, Elements stopped providing support to different varieties of PDF files.  I forget exactly when that was, but judging by your post, it happened with Elements 14.

Added:  For a fuller explanation see this post by MichelBParis.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

quote

Unfortunately, Elements stopped providing support to different varieties of PDF files.  I forget exactly when that was, but judging by your post, it happened with Elements 14.

Added:  For a fuller explanation see this post by MichelBParis.


By @Greg_S.

 

I don't know what is happening exactly in this case. I have never seen a difference between PSE10 and more recent versions to open various pdf flavours.

Does the file open normally in Acrobat Reader or other editors/browsers?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

LATEST

Have you tried restarting your mac to see if that makes a difference?

 

Seems to be an ongoing issue on the mac side since pse 11:

 

https://feedback.photoshop.com/conversations/photoshop-elements/elements-11-pdfs-from-nonadobe-softw...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines