Advice on workflow to non destructivly edit Tiff

Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

Hi everyone,

 

I am currently working with some TIF images. When I open them in Photoshop, the TIF files get loaded into Bitmap mode - 8bits. The only other available mode to change is Grayscale.

 

I need to crop them and erase the background. I was planning on using the crop tool with 'delete cropped pixels' unticked. The problem is this option is grayed out. Also, I can't add layers nor unlock my current layer.

 

I figured this is because of the file type. So, I decied to use File>Export>Export As and save my TIFas a JPG. I opened that and I can untick 'delete cropped pixels' and add layers as normal.

 

My question is:

Is this the correct way to go, that is, export as JPG? or am I missing something? I realized that changin mode to Grayscale also allows me to add layers, etc as normal. Maybe I should just do this instead of exporting as JPG and reopening?

 

Thanks in advance for your advice

Shynn

 

Adobe Community Professional
Correct answer by Conrad C | Adobe Community Professional

I think I figured out that part, It’s a little wonky, but here goes:

 

JPEG is not an option in File > Save As because Photoshop gets picky about the document being in a form that JPEG supports. JPEG apparently doesn’t support 1-bit images, so the only file formats listed in Save As are the ones that do support 1-bit images.

 

JPEG is an option in the Export submenu commands, even if the document is 1-bit. Does that mean they save a 1-bit JPEG? No, they can’t. So if you export a 1-bit document through the Export commands, although they accept it, they don’t tell you that they are converting it to 8-bit RGB on the way out so that they can be legal JPEGs.

 

Unfortunately you are starting with a 1-bit image and need metadata preserved, so you got caught in the different ways those commands work. You have a 1 bit image but you also need to preserve metadata, so the only path out is converting to Grayscale (8 bits) just to be able to see JPEG show up as a format in the Save As dialog box.

TOPICS
How to, Import and export, Windows

Views

80

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Advice on workflow to non destructivly edit Tiff

Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

Hi everyone,

 

I am currently working with some TIF images. When I open them in Photoshop, the TIF files get loaded into Bitmap mode - 8bits. The only other available mode to change is Grayscale.

 

I need to crop them and erase the background. I was planning on using the crop tool with 'delete cropped pixels' unticked. The problem is this option is grayed out. Also, I can't add layers nor unlock my current layer.

 

I figured this is because of the file type. So, I decied to use File>Export>Export As and save my TIFas a JPG. I opened that and I can untick 'delete cropped pixels' and add layers as normal.

 

My question is:

Is this the correct way to go, that is, export as JPG? or am I missing something? I realized that changin mode to Grayscale also allows me to add layers, etc as normal. Maybe I should just do this instead of exporting as JPG and reopening?

 

Thanks in advance for your advice

Shynn

 

Adobe Community Professional
Correct answer by Conrad C | Adobe Community Professional

I think I figured out that part, It’s a little wonky, but here goes:

 

JPEG is not an option in File > Save As because Photoshop gets picky about the document being in a form that JPEG supports. JPEG apparently doesn’t support 1-bit images, so the only file formats listed in Save As are the ones that do support 1-bit images.

 

JPEG is an option in the Export submenu commands, even if the document is 1-bit. Does that mean they save a 1-bit JPEG? No, they can’t. So if you export a 1-bit document through the Export commands, although they accept it, they don’t tell you that they are converting it to 8-bit RGB on the way out so that they can be legal JPEGs.

 

Unfortunately you are starting with a 1-bit image and need metadata preserved, so you got caught in the different ways those commands work. You have a 1 bit image but you also need to preserve metadata, so the only path out is converting to Grayscale (8 bits) just to be able to see JPEG show up as a format in the Save As dialog box.

TOPICS
How to, Import and export, Windows

Views

81

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 08, 2021 1
Adobe Community Professional ,
Jan 08, 2021

Copy link to clipboard

Copied

"save my TIFas a JPG. ...I can...add layers as normal."

 

JPGs don't support layers. When you save, you will have one Background layer with no transparency. Try saving as PSD. Does that work?

 

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

Hi Jane,

 

What do you mean they don't support layers?  I just meant that while working with JPG I can add additional layers to my PSD.

 

Like so: Note that I have 2 layers here working with a JPG

asfasfd.png

Instead, when I am working with a TIF I get this:

ShynnSup_1-1610135586534.png

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Adobe Community Professional ,
Jan 08, 2021

Copy link to clipboard

Copied

It's not a jpeg when it's open. A file format is a storage specification, it does not apply when the file is open. Then it's unpacked and just an image in memory.

 

So you can open a jpeg and add layers, but you can't save the layered file as jpeg. Then you need to flatten.

 

But the odd thing here is the missing options under Image > Mode. What kind of file is this, and where does it come from? I don't mean format, I mean what does it contain, what kind of data.

 

Can you post a screenshot of the Image Mode menu, and also the Layers panel? Screenshot, not phone photo -

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

"So you can open a jpeg and add layers, but you can't save the layered file as jpeg. Then you need to flatten."

 

I understand that, I don't want to save the layered file, no idea where you would get that idea from.

 

I already wrote on my OP that info:

 

"I am currently working with some TIF images. When I open them in Photoshop, the TIF files get loaded into Bitmap mode - 8bits. The only other available mode to change is Grayscale."

 

Oh, and I posted a phone photo because a screenshot would not capture the 'prohibition sign' icon that Photoshop displays when I hover the mouse over the New Layer button. Didn't you know that?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Adobe Community Professional ,
Jan 08, 2021

Copy link to clipboard

Copied

I was getting that idea from you. I was trying to answer your "What do you mean they don't support layers?"

 

But I can see this isn't going anywhere.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

 

Here you can see my panels. Like I said, only additional available mode is Grayscale. The mode is Bitmap. I can't add layers, nor unlock the only existing layer. It is all grayed out.

 

The image (which I replaced with a white plane) is a scan from a drawing. I need to crop it non-destructivly, but the option is also grayed out.

 

I have two options:

  1. Export as JPG and open it.
  2. Change mode to grayscale.

 

Both these options make all tools available again.

 

 

panels grayed out.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

What is even weirder is that once I change mode to Grayscale, all other modes become available. That is, if I want to change mode to RGB, I first need to change to Grayscale to then change to RGB. Pretty strange behaviour...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Adobe Community Professional ,
Jan 08, 2021

Copy link to clipboard

Copied

If you open an image and it shows up as Bitmap mode, then that is how the previous application saved it. Bitmap means one bit per pixel, which means no gray levels and no color — just black pixel on, or black pixel off, like the screen on the original Apple Macintosh in 1984. 1 bit per pixel is very minimal in today’s world of 14 bits per pixel camera sensors and 32 bits per pixel color images.

 

Today, a common source of 1-bit images is scanning software set to a mode like Black and White, Line Art, or something like that. Because as shown above, a 1-bit (Bitmap mode) image cannot store gray levels, colors, layers, masks, etc. Did the images come from scanning software, or another source?

 

The fact that the image is in Bitmap (1 bit per pixel) mode is why not much works in Photoshop when you leave the image in Bitmap mode. The majority of features in Photoshop operate on images that have 8 or more bits per channel, such as very common 8-bits-per-pixel RGB (three channel) JPEG images.

 

What is happening when you switch modes is that you are having the image slowly climb back up the ladder of image quality. Bitmap (1-bit) is the absolute lowest, so very few Photoshop features work on it. When you switch to Grayscale, you make the image 8 bits per pixel for one monochrome channel, so more features work, but not any features using color. When you switch from Grayscale to RGB, now you have 8 bits per pixel for three channels (RGB), so now nearly all Photoshop features work. At this point, the only Photoshop features that don’t work are the ones designed only for 16 or 32 bits per pixel images.

 

So the mode behavior you’re seeing is perfectly normal for many image editors. It’s how Photoshop has worked for over 25 years. As you’re seeing, change the image to Grayscale to make layers and other features available by giving the image more than 1 bit per pixel, then if you want, change the image to RGB to make color features available. Then, at the end, export to your final format such as JPEG or PNG — but understand that if the export file format you choose doesn’t support layers, the image will be flattened on export.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 3
Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

Shouldn't I be able change directly to RGB? Seems PS is still not smart enough.

Anways, that explains all of my current situation. Thank you. Indeed, yes, this is a scan I am working with.

 

I ended up using the workflow of changing to Grayscale and then to RGB.

 

The other method actually cuased me some trouble, because the option to 'Save As' JPEG was not available, so I decided to export to JPEG instead, big mistake. Resolution data erased, back to default 72PPI and that screwed the rest of my workflow which included importing my eddited images into a drafting software, which actually does care about PPI. So I had the original reference TIF at 400 PPI and the edited JPEG image at 72 PPI. Not good.

 

I ended up sticking to TIF all the way, simply changig the mode inside PS. Hope this is okay.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Adobe Community Professional ,
Jan 08, 2021

Copy link to clipboard

Copied

If you need to preserve resolution data in a JPEG file, use File > Save As and choose JPEG from the Format menu. Don’t use any of the commands on the Export submenu, because they’re designed to strip a lot of metadata to save space for web uploads. But Save As includes metadata such as pixels per inch, so it can be a better way to make JPEG files that are intended for print.

 

Edit: I’m not sure why Photoshop can’t go straight from 1-bit to 8-bit RGB; it could just be that they haven’t updated that part yet. It’s a reasonable thing to request, if you want to request it at the Photoshop Feedback site. I tried it in a non-Adobe competitor, but that program doesn’t offer a 1-bit option; it converts them to 8-bit RGB which would have worked fine for this. But Photoshop is able to preserve it as 1-bit in case that is what someone needs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Explorer ,
Jan 08, 2021

Copy link to clipboard

Copied

Yup, but the orignal TIF did not enable me to save as JPEG unless I changed the mode to Grayscale. So I did that to edit the image and then I decied to keep it as TIF to avoid compression. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 0
Adobe Community Professional ,
Jan 08, 2021

Copy link to clipboard

Copied

I think I figured out that part, It’s a little wonky, but here goes:

 

JPEG is not an option in File > Save As because Photoshop gets picky about the document being in a form that JPEG supports. JPEG apparently doesn’t support 1-bit images, so the only file formats listed in Save As are the ones that do support 1-bit images.

 

JPEG is an option in the Export submenu commands, even if the document is 1-bit. Does that mean they save a 1-bit JPEG? No, they can’t. So if you export a 1-bit document through the Export commands, although they accept it, they don’t tell you that they are converting it to 8-bit RGB on the way out so that they can be legal JPEGs.

 

Unfortunately you are starting with a 1-bit image and need metadata preserved, so you got caught in the different ways those commands work. You have a 1 bit image but you also need to preserve metadata, so the only path out is converting to Grayscale (8 bits) just to be able to see JPEG show up as a format in the Save As dialog box.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 1