Duplicated layers won't animate.

Explorer ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

I use this plugin/script that will let me turn a still image into an animated kaleidoscope. It will create a group with all the layers used for the animation. Sometimes, depending on the results, I want to do edits after the animation layers have been created. I was previously able to do things like increase the canvas size and duplicate the group with the animation layers and then arrange the groups in on the canvas so that they all play simulateously to create a tiled look to the animation.

However, this no longer works, and only the original group will animate and the duplicated groups are just stuck on the first frame for the duration of the animation. After some investigation I discovered that the original animation layer group would have the appropriate layer set as visible for each frame while the others that weren't supposed to show were hidden. The duplicated layer group does not seem to copy this anymore like it used to and now it just has the layers for the first frame set as visible for all frames.

 

I'm not sure if a recent update "broke" this, or if I accidentally changed some setting that is causing this to happen. Now I realize I can manually fix this by going into the timeline and selecting a frame and then setting the layers that are supposed to be visible for this frame, then rinse and repeat until I've gone through all the frames. But there are a lot of  frames and layers so it's not feasible to do this for each animation I make. Even recording an action to automate the process for me may take a fair bit of time, so I wanted to see if anyone here has any ideas for what went wrong and how to fix it so that the duplicated layer groups keep all the frame information from the original group like they used to before I spend all that time recording the action?

 

Furthermore, it now seems that unless I have all frames selected in the timeline, that trying to move a layer group from one part of the canvas to the another will only show that move in a single frame, and this was not something I had to worry about in past animations where I did this sort of edit. Again, I'm not sure if this is due to an update or if it's because of something I inadvertantly did. I can live with this if need be as it's not that difficult to select all layers, and it just takes time to get used to adding the step to my workflow, but if anyone has any insight into this issue, or the previous one mentioned, I'd really appreciate it.

I am using Photoshop 2021 with the latest updates and I'm on windows 10. Thanks in advance for your help.

PS: As a side note, I notice that when I duplicate a layer group, in the history panel it says "duplicate layer" and I'm fairly sure it used to say "duplicate group" when I was duplicating a group of layers. Now it's entirely possible that my memory is completely faulty on this point, but if I am correct that it's supposed to say "duplicate group" in the history panel, then perhaps this will provide an additional clue as to what's wrong.

TOPICS
Problem or error

Views

138

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , May 27, 2021 May 27, 2021
Of course after writing all of that out, I figured out what the problem was. I needed to duplicate the layer groups and do other edits after converting to a video timeline and not before. All seems to be working now. I can't see a way to delete my original post, but maybe this will help someone else facing a similar problem.

Likes

Translate

Translate
Explorer ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

LATEST

Of course after writing all of that out, I figured out what the problem was. I needed to duplicate the layer groups and do other edits after converting to a video timeline and not before. All seems to be working now.

I can't see a way to delete my original post, but maybe this will help someone else facing a similar problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines