Highlighted

'Edit Contents' on Smart Object goes straight into Illustrator and turns object into flat image

New Here ,
Nov 18, 2020

Copy link to clipboard

Copied

About a week ago when using Photoshop a message I had not seen before appeared from Windows when trying to edit a Smart Object  asked how I wanted to open the Smart Object which I selected Illustrator (as at the time the SMart Object linked straight to Illustrator). Now whenever I want to edit a Smart Object it opens Illustrator instead of opening the smart object in Photoshop, once opened in Illustrator it is 1 flat image layer also, has anyone expereinced this before? If so how do I change this.

 

Thanks!

Luke

Adobe Community Professional
Correct answer by D Fosse | Adobe Community Professional

OK, it seems you can't actually browse program files from here. You can only choose from the presented alternatives.

 

Then you need to locate an actual .PSB file somewhere, and right-click > Open With > Choose another app. If you still don't have PS listed here, click "look for another app on this PC" and navigate to the Photoshop.exe under Program Files > Adobe > etc.

 

There could be a bigger problem here if you updated to PS 2021 and then uninstalled 2020. That's a well-known problem that can hit some users. In that case you may need to uninstall and then reinstall again.

 

But try "open with" first.

TOPICS
How to, Problem or error

Views

47

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

'Edit Contents' on Smart Object goes straight into Illustrator and turns object into flat image

New Here ,
Nov 18, 2020

Copy link to clipboard

Copied

About a week ago when using Photoshop a message I had not seen before appeared from Windows when trying to edit a Smart Object  asked how I wanted to open the Smart Object which I selected Illustrator (as at the time the SMart Object linked straight to Illustrator). Now whenever I want to edit a Smart Object it opens Illustrator instead of opening the smart object in Photoshop, once opened in Illustrator it is 1 flat image layer also, has anyone expereinced this before? If so how do I change this.

 

Thanks!

Luke

Adobe Community Professional
Correct answer by D Fosse | Adobe Community Professional

OK, it seems you can't actually browse program files from here. You can only choose from the presented alternatives.

 

Then you need to locate an actual .PSB file somewhere, and right-click > Open With > Choose another app. If you still don't have PS listed here, click "look for another app on this PC" and navigate to the Photoshop.exe under Program Files > Adobe > etc.

 

There could be a bigger problem here if you updated to PS 2021 and then uninstalled 2020. That's a well-known problem that can hit some users. In that case you may need to uninstall and then reinstall again.

 

But try "open with" first.

TOPICS
How to, Problem or error

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 18, 2020 0
LEGEND ,
Nov 18, 2020

Copy link to clipboard

Copied

What have you done for trouble-shooting so far? 

Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point:

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

 

As a work-around you could try using

Layer > Smart Objects > Convert to Linked

and opening the resulting file/s directly. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 0
New Here ,
Nov 18, 2020

Copy link to clipboard

Copied

As a work-around you could try using

Layer > Smart Objects > Convert to Linked

and opening the resulting file/s directly. 

 

Unfortuantly a lot of the files I want to edit were copied from Illustrator straight into Photoshop rather than linking ot a specific file, therefore I can not access the original illustrator file without it being one flatened layer.

 

I will try resetting preferences to see if that does anything!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 0
LEGEND ,
Nov 18, 2020

Copy link to clipboard

Copied

If you pasted them as Smart Objects from Illustrator then they should get opened in Illustrator, I thought you were talking about pixel SO being opened in Illustrator. 

Could you please post a screenshot taken at View > 100% with the pertinent Panels (Layers, Channels, Options Bar, …) visible? 

 

»Unfortuantly a lot of the files I want to edit were copied from Illustrator straight into Photoshop rather than linking ot a specific file«

I did not speak about relinking the SO to some existing file but about converting it to a linked SO. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 0
Adobe Community Professional ,
Nov 18, 2020

Copy link to clipboard

Copied

My guess is that you did not have file associations for PSB set in you operating system. That's why it asked.

 

Go into Windows settings > Apps > Default apps > Default apps by file type and check your file associations for .psb and .ai:

ext.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 2
New Here ,
Nov 18, 2020

Copy link to clipboard

Copied

That seems to be the issue thank you for commenting, however when I try and change back to Photoshop I dont have the option?

 

Adobe Issue.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 0
Adobe Community Professional ,
Nov 18, 2020

Copy link to clipboard

Copied

OK, it seems you can't actually browse program files from here. You can only choose from the presented alternatives.

 

Then you need to locate an actual .PSB file somewhere, and right-click > Open With > Choose another app. If you still don't have PS listed here, click "look for another app on this PC" and navigate to the Photoshop.exe under Program Files > Adobe > etc.

 

There could be a bigger problem here if you updated to PS 2021 and then uninstalled 2020. That's a well-known problem that can hit some users. In that case you may need to uninstall and then reinstall again.

 

But try "open with" first.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 1
New Here ,
Nov 18, 2020

Copy link to clipboard

Copied

Thanks thats great, it worked! Appreciate the quick feedback.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 18, 2020 0