Highlighted

Fonts not recognised between computers - Even if fonts are installed

Participant ,
Sep 04, 2017

Copy link to clipboard

Copied

Hi, so I've searched the forums and it doesn't look like this issue has been covered.

I'm working with a co-worker on the same project. We both have all the fonts installed on our machines, from the same font files. Yet when one of us opens a PSD made by the other, the fonts aren't being recognised and get substituted for Myriad pro, even though the font is installed on the machine.

The workaround is to change one text layer back into the right font, and then go to type > resolve missing fonts *select font from list* and this changes them across the PSD. The thing is, when this file is then saved and then opened on the other machine, the font is now 'missing' on that computer?

This is incredibly frustrating and basically means we can't currently collaborate...

Anybody have any ideas?

Cheers

Thom

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Fonts not recognised between computers - Even if fonts are installed

Participant ,
Sep 04, 2017

Copy link to clipboard

Copied

Hi, so I've searched the forums and it doesn't look like this issue has been covered.

I'm working with a co-worker on the same project. We both have all the fonts installed on our machines, from the same font files. Yet when one of us opens a PSD made by the other, the fonts aren't being recognised and get substituted for Myriad pro, even though the font is installed on the machine.

The workaround is to change one text layer back into the right font, and then go to type > resolve missing fonts *select font from list* and this changes them across the PSD. The thing is, when this file is then saved and then opened on the other machine, the font is now 'missing' on that computer?

This is incredibly frustrating and basically means we can't currently collaborate...

Anybody have any ideas?

Cheers

Thom

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 04, 2017 0
Most Valuable Participant ,
Sep 04, 2017

Copy link to clipboard

Copied

What OS are you using.  Fonts Are installed into you OS from many files not a single package.  If you  use Windows check that the Windows Font folder on both machines have the same fonts installed.  It sound like your does not have a font your co-worker has and is using in Photoshop.

Capture.jpg

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2017 0
Participant ,
Sep 05, 2017

Copy link to clipboard

Copied

Hi - cheers for getting in touch so quick

Yeah unfortunately I don't think this is the issue. Both machines have the same font installed in all its weights from the same font files. The paths to the fonts are the same too.

what's more, once the fonts have been reselected, the other computer won't recognise the font again, so it will need reselecting again. It is very bizzare. I thought perhaps its the font file itself - Only one of the fonts in question is Open Sans, and i can't see that being the cause of the issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Most Valuable Participant ,
Sep 05, 2017

Copy link to clipboard

Copied

What OS are your machins running?  You machine and your co-worker's machine.  Font are install into your OS and not from a single package or file.  Fonts are not installed into Photoshop.  Are your systems up to date ? What versions of Photoshop are you two using, are they up to date?.   Please read the guidlenes here.

Supply pertinent information for quicker answers

  • The more information you supply about your situation, the better equipped other community members will be to answer. Consider including the following in your question:
  • Adobe product and version number
  • Operating system and version number
  • The full text of any error message(s)
  • What you were doing when the problem occurred
  • Screenshots of the problem
  • Computer hardware, such as CPU; GPU; amount of RAM; etc.
  • What Fonts are you using?
JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Participant ,
Sep 07, 2017

Copy link to clipboard

Copied

Hi

Both machines of equal spec, both running Windows 10, and both running Photoshop 2017.1.1

The error message is the creative cloud missing fonts popup which says "some font used in this document are missing..." etc

Computer hardware I'd imagine is irrelivent in this case, but just in case; both machines are i7-4790 @3.60GHz, 16gb ram, GeForce GTX 750 Ti cards with 2gb Vram

The fonts seem to be anything that was installed from Google fonts, so far Open Sans, Poppins, Playfair and a handful of others.

The weirdest thing for me is that it continues to go back and forth; If we replace the 'missing' font with the same font, the font is then 'missing' again on the original computer. If it is replaced again there, then again it will be missing on the second computer. 100% sure they are the same font files. Both machines have uninstalled and reinstalled from the same download.

Cheers

Thom

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2017 0
Most Valuable Participant ,
Sep 07, 2017

Copy link to clipboard

Copied

IMO your machine is missing a font installed on your co-workers machine.  You should compare his windows Font folder to you windows font folder and install the missing font on your machine.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2017 0
Participant ,
Sep 07, 2017

Copy link to clipboard

Copied

Hi Mack

Yeah I know its a tricky one to explain - but to be clear, we both installed the font from the same font file. Yet every time either of us replace the 'missing' font and saves the file, the other computer will have to replace the font again in order to edit it. Even if they've laready done it for that file before. Then if its replaced again for that computer, the other computer loses it again.

I know it sounds like an issue with the font, but I can't see how it can be since we installed from the same file, and they live in the same place on both machines. Its completely bazaar, but unfortunately makes it very difficult to collaberate...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2017 0
Community Beginner ,
Sep 07, 2017

Copy link to clipboard

Copied

Hi Thom,

It sounds like you have a font "linking" problem. It's a similar concept in InDesign. To explain - In InDesign, images aren't generally embedded in the file. Rather, you use image placeholders that reference it. If you delete or move the source image, you get a big X, and/or an error message.

If you are referencing web fonts, this might be the issue?

You have also used the word "downloaded", so, I am not sure if it's a font file on your system, or something that you are referencing from the web?

Maybe the font is corrupt?

Have you tried using a different font, across your machines, just to see if that works? Dup your file, make sure you have the same font installed across machines, and try it.

This way, you will know if either the font, or your file is corrupt (possibly).

Good luck!

- Daniel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2017 0
Participant ,
Sep 08, 2017

Copy link to clipboard

Copied

Hi Daniel

Yeah I'm afraid these aren't the issues. Genuinely don't mean to be rude but I think the majority of these questions have been anwered already. We have both installed the fonts from the same files downloaded from Google Fonts. They aren't web fonts we are referencing.

In terms of swapping the fonts, its weird as some fonts work fine and others don't. Open Sans is one of them, but again I can't see it being an issue with a really popular font like that.

The only thing I’ve found after digging further this morning, is when I go into a font’s properties and click on the details tab, under Font Embeddability it says ‘Editable’ on my machine, but ‘Installable’ on the other machine. So it miiiight have something to do with that...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2017 0
Community Beginner ,
Sep 08, 2017

Copy link to clipboard

Copied

Hi Thom,

Trash your Windows machines, and get Macs, lol!

It's "The ultimate upgrade", ya know. 😄

Just playing - just playing.

I know that these are basic questions...

1) Are you running the latest software on all machines?

2) Have you tried calling/e-mailing Adobe about this?

3) Are you near a Microsoft store? They are always super helpful.

Sorry, sir. I have never had this issue, and so, can't offer much more.

I sincerely hope that you can get this solved!

😄

- Daniel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2017 0
Participant ,
Sep 08, 2017

Copy link to clipboard

Copied

Hi Daniel

Ha! I wish! Im a Mac man myself, but alas, I'm tied to a PC here at work.

Yes all software up to date etc. Won't be able to take computers in store, however our internal IT rescource is taking a look too.

It may have something to do with this editable vs installable fonts afterall, which is linked to being / not being a local admin on the machines... will update when i know for sure.

Cheers

Thom

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2017 0
Community Beginner ,
Sep 04, 2017

Copy link to clipboard

Copied

Hey there, Thom,

I hope that this day finds you well.

Indeed. It looks like the same font isn't installed from computer to computer. There are two ways to fix this.

1) Copy and paste the fonts across computers, so that the file can access them.

2) Adobe's attempt to solve this problem is with Adobe TypeKit. Perhaps you can find a similar font in TypeKit, and use that?

Sincerely,

[Personal information removed by moderator.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2017 0
Contributor ,
Sep 04, 2017

Copy link to clipboard

Copied

Hi Thom,

I would like to know which operating system you are using?

Have you tried to change that font with another one and then choose your selected one again?

If you are using a Mac machine and you are using software like (Font Explorer) try to deactivate it and then reactivate it again.

Thanks,

Ahmed

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2017 0
Most Valuable Participant ,
Sep 07, 2017

Copy link to clipboard

Copied

Have you compaired the two font folders. Are the number of files the same on both systems and do all the files have the same name date and size and is installed?

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2017 0
New Here ,
Nov 03, 2020

Copy link to clipboard

Copied

A little late, but I was experiencing this same issue and luckily found a solution. In my case, this was happening in InDesign using Google Open Sans and machines running Windows 10 as well -- didn't test it out in Photoshop, but it seems like it might be a font registry issue, so could potentially apply to multiple Adobe apps.

 

Below are some potential causes I think might cause this missing font issue:
1. Having an older version of a Google Font previously installed, and then later installing/using a newer version

2. Installing the fonts via different methods (e.g. right-clicking on font, and selecting install vs install for all users)

 

Regardless of what triggers this issue, the problem seems to be that the font is installed in two different registry locations (or both if you've installed using multiple versions or using both install methods) and seems to cause an error with the font file associations from one machine to the other (possibly prioritizing one font version/location over the other and causing a mismatch).

 

The solution for me was to go to both of these locations in the registry and delete all of the affected fonts directly from in there and then reinstall the fonts (Note: uninstalling the fonts didn't work via Windows Fonts folder or Control Panel > Fonts; it would only uninstall one version of the font but leave the other) -- steps listed below:

 

Press Windows key+R to open Run window. Now, type “regedit” and hit Enter
Agree to enter the Registry Editor
Go to registry locations listed below and delete the affected fonts from the list of files.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Fonts

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Fonts

When you have deleted the files in both locations, return to the System Fonts folder and refresh.
The fonts should now be removed.
Reinstall the font(s) using a consistent method: Select fonts, right-click and click “Install for all users” (other parties would need to go though this process as well in case they are the ones who installed it differently, or you could try installing the font(s) using "install" on your end as well to try and match up with them)
Error should be resolved.

If the steps above resolve the issue, you may need to first turn off the "Windows Font Cache Service" and "Windows Presentation Foundation Font Cache 3.0.0.0" in the Services panel first before going through the steps above (I turned off the font cache to resolve my issue, but not sure if it was a relevant step in the process) -- I can provide instructions for that process as well if anyone is still experiencing this issue and the steps above don't resolve the issue on their own.

Thanks and hopefully this helps someone else out there encountering this frustrating issue!

Jason

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0
New Here ,
Nov 03, 2020

Copy link to clipboard

Copied

Not able to edit my post for some reason, but the last section should read: "If the steps above don't resolve the issue..."

 

Also, the numbered formatting for the instructions disappeared, but I'll correct if I can edit at a later time.

Jason

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2020 0