Highlighted

Photoshop brush delay + UI flicker using dedicated GPU - Windows 10

Community Beginner ,
Jul 24, 2019

Copy link to clipboard

Copied

Hi!

I'm noticing a few annoying artifacts on Photoshop and After Effects when using dedicated nVidia GPU.

There are basically 2 things I notice across both apps:

- Display delay: When using a brush on PS, or anything that makes quick changes on the canvas, the preview fails to show the end result, until I make a new interaction on the app. For example, if I make a quick stroke, sometimes the tip of the stroke is missing, until I click again on the canvas. I attach a video demonstrating this.

- UI flicker: The brightness of the gray area surrounding the canvas seem to flicker occasionally. This happens both in Ps and Ae.

These problems only occur when using the dedicated NVIDIA GPU (that is the default). If I switch to the integrated graphics card, I no longer encounter these problems, but I would like to make use of the full power of the dedicated card.

All my display drivers, Windows and Adobe software are up to date. !

This is my system:

Dell XPS 9570 - Core i7 8750H - 16GB RAM

Inte UHD Graphics 630

nVidia GeForce GTX 1050 Ti with Max-Q Design  (Driver v431.60 DCH-type)

Windows 10 Home 1903

Video showing the display delay issue on Photoshop (some brush stroke tips not previewing correctly):

Video showing the display delay issue on After Effects (textbox fails to show last letter until I click again):

For some reason the UI flicker doesn't show on the screencasts, so I filmed it. You can see in this video how the brightness of the main area of the UI flickers when I click on different places:

Message was edited by: Sahil Chawla

Adobe Community Professional
Correct answer by Ged Traynor | Adobe Community Professional

I have the same Windows 10 build and same version of Photoshop, did you try adding PS and sniffer.exe to the Nvidia control panel

Also give resetting PS preferences a shot

Views

685

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop brush delay + UI flicker using dedicated GPU - Windows 10

Community Beginner ,
Jul 24, 2019

Copy link to clipboard

Copied

Hi!

I'm noticing a few annoying artifacts on Photoshop and After Effects when using dedicated nVidia GPU.

There are basically 2 things I notice across both apps:

- Display delay: When using a brush on PS, or anything that makes quick changes on the canvas, the preview fails to show the end result, until I make a new interaction on the app. For example, if I make a quick stroke, sometimes the tip of the stroke is missing, until I click again on the canvas. I attach a video demonstrating this.

- UI flicker: The brightness of the gray area surrounding the canvas seem to flicker occasionally. This happens both in Ps and Ae.

These problems only occur when using the dedicated NVIDIA GPU (that is the default). If I switch to the integrated graphics card, I no longer encounter these problems, but I would like to make use of the full power of the dedicated card.

All my display drivers, Windows and Adobe software are up to date. !

This is my system:

Dell XPS 9570 - Core i7 8750H - 16GB RAM

Inte UHD Graphics 630

nVidia GeForce GTX 1050 Ti with Max-Q Design  (Driver v431.60 DCH-type)

Windows 10 Home 1903

Video showing the display delay issue on Photoshop (some brush stroke tips not previewing correctly):

Video showing the display delay issue on After Effects (textbox fails to show last letter until I click again):

For some reason the UI flicker doesn't show on the screencasts, so I filmed it. You can see in this video how the brightness of the main area of the UI flickers when I click on different places:

Message was edited by: Sahil Chawla

Adobe Community Professional
Correct answer by Ged Traynor | Adobe Community Professional

I have the same Windows 10 build and same version of Photoshop, did you try adding PS and sniffer.exe to the Nvidia control panel

Also give resetting PS preferences a shot

Views

686

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 24, 2019 0
Adobe Employee ,
Jul 24, 2019

Copy link to clipboard

Copied

Hi there,

That shouldn't be happening, let's make it right.

Could you please let us know the exact version of Photoshop and the operating system you're working on?

Also, could you try disabling the inbuilt gpu and then check if you experience the same issues with the dedicated gpu? Troubleshoot Photoshop graphics processor (GPU) and graphics driver issues


Have you checked if there is any update available for the dedicated graphics card?

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0
Community Beginner ,
Jul 24, 2019

Copy link to clipboard

Copied

Thanks guys.

Photoshop version is 20.0.5

OS is Windows 10 Home 1903 build 18362.239

I have the latest drivers for the graphic cards, there are no newest updated.

I was hoping that I woudln't need to disable the whole inbuit GPU in the BIOS, since that's the one that apparently is working right.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0
Adobe Community Professional ,
Jul 24, 2019

Copy link to clipboard

Copied

I have the same Windows 10 build and same version of Photoshop, did you try adding PS and sniffer.exe to the Nvidia control panel

Also give resetting PS preferences a shot

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0
Community Beginner ,
Jul 24, 2019

Copy link to clipboard

Copied

Hey Ged,

Apparently that worked!

First I added both PS and Sniffer to the Nvidia Panel, with no luck. But then I reset Prefs but also set the nvidia GPU as preferred engine in the global settings of the Control Panel.

Not sure what specifcally, but the overall config did the job (not).

After Effects still seem to be affected, but I will continue on that app forum.

Thanks for your help!

EDIT: It turns out it didn't actually work, the problem just seemed to disappear from a moment but then it was back, so I don't think I actually solved anything. The problem persists and I don't think there's a way to solve it. I'll just wait for the next updates to see what happens. In the meantime I'll have to stick with integrated graphics, rendering useless my purchase of a laptop with nvidia graphics card.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0
Adobe Community Professional ,
Jul 24, 2019

Copy link to clipboard

Copied

Hi

Can't reply about the After Effects issue so maybe you should post that query here After Effects , but for Photoshop have you tried adding Photoshop.exe and Sniffer.exe to the 3D settings in the Nvidia control panel.

I have the same card as you and don't experience any issues with brush lag, although I have my Intel GPU disabled in the BIOS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0
New Here ,
Aug 13, 2019

Copy link to clipboard

Copied

did you resolve this issue...cause I am having the same issue but I am using PS and LR this is the video I took.... also running xps 15 9750

https://www.youtube.com/watch?v=TohI4hkNUxAhttps://www.youtube.com/watch?v=TohI4hkNUxA

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2019 0
Community Beginner ,
Aug 18, 2019

Copy link to clipboard

Copied

Hey Andy,

No, I did not solve it. I settled by using integrated graphics.

I didn't expect this laptop to be so problematic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2019 0
New Here ,
Jan 02, 2020

Copy link to clipboard

Copied

Happens also in my laptop, which does not even have integrated graphics (due to G-sync disabling them) and a GTX 980. I see it happening not only on Adobe apps but also on other programs with a similar UI (I think they might have been done with Adobe XD). I don´t even know what is the issue but same here, only disabling GPU acceleration makes it go away. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 02, 2020 0
cablaz LATEST
New Here ,
Oct 02, 2020

Copy link to clipboard

Copied

Hey andrew I see that you are also looking for a solution to this problem. I have the same issue, did you ever find a solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2020 0