Highlighted

Photoshop CC 20.0.4 Brush Lag

Participant ,
Apr 13, 2019

Copy link to clipboard

Copied

Since Photoshop 20.0.4 came out I have a horrible brush lag.

I already reduced the mode from advanced to normal in Preferences, but it doesn't help.

Is this a known bug? It is so super slow that no matter how slow I move the brush, the lag is always there.

I wish Adobe wouldn't introduce new bugs with updates. Fewer updates - and without added "features" like this lag, which I didn't have before.

Views

4.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop CC 20.0.4 Brush Lag

Participant ,
Apr 13, 2019

Copy link to clipboard

Copied

Since Photoshop 20.0.4 came out I have a horrible brush lag.

I already reduced the mode from advanced to normal in Preferences, but it doesn't help.

Is this a known bug? It is so super slow that no matter how slow I move the brush, the lag is always there.

I wish Adobe wouldn't introduce new bugs with updates. Fewer updates - and without added "features" like this lag, which I didn't have before.

Views

4.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Apr 15, 2019

Copy link to clipboard

Copied

Hi Ocean2011,

Sorry that you're facing brush lag in Photoshop CC 20.0.4.

Are you using a tablet to draw in Photoshop? If so then, which tablet are you using and have you checked that tablet drivers are updated to latest version? If you're not using a tablet, then do you notice the lag while working with third party or custom brushes?

Couple of troubleshooting steps if you're using a tablet, that you can try to resolve the lag issue:

  • Follow the suggestions in Photoshop crashing due to libcef.dll.
  • Update to the latest version of your peripheral’s driver.
  • Try using Photoshop with a different peripheral unit.
  • Contact the manufacturer of your peripheral for additional support.

You may also restore Photoshop preferences to default, Please refer this article for instructions on how to restore Photoshop preferences:

https://helpx.adobe.com/photoshop/using/preferences.html#AdjustpreferencesinPhotoshop

Let us know how it goes.

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Apr 15, 2019

Copy link to clipboard

Copied

I'm working with a Wacom Intuos Pro S. This is the standard high quality tablet and Photoshop must be able to work with that.

I have updated the driver.

As I'm on a Mac, the first point doesn't apply.

The lag has not improved at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 16, 2019

Copy link to clipboard

Copied

Do you face the brush lag only while working with 3rd party brushes or even with the default Photoshop brushes?

Also, does the brush lags if you draw using your mouse instead of the tablet?

~Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Apr 16, 2019

Copy link to clipboard

Copied

I don't use third party brushes.

I no longer use a mouse. I don't even own one. For a photographer, it's a bad input device.

I have a top of the line Wacom tablet - which is the only way you'd want to edit and retouch.'

I have been using Wacoms since CS4 and never experienced anything like this.

I have the impression that the lag is worse when editing masks. I never use quick mask mode. I click the "\" key to get the mask visible.

Sometimes, the tile structure Photoshop processes in breaks open, and one tile looks not as the image looks.

Then I have to go one step back in history, and then forward again, until Photoshop catches up (other people have reported sluggishness of 20.0.4, but the brush problem is the only problem I have encountered on my  machine so far)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 22, 2019

Copy link to clipboard

Copied

Sorry about the delay in my response.

Could you please enable root user account on your computer and see if the issue still persists? See How to enable the root user on your Mac or change your root password - Apple Support

~Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 26, 2019

Copy link to clipboard

Copied

I have the same problem.

It only happens with Photoshop, and it happens even if i use the touch pad on the laptop. I tried that to check it wasn't the tablet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 26, 2019

Copy link to clipboard

Copied

I tried this and it didn't help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 14, 2020

Copy link to clipboard

Copied

Every time I install a new version of photoshop, I create a PSUserConfig.txt file in the user settings directory. Something like this on your machine:

 

C:\Users\{User Name}\AppData\Roaming\Adobe\{Photoshop version}\{Photoshop Version} Settings

 

The contents of the file should look like this for me:
 
# Use WinTab in PS CC for Wacom Tablet not Ink
UseSystemStylus 0
 
I just got a new machine with CC 2020, noticed the lag when using almost any brush, added the PSUserConfig.txt file with the above contents, problem solved.
 
# Transform CC 2019 scale mode unconstrained
TranformProportionalScale 0
#Don't warn when running a script. Added this so that I didn't have to click the "Yes" button when using the ZBrush to Photoshop plugin
WarnRunningScripts 0

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 26, 2019

Copy link to clipboard

Copied

Have you enabled Legacy compositing in the performance area in preferences? That helped me when I had issues

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 17, 2019

Copy link to clipboard

Copied

I enabled Legacy compositing and put it in Basic mode in Performance preferences and the lag is gone. I was using a mouse on my PC and first noticed the lag when using a Genius tablet, then found it also did it when using the mouse. Now it's gone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 09, 2020

Copy link to clipboard

Copied

I had this problem. For me, it was as simple as turning 'Smoothing' to 0%... I didn't realise this can cause severe brush lag

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 06, 2020

Copy link to clipboard

Copied

Yep, smootihng was my issue also.  Happened to me twice now and forgot that it caused the issue previously.  3 hours or searching and reinstalling software ect...lordy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 13, 2020

Copy link to clipboard

Copied

That worked for me perfect thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
hoelleoh LATEST
New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

works for me. but then you can't use the smoothing option, wich is quite helpful to not have a less "jumpy" line. 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...