Photoshop CC 2020 Slow Loading Layers

New Here ,
Nov 12, 2019

Copy link to clipboard

Copied

I just updated all my programs to 2020 and when I turn on and off my layers they take an oddly long time to load or load when I click on the art. The files are from 2019 I don't know if this is just a problem with the file.

TOPICS
Problem or error

Views

4.9K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2 Correct Answers

Community Beginner , Dec 07, 2020
themezly Community Beginner , Dec 07, 2020
As far as I can see here OP has asked about CC 2020 not 2019, and in 2020 the "Legacy compositing" has been disabled  Please provide an actual solution since this is the most ridiclous subscription I have signed up for. C6 blows 2020 blows out of the water. Here is my system and you can see in image above that CC should be able to handle anything with the assigned RAM and GPU power.   Who ever finds this post and has same issue, I opened new one here https://community.adobe.com/t5/photoshop/photoshop-cc-2020-extremly-slow-no-solution-in-sight/m-p/11658868?page=1#M491948

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional , Jan 16, 2020
kevin stohlmeyer Adobe Community Professional , Jan 16, 2020
Have you tried turning on Legacy compositing in Photoshop preferences?

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Employee ,
Nov 12, 2019

Copy link to clipboard

Copied

Hi there,

 

This is not a typical experience as Photoshop 2020 is slow at loading Layers, sorry to hear about this.

 

Could you please turn on the Legacy Compositing option in Performance preferences?
Choose Edit > Preferences > Performance (Windows) or Photoshop > Preferences > Performance (macOS). Select Legacy Compositing. Quit and relaunch Photoshop.
 
Let us know how it goes.
 
Thanks,
Akash

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 14, 2020

Copy link to clipboard

Copied

It does the same for me. Layer visibility toggle is useless (turning off and on has no effect). Loading an adjustment layer takes a long time. I had to revert to 2019 version and works fine. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 14, 2020

Copy link to clipboard

Copied

I had the same problem, I ended up reverting to the 2019 version. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 14, 2020

Copy link to clipboard

Copied

what are your computer specs? Mac/Win OS version, specific PS version, RAM, HD space, working off external, network or local?

How large is the file (both file size and pixel dimensions)?

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Mac Pro (Late 2013)

3 GHz 8-Core Intel Xeon E5

32 GB 1866 MHz DDR3

graphics AMD FirePro D700 6 GB

 

local. 

 

hd space 220 gb available of 1TB

file size 72m  3000 x 4000 pixels

 

I reverted to 2019 and for a while (a few hours), it seemed like it was OK, but now it presents the same problem.  Files are also very slow to save. I have been working with the same file sizes for years and never had a problem. 

 

I am running on Catalina.

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 16, 2020

Copy link to clipboard

Copied

Have you tried turning on Legacy compositing in Photoshop preferences?

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 16, 2020

Copy link to clipboard

Copied

The more I read threads like this - the common factor in all is Catalina. I don't have a concrete answer as to why it would (if it is) affecting performance, but it can't be ignored.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Yes, I believe all my computer's issues began with that upgrade. Waiting patiently for a fix. 

And, yes I turned on the Legacy compositing and it seems to have helped with the layer visibility. 

Thank you! 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
schroef LATEST
Engaged ,
Jan 22, 2021

Copy link to clipboard

Copied

Well im actually on Windows 10 20H2 with PS 21. I got an Omen 15 Ryzen 7 16gb RAM 1660Ti. I find this version very sluggish and slow. Starting photoshop and opening a document already show slow UI. when i have 2 docs open and close one. The UI seems to be freezing or not updating, it takes a few seconds to update the layers to the active document.

 

Now i noticed switch layer comps is super sluggish. At work im using an old Mac system running 2018cc, we cant upgrade due to the old system. There running 300+ layers and layercomsp is still smooth. Then on this Windows machine i tested ticking off "Layer comps for smartobjects" and voila layercomps switch fast again. I always wished for this feature, but in reality it doesnt seem to work properly. I get the feeling its actually reading all the links smartobjects which should not be necessary since that info is in the layer attributes or description. When i uncheck this option the layercomps switch instantly no lag lagg. The lag is awful its doesnt seem to be consistant in length but its about 20-30 seconds running 190 layers. I guess this time depends on the amount of linked smartobjects. Im working from an USB 3 drive and moticed it flashing, therefor my believes its actually reloading linked files. I also noticed that linked AI files get misplaced due to this behavior. I guess its choosign place option which is default and that ruins the design because it used a different place method.

 

Below is a screen recording. Notice the huge difference in speeds when smartobject check is OFF.

https://www.dropbox.com/s/6etbq1datb0tyat/slow-layercomps-with-linkedobjects-check.mp4?dl=0

 

Here's also a screenshot of the update issue with linked AI files, i guess same goes for PSD. When placing these files we can set the crop options. These options are i blieve not available on script level and due to that it placing by default behavior which is bounding box. I dont use that since its not precise and doesnt meet my needs. But this causing my design to jump around when i do use this "update smarrtobject selection". So thats another issue with this feature.

 

Placement AI files is updated wrongPlacement AI files is updated wrongOriginal placement AI files with artboardOriginal placement AI files with artboardPlcaec menh AI files(same for PSD) Cropt to causes issues when updating layercomps, it defaults to Bounding boxPlcaec menh AI files(same for PSD) Cropt to causes issues when updating layercomps, it defaults to Bounding box

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 06, 2020

Copy link to clipboard

Copied

Hello everyone,

 

Same issues here, in Photoshop 2019.

I tried both, "Legacy Compositing" and the "UnChecked" setting under the Preferences, Performance Options.

Turns out a "Layer FX" (Bevel/Emboss) was causing mag layer On/Off visibility lag.

Hope this helps.

 

-Berube

 

[website removed by moderator]

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 21, 2020

Copy link to clipboard

Copied

I'm having the same issue. my computer is kind of insanely good, so it makes no sense to me why 2020 would have any issues beyond just poor construction. No matter my file size, selecting and creating layers and groups will freeze up photoshop 2020, even empty layers.  Going to try 2019 again because it's taking me hours extra to do anything.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 28, 2020

Copy link to clipboard

Copied

I'm having the same issues, all of a sudden (following the Adobe latest updates + Nvidia Latest updates) Photoshop is insanely slow. Slow to open little files, slow to select layes or manipulate them, impossible to shift layers between open documents 😞
I've tried disableing the 3D acceleration and also tried reinstalling (clean install) the Nvidia Driver.
Nothing, it still legging. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 07, 2020

Copy link to clipboard

Copied

Same issues here.

Ryzen 3800x

32GB RAM

2070 Super

W will follow this topic.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 07, 2020

Copy link to clipboard

Copied

SAME HERE

im running these babies, which should have no problem editing anything at all

ryzen 9 3950x

32gb ram

titan

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 07, 2020

Copy link to clipboard

Copied

As far as I can see here OP has asked about CC 2020 not 2019, and in 2020 the "Legacy compositing" has been disabled

themezly_2-1607394572112.png

 

 

Please provide an actual solution since this is the most ridiclous subscription I have signed up for. C6 blows 2020 blows out of the water. Here is my system and you can see in image above that CC should be able to handle anything with the assigned RAM and GPU power. 

 

themezly_1-1607394540816.png

 

Who ever finds this post and has same issue, I opened new one here https://community.adobe.com/t5/photoshop/photoshop-cc-2020-extremly-slow-no-solution-in-sight/m-p/11...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more