Highlighted

Photoshop CS6 saves slices as jpgs rather than gifs

Participant ,
Mar 07, 2013

Copy link to clipboard

Copied

I have a psd image that is ~7000x7000 pixels and divided into ~800 slices.

I then:

  1. Choose File | Save for Web | GIF 128 No Dither (and leave the other options, like 128 olors, Transparency, etc at the defaults).
  2. Click Save (in the Save for Web dialog).
  3. Specify a file name (e.g., myfilename.gif)..
  4. Leave "Images Only", "Background Image", and "All Slices" selected.
  5. Click Save.

>>>The first file, myfilename_01.gif is saved as a gif. All of the remaining 800 slices are saved as jpgs (e.g., myfilename_02.jpg). This happens every time.

Any ideas? It sure seems like a bug.

Thanks.

After many hours of chatting with Adobe (who never could figure out what was wrong), I discovered that the Save For Web preset only affects the currently selected slice. I needed to:

  1. Choose File | Save for Web.
  2. >>>Drag the mouse in the Save for Web dialog so all slices are selected.
  3. Select the desired Preset.
  4. Save the file

Whew!

Views

19.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop CS6 saves slices as jpgs rather than gifs

Participant ,
Mar 07, 2013

Copy link to clipboard

Copied

I have a psd image that is ~7000x7000 pixels and divided into ~800 slices.

I then:

  1. Choose File | Save for Web | GIF 128 No Dither (and leave the other options, like 128 olors, Transparency, etc at the defaults).
  2. Click Save (in the Save for Web dialog).
  3. Specify a file name (e.g., myfilename.gif)..
  4. Leave "Images Only", "Background Image", and "All Slices" selected.
  5. Click Save.

>>>The first file, myfilename_01.gif is saved as a gif. All of the remaining 800 slices are saved as jpgs (e.g., myfilename_02.jpg). This happens every time.

Any ideas? It sure seems like a bug.

Thanks.

After many hours of chatting with Adobe (who never could figure out what was wrong), I discovered that the Save For Web preset only affects the currently selected slice. I needed to:

  1. Choose File | Save for Web.
  2. >>>Drag the mouse in the Save for Web dialog so all slices are selected.
  3. Select the desired Preset.
  4. Save the file

Whew!

Views

19.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 07, 2013 1
LEGEND ,
Mar 07, 2013

Copy link to clipboard

Copied

Does this also occur with smaller numbers of slices?

What have you done for trouble-shooting so far?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 1
Participant ,
Mar 07, 2013

Copy link to clipboard

Copied

  • It happens regardless of the size of the slices or images. E.g., I changed it so there were only four slices and PS6 output one gif and three jpgs. I changed the image size to ~200x200 pixels with four slices with the same results.
  • I tried outputting as PNG-8 128 Dithered preset and it output 1 gif and ~800 jpgs.
  • I saved as "HTML and Images" in addition to "Images Only."
  • I tried with the Settings (in the "Save Optimized As" dialog) set to "Default Settings" as well as "Background Image."
  • I tried outputting as GIF 32 Dithered preset.
  • I selected10 slices and outputting using the <save> "Selected Slices" option. Interestingly, it only output the first slice (e.g., myname_01.gif).

I'm truly stumped as to why jpgs are being created.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 0
LEGEND ,
Mar 07, 2013

Copy link to clipboard

Copied

I cannot reproduce this issue (13.0.4 on Mac OS 10.6.8).

Have you trashed Photoshop’s preferences yet and also the SfW preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 0
Participant ,
Mar 07, 2013

Copy link to clipboard

Copied

I first delete all of these folders to reset the Save for Web command:

  • C:\Users\MyName\AppData\Roaming\Adobe\Adobe Illustrator CS6 Settings\en_US\x64\Save for Web Settings
  • C:\Users\MyName\AppData\Roaming\Adobe\Adobe Illustrator CS6 Settings\en_US\x86\Save for Web Settings
  • C:\Users\MyName\AppData\Roaming\Adobe\Plugins\Adobe Save for Web CS6
  • C:\Users\MyName\AppData\Roaming\Adobe\Adobe Photoshop CS6\Adobe Photoshop CS6 Settings

When that didn't work, I started PS and pressed Ctrl+Shift+Alt which deleted all of the PS settings.

The problem remains.

Interestingly, of the 870 files that are created, the first and last files are gifs (and the rest are jpgs).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 0
LEGEND ,
Mar 07, 2013

Copy link to clipboard

Copied

Trashing Photoshop’s prefs can be done by keeping command-alt-shift/ctrl-alt-shift pressed while starting Photoshop (after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved and making a note of the Preferences one has changed).

The Save for Web Preferences one may have to remove manually, but their position depends on the OS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 0
Participant ,
Mar 07, 2013

Copy link to clipboard

Copied

I'm contacting Adobe Support (via Chat) to see what they say...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 0
Participant ,
Mar 07, 2013

Copy link to clipboard

Copied

The support rep had me confirm the existence of the *.irs files (which are the presets for the various formats). He had me choose the Optimize to File Size command (in the Save for Web dialog) and confirm that "Auto Select GIF/JPEG" was unselected (it was, and I don't think this dialog controls the output if you're using a preset, but it was a good guess). And ultimately, he had me uninstall and reinstall CS6 (ugh).

>>The problem remains. Groan.

I found this forum post (http://feedback.photoshop.com/photoshop_family/topics/wont_save_all_slices_in_same_format) where someone was having the opposite problem (the first and last files are jpgs and all the other files are gifs).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2013 0
Participant ,
Mar 11, 2013

Copy link to clipboard

Copied

After many hours of chatting with Adobe (who never could figure out what was wrong), I discovered that the Save For Web preset only affects the currently selected slice. I needed to:

  1. Choose File | Save for Web.
  2. >>>Drag the mouse in the Save for Web dialog so all slices are selected.
  3. Select the desired Preset.
  4. Save the file

Whew!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2013 3
Community Beginner ,
Jun 20, 2014

Copy link to clipboard

Copied

This is nuts!  I just had this happen with the new Photoshop CC 2014.  It kept saving ALL slices as GIFs!  I did the ">>>Drag the mouse in the Save for Web dialog so all slices are selected" thing and that worked, and it saved them all as .PNGs (which is what I wanted) EXCEPT the first slice!  ARGH!

I restarted Photoshop previously and THAT didn't help!  I saved a new image as a PNG and then tried to save for web with my original slices - which worked with the previous version - but that DIDN'T work with 2014!  I didn't bother to unistall and reinstall because when I have had this problem before THAT DIDN'T help!

Eventually got them all saved as PNGs by using the ">>>Drag the mouse in the Save for Web dialog..." method PLUS individually saving the 1st slice for web as a PNG!

DANG!  It shouldn't be that much work to get the program to do what you tell it to do!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2014 1
New Here ,
Nov 07, 2020

Copy link to clipboard

Copied

Apologies for necroing an old post, however, this is (believe it or not) still an issue today (Nov. 2020), and I wanted to share a simple workaround to avoid the first file being saved as a .gif.

Follow the same procedure as described before in the Save For Web Dialog:
- Zoom out to see all the slices
- Mouse click-drag to select all slices
- Apply desired export settings to the selected slices
- Click on "Save As..."
- It'll still have the .gif extension, but simply rename the extension as well in the save as dialog, and it'll save everything as the desired format, in my case I renamed from <file_name>.gif to <file_name>.png.

Hope this helps some lost traveler like myself 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2020 0
New Here ,
Sep 28, 2017

Copy link to clipboard

Copied

What a piece of crap is this software, getting worse with every damned version. Thanks for the suggestion of selecting them with the mouse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 28, 2017 0