Photoshop on macOS Catalina: Does not detect GPU

New Here ,
Jun 05, 2021 Jun 05, 2021

Copy link to clipboard

Copied

Hi
My com. is

Screen Shot 2021-06-05 at 10.36.03 AM.png

And in preferences Photoshop tell me

Screen Shot 2021-06-05 at 10.39.08 AM.png

It does not allow me to tick the section for my graphics card and this does not work in Photoshop.

And the resultant is

Screen Shot 2021-05-18 at 1.56.31 PM.pngScreen Shot 2021-05-18 at 1.56.23 PM.pngScreen Shot 2021-05-18 at 1.55.56 PM.png

And I do not know how to reinstall the display drivers.

But I use Illustrator, Lightroom, InDesign, Bridge, and Acrobat, and every program working perfectly.

Only Photoshop. Photoshop not working properly.

Please Help me.

 

Best regards

Cvetanka

 

TOPICS
Mac, Performance, Problem or error

Views

513

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Jun 06, 2021 Jun 06, 2021
This card is from a late 2013 imac.  Given that https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html requires a passmark of 2000 op/sec, the 755M is at 733. I'd suggest roll back Photoshop  to v22.3 or v22.2 if Deactivate Native Canvas does not work.

Likes

Translate

Translate
Adobe Employee ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

Hi Cvetanka,

 

Sorry that Photoshop does not detect the GPU unit on your Mac running the OS Catalina.

 

Which exact version of Photoshop are you using?

 

We are aware of an issue where Photoshop 22.3.1 is not properly detecting the GPU, please ensure that you are using Photoshop version 22.4.1(latest). See: https://helpx.adobe.com/photoshop/kb/uptodate.html 

 

In Photoshop 22.4 or 22.4.1 (May 2021), use of 3D features (Text extrusion, Lighting Effects, Normal Map and Bump Map filters) may not update the screen properly or render the correct results.  

We recommend using the Tech Preview option for overriding Photoshop’s native canvas mode to continue to use the 3D features.

 

Go to Preferences > Technology Previews, and check the item Deactivate Native Canvas, then restart Photoshop. 

 

Let us know if that helps.

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Hi Akash Sharma

Deactivate Native Canvas does not work but thanks for your help.

Have a good day.

Best regards

Cvetanka.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

This card is from a late 2013 imac.  Given that https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html requires a passmark of 2000 op/sec, the 755M is at 733.

 

I'd suggest roll back Photoshop  to v22.3 or v22.2 if Deactivate Native Canvas does not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

LATEST

Hi gener7

 

Thanks for your help.

I switch on v22.2 and now everything working.
Have a good day.
Best regards
Cvetanka

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines