Highlighted

Pixel Grid not showing on cc 2019

New Here ,
Aug 01, 2019

Copy link to clipboard

Copied

I'm trying to make some pixel art, however I can not seem to get my pixel grid to display, it just a white canvas. I have looked and looked but everything thing that i am finding to trouble shoot is already active on my PS file.

I already tired view>show>pixel grid and nothing shows up

I have also tired edit>preferences>advanced settings> and checked use openCL but its already checked and still nothing.

I have messed with the guides, grid, & slices by changing it to a different color and still no gird shows up just a white canvas.

I have also tried changing the graphics processor setting and still nothing.

has any one run into this issue and know why is not working?

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Pixel Grid not showing on cc 2019

New Here ,
Aug 01, 2019

Copy link to clipboard

Copied

I'm trying to make some pixel art, however I can not seem to get my pixel grid to display, it just a white canvas. I have looked and looked but everything thing that i am finding to trouble shoot is already active on my PS file.

I already tired view>show>pixel grid and nothing shows up

I have also tired edit>preferences>advanced settings> and checked use openCL but its already checked and still nothing.

I have messed with the guides, grid, & slices by changing it to a different color and still no gird shows up just a white canvas.

I have also tried changing the graphics processor setting and still nothing.

has any one run into this issue and know why is not working?

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 01, 2019 0
Most Valuable Participant ,
Aug 01, 2019

Copy link to clipboard

Copied

I believe the pixel grid should show when you zoom in to 500%+.  You can also display a grid over you image using menu View>Show>Grid or shortcut Ctrl+'  you set the size of the grid spacing in you Photoshop Preferences but that grid will not actually display a 1px with subdivisions. It more for showing a grid like a 100px grid or 1 inch grid. The menu item View>Show>Pixel Grid does not kick on till you zoom in to 500%.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2019 1
Adobe Community Professional ,
Aug 01, 2019

Copy link to clipboard

Copied

If you have only white, Background layer then try this:

  • create blank new layer above the Background layer
  • turn off visibility of white Background layer
  • you can change grid size from Preferences > Transparency and Gamut > Grid Size and you can zoom in using zoom tool
  • paint or do whatever you need to do
  • you can create as many blank new layer as you want
  • turn visibility of Background layer on/off  if you want to preview or check something
  • if you want everything merged on a single layer you can merge layers or to flatten the image whenever you want but do not rush until you are done and everything checked.

Edit: Here is my understanding of your problem: you can not see pixel grid when you have white or very light background color because grid lines which appears above 500% zoom level are very light, is that the case? Another fix is to add color layer above background layer what will allow you to see pixel grid and to work on separate layers above colored layer which can be deleted later if you need white background for your project.

Here is screenshot of the same document with the same zoom level where the only difference is bgr color.

pixel grid.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2019 0
Most Valuable Participant ,
Aug 02, 2019

Copy link to clipboard

Copied

The OP question was about the pixel grid. Photoshop only seen to display that grid when you have that menu item checked and you have zoomed in to more than 500%. At 501% zoom Photoshop starts to display the pixel grid on my machine.

Capture.jpg

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2019 0
Adobe Community Professional ,
Aug 02, 2019

Copy link to clipboard

Copied

Hello, you need to have a GPU enabled, check in edit>preferences>performance

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2019 2
Most Valuable Participant ,
Aug 02, 2019

Copy link to clipboard

Copied

Yes Zoom 501%+  and an Enabled GPU is required.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2019 0
New Here ,
Aug 30, 2020

Copy link to clipboard

Copied

but I had pixel grid in PS-2017cc now I updated to ps2020, I cant see pixel grid anymore. I dont have GPU. please help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 30, 2020 0
jeet5233 LATEST
New Here ,
Aug 30, 2020

Copy link to clipboard

Copied

setting for grid and guides option in preferencessetting for grid and guides option in preferenceseffect should come equal to square pixel, but its noteffect should come equal to square pixel, but its not

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 30, 2020 0
New Here ,
Jan 29, 2020

Copy link to clipboard

Copied

Thanks alot for your support.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2020 0
Community Beginner ,
Apr 09, 2020

Copy link to clipboard

Copied

^^^^^now this is information! Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2020 0