Re-saving PSDs with Maximize Compatibility

Community Beginner ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

I've been using Ps for decades. Before Lightroom existed, best practice was to turn "maximize compatibility" off to save space unless you needed compatibility with specific DTP programs. When Lightroom came along, best practice changed to turning "maximize compatibility" on. That left users like me with many files that couldn't be imported into Lightroom. Logic would suggest that simply re-saving these files after the "maximize compatibility" option was changed in Preferences would be enough to solve the problem. It is not. What do I have to do to get Ps to resave the files so they can be imported into Lr?

 

FWIW, I have tried re-sizing (w/o resampling) and saving. That didn't work. I've tried adding an empty layer. That didn't work. This process shouldn't be this hard. I'm looking for a fast, non-destructive way to do this without adding unnecessary size to the file. (I understand that maximizing compatibility necessarily increases file size. I'm talking about anything else.)

TOPICS
How to, Problem or error

Views

60

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Feb 24, 2021 Feb 24, 2021
When you do a Save As you can replace the original file so you won't have duplicates or different file names. I think you have to do a Save As to get the Maximize Compatibility option.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Have you tried grouping the older image files into a Smart Object and resaving, or saving with a different file name?

Have you started a similar thread in the Lightroom forum?

 

I know that one of the things that does not work unless you use max compatability is Displacement Maps.  I found that out the hard way some years ago.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

Hi Trevor.Dennis. I have not started a similar thread elsewhere. I have not been using the "Save as" approach because I'm trying to avoid creating duplicate files. This is not the first time I have encountered this issue and I'm sure I was able to find a solution by just re-saving but, for the life of me, I can't remember how I did it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

After turning on Maximize Compatibility did you use File>Save As to generate a new file or write over the old file?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

Hi Jeff. I've been saving. Not Saving as. I'm trying to avoid creating duplicates or messing up my file naming structure.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

When you do a Save As you can replace the original file so you won't have duplicates or different file names. I think you have to do a Save As to get the Maximize Compatibility option.


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

Of course! Thank you, Dan. That works perfectly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines