Highlighted

Unable to drag files into Photoshop CC

Community Beginner ,
Jan 10, 2017

Copy link to clipboard

Copied

I am running the latest version of Photoshop CC and Windows 10 64-bit.

Hi all, I've been having an issue for a while (since one of the recent updates, I cannot remember which) where I am unable to drag files from any location on my PC into Photoshop. Rather than the file opening (or being placed into an open document), the mouse cursor changes to a "stop" or "no" icon. I recorded a video of what it looks like:

I had temporarily solved the problem by doing the following (as per Google):

  1. I stopped running Photoshop as an administrator (which I had been doing as a means to 'fix' another problem I was having).
    • This did NOT work on its own. I went on to do the second step (below) as recommended in various Google results.
  2. I disabled the "Show Messages" option under Edit > Preferences > General > Show Messages.
    • This seemed like an odd 'fix' to me, but it actually worked! (Briefly).

Doing both those items worked and allowed me to drag files into Photoshop again, however, upon restarting my PC those fixes no longer worked and I am still unable to drag files in.

I suspect this issue has to do with permissions, however, I've reviewed my permissions on each of my hard drives and I have full control over everything, as far as I can tell.

Being able to drag files in from multiple locations is almost essential for my workflow so any help is appreciated!

Correct answer by moondoggo | Community Beginner

I found the solution!

Photoshop must not be running as an administrator-- this is what causes the drag and drop problem. I knew this already, but I thought I'd checked all of my permissions settings. It turns out that the taskbar shortcut had its own permissions settings, separate of the settings for the .exe itself. While the .exe was not set to run as administrator, the taskbar shortcut was. So, opening PS from the .exe (or from the Creative Cloud launcher) worked, but opening it from the taskbar caused the issue. When I was checking permissions settings earlier, I only checked the settings in the Compatibility and Security tabs, and completely forgot about the shortcut itself having its own permissions.

photoshop thing.png

So, solved!

Topics

Problem or error

Views

31.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to drag files into Photoshop CC

Community Beginner ,
Jan 10, 2017

Copy link to clipboard

Copied

I am running the latest version of Photoshop CC and Windows 10 64-bit.

Hi all, I've been having an issue for a while (since one of the recent updates, I cannot remember which) where I am unable to drag files from any location on my PC into Photoshop. Rather than the file opening (or being placed into an open document), the mouse cursor changes to a "stop" or "no" icon. I recorded a video of what it looks like:

I had temporarily solved the problem by doing the following (as per Google):

  1. I stopped running Photoshop as an administrator (which I had been doing as a means to 'fix' another problem I was having).
    • This did NOT work on its own. I went on to do the second step (below) as recommended in various Google results.
  2. I disabled the "Show Messages" option under Edit > Preferences > General > Show Messages.
    • This seemed like an odd 'fix' to me, but it actually worked! (Briefly).

Doing both those items worked and allowed me to drag files into Photoshop again, however, upon restarting my PC those fixes no longer worked and I am still unable to drag files in.

I suspect this issue has to do with permissions, however, I've reviewed my permissions on each of my hard drives and I have full control over everything, as far as I can tell.

Being able to drag files in from multiple locations is almost essential for my workflow so any help is appreciated!

Correct answer by moondoggo | Community Beginner

I found the solution!

Photoshop must not be running as an administrator-- this is what causes the drag and drop problem. I knew this already, but I thought I'd checked all of my permissions settings. It turns out that the taskbar shortcut had its own permissions settings, separate of the settings for the .exe itself. While the .exe was not set to run as administrator, the taskbar shortcut was. So, opening PS from the .exe (or from the Creative Cloud launcher) worked, but opening it from the taskbar caused the issue. When I was checking permissions settings earlier, I only checked the settings in the Compatibility and Security tabs, and completely forgot about the shortcut itself having its own permissions.

photoshop thing.png

So, solved!

Topics

Problem or error

Views

31.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 10, 2017

Copy link to clipboard

Copied

The fact that you were able to find similar issues on Google suggests a bug or conflict, but I would still be inclined to try resetting Preferences.  Or you could try starting Photoshop while holding down the Shift key to force third party plug-ins and extensions to be ignored.

If you still have the problem after that, paste your System Info to this thread (Help > System info > Copy).  That won't fix anything, but will allow other people with the same issue to compare their set up with yours.  I can tell you that I have not had this problem with CC and Windows 10.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 10, 2017

Copy link to clipboard

Copied

Thanks for the tips. I tried starting PS without third party plugins as you suggested, but that did not work. Resetting preferences also failed to solve the issue.

Here is my system info after I reset my preferences; hopefully this provides some insight.

Adobe Photoshop Version: 2017.0.1 20161130.r.29 2016/11/30:23:00:00 CL 1099099  x64

Number of Launches: 0

Version: 10 or greater

System architecture: AMD CPU Family:15, Model:2, Stepping:0 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX

Physical processor count: 4

Logical processor count: 8

Processor speed: 4013 MHz

Built-in memory: 32680 MB

Free memory: 2 MB

Memory available to Photoshop: 29458 MB

Memory used by Photoshop: 70 %

History Thumbnails: Enabled.

Touch Bar: Enabled.

Alias Layers: Disabled.

Modifier Palette: Enabled.

3D Multitone Printing: Disabled.

Highbeam: Enabled.

Image tile size: 1028K

Image cache levels: 4

Font Preview: Medium

TextComposer: Latin

Display: 1

Display Bounds: top=0, left=0, bottom=1200, right=1920

Display: 2

Display Bounds: top=0, left=-1920, bottom=1080, right=0

OpenGL Drawing: Enabled.

OpenGL Allow Old GPUs: Not Detected.

OpenGL Drawing Mode: Advanced

OpenGL Allow Normal Mode: True.

OpenGL Allow Advanced Mode: True.

AIFCoreInitialized=1

AIFOGLInitialized=1

OGLContextCreated=1

NumGLGPUs=1

NumCLGPUs=1

NumNativeGPUs=0

glgpu[0].GLVersion="4.1"

glgpu[0].IsIntegratedGLGPU=0

glgpu[0].GLMemoryMB=4096

glgpu[0].GLName="NVIDIA GeForce GTX 960"

glgpu[0].GLVendor="NVIDIA Corporation"

glgpu[0].GLVendorID=4318

glgpu[0].GLDriverVersion="21.21.13.7633"

glgpu[0].GLRectTextureSize=16384

glgpu[0].GLRenderer="GeForce GTX 960/PCIe/SSE2"

glgpu[0].GLRendererID=5121

glgpu[0].HasGLNPOTSupport=1

glgpu[0].GLDriver="C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2um"

glgpu[0].GLDriverDate="20161211000000.000000-000"

glgpu[0].CanCompileProgramGLSL=1

glgpu[0].GLFrameBufferOK=1

glgpu[0].glGetString[GL_SHADING_LANGUAGE_VERSION]="4.50 NVIDIA"

glgpu[0].glGetProgramivARB[GL_FRAGMENT_PROGRAM_ARB][GL_MAX_PROGRAM_INSTRUCTIONS_ARB]=[65536]

glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_UNITS]=[4]

glgpu[0].glGetIntegerv[GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS]=[192]

glgpu[0].glGetIntegerv[GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS]=[32]

glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_IMAGE_UNITS]=[32]

glgpu[0].glGetIntegerv[GL_MAX_DRAW_BUFFERS]=[8]

glgpu[0].glGetIntegerv[GL_MAX_VERTEX_UNIFORM_COMPONENTS]=[4096]

glgpu[0].glGetIntegerv[GL_MAX_FRAGMENT_UNIFORM_COMPONENTS]=[4096]

glgpu[0].glGetIntegerv[GL_MAX_VARYING_FLOATS]=[124]

glgpu[0].glGetIntegerv[GL_MAX_VERTEX_ATTRIBS]=[16]

glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_PROGRAM]=1

glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_PROGRAM]=1

glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_SHADER]=1

glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_SHADER]=1

glgpu[0].extension[AIF::OGL::GL_EXT_FRAMEBUFFER_OBJECT]=1

glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_RECTANGLE]=1

glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_FLOAT]=1

glgpu[0].extension[AIF::OGL::GL_ARB_OCCLUSION_QUERY]=1

glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_BUFFER_OBJECT]=1

glgpu[0].extension[AIF::OGL::GL_ARB_SHADER_TEXTURE_LOD]=1

clgpu[0].CLPlatformVersion="1.2"

clgpu[0].CLDeviceVersion="1.2 CUDA"

clgpu[0].IsIntegratedCLGPU=0

clgpu[0].CLMemoryMB=4096

clgpu[0].CLName="GeForce GTX 960"

clgpu[0].CLVendor="NVIDIA Corporation"

clgpu[0].CLVendorID=4318

clgpu[0].CLDriverVersion="376.33"

clgpu[0].CLBandwidth=8.03426e+10

clgpu[0].CLCompute=1069.4

License Type: Subscription

Serial number: 90970323845936773099

GUIDBucket:

  bucket: 141

  test: ReduceUXFriction

Application folder: C:\Program Files\Adobe\Adobe Photoshop CC 2017\

Temporary file path: C:\Users\shera\AppData\Local\Temp\

Photoshop scratch has async I/O enabled

Scratch volume(s):

  Startup, 465.2G, 298.8G free

Required Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CC 2017\Required\Plug-Ins\

Primary Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CC 2017\Plug-ins\

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 10, 2017

Copy link to clipboard

Copied

I've found a solution in a way, but it doesn't stick after a reboot so it's only temporary.

I uninstalled Photoshop (leaving my preferences intact), and reinstalled. It fixed the problem, however, after a reboot (having done NOTHING else other than confirm the issue was solved), I could no longer drag images into Photoshop again.

My only thought is, what could possibly change during a reboot that would cause Photoshop to behave differently afterwards?

Anyways, hope this provides some insight. I'll continue updating this thread if I discover anything new.

Edit:

Additionally, it seems like I am able to drag-and-drop into Photoshop just fine if I launch it from the actual .exe location rather than from my taskbar shortcut. I discovered this after my reinstall of Photoshop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 10, 2017

Copy link to clipboard

Copied

I found the solution!

Photoshop must not be running as an administrator-- this is what causes the drag and drop problem. I knew this already, but I thought I'd checked all of my permissions settings. It turns out that the taskbar shortcut had its own permissions settings, separate of the settings for the .exe itself. While the .exe was not set to run as administrator, the taskbar shortcut was. So, opening PS from the .exe (or from the Creative Cloud launcher) worked, but opening it from the taskbar caused the issue. When I was checking permissions settings earlier, I only checked the settings in the Compatibility and Security tabs, and completely forgot about the shortcut itself having its own permissions.

photoshop thing.png

So, solved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 20, 2018

Copy link to clipboard

Copied

thank you .... it's work good with me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 02, 2020

Copy link to clipboard

Copied

Thnx u ..
It's worked
but i uncheck run as administrator from "Advanced Properties"
and and run with out Run as Administrator

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 01, 2019

Copy link to clipboard

Copied

i have the same problem and none of this works for me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 18, 2019

Copy link to clipboard

Copied

As i was searching online as well since I've had the same situation after an update, and when  disable the "run phoshop as an administrator" doesn't work, try to disable the "skip transform when placing" under Edit > Preferences > General >

Hope it helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 12, 2020

Copy link to clipboard

Copied

Thank you, none of the other fixes worked but yours did!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...