Highlighted

Video not rendering as texture/surface of 3D object in Photoshop 2020

Community Beginner ,
Jan 28, 2020

Copy link to clipboard

Copied

Dear community

 

I found that video (mp4 file) is not rendering as texture/surface of 3D object in Photoshop 2020. I have used this feature many times before in other versions of Photoshop and for some reason is not working in PS 2020. The object applies only the image of the first video frame and it doesn't change it along the timelime. The same image appears stactic (as a still image, not a video) when I fully render it as well. I have reinstalled Photoshop, I have even reinstalled my whole Mac because of this - being trying to solve it for a month now with no luck. Is anyone having the same problem? Can you help me?

Adobe Community Professional
Correct answer by davescm | Adobe Community Professional

Hi

It's a while since I did this in Photoshop (I would normally use After Effects) and just tried in two versions v21.0.3 and v19.1.9, neither worked. So I tried back in V21 and it worked once and not since.

I'll try  again tomorrow to see if I can find out why/how it worked once

Dave

Topics

Bug, Mac, Problem or error

Views

418

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Video not rendering as texture/surface of 3D object in Photoshop 2020

Community Beginner ,
Jan 28, 2020

Copy link to clipboard

Copied

Dear community

 

I found that video (mp4 file) is not rendering as texture/surface of 3D object in Photoshop 2020. I have used this feature many times before in other versions of Photoshop and for some reason is not working in PS 2020. The object applies only the image of the first video frame and it doesn't change it along the timelime. The same image appears stactic (as a still image, not a video) when I fully render it as well. I have reinstalled Photoshop, I have even reinstalled my whole Mac because of this - being trying to solve it for a month now with no luck. Is anyone having the same problem? Can you help me?

Adobe Community Professional
Correct answer by davescm | Adobe Community Professional

Hi

It's a while since I did this in Photoshop (I would normally use After Effects) and just tried in two versions v21.0.3 and v19.1.9, neither worked. So I tried back in V21 and it worked once and not since.

I'll try  again tomorrow to see if I can find out why/how it worked once

Dave

Topics

Bug, Mac, Problem or error

Views

419

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Jan 28, 2020

Copy link to clipboard

Copied

Does it play correctly in the video time line or frame animation time line? A screen capture of PS layers palette and its time line would be helpful

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 28, 2020

Copy link to clipboard

Copied

This project is using the video timeline, it is not imported as animation but as video (mp4 file). The problem is that it just recognises the first frame creating a still image of that frame across the whole timeline. I attached a screenshot.Screenshot 2020-01-28 at 14.07.50.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jan 28, 2020

Copy link to clipboard

Copied

It looks like you have a sphere 3d object have you animated the mesh in the time line. I do not seem to have any problem doing that in the video time line. The Animation plays in the  time line and the exported mp4 works as well.

image.png

Earth Animated MP4 Photoshop 2020s

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 28, 2020

Copy link to clipboard

Copied

Thank you for your help. But the issue is quite different. The sphere you are showing here has a still image on it (as surface) and it is later animated (rotated in this case) as a 3D object. My sphere is still (not animated) but has a video as a surface (not a still image like yours). My image should show the video moving on the sphere and it doesn't - that's the problem. The material applied to my sphere is a mp4 video file and yours is a still image of the earth. I have done this with previous Photoshop versions and it is as easy as placing a still image. I am starting to wonder if it is a problem between Catalina (latest Mac version) and CC2020...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 28, 2020

Copy link to clipboard

Copied

See here for the video rendering issue in Catalina. Can you give that step a try and see if it affects your 3D issue

https://helpx.adobe.com/photoshop/kb/photoshop-and-macos-catalina.html

Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 28, 2020

Copy link to clipboard

Copied

Thank you Dave

 

I checked this Help doc earlier and did what it suggests - granted full access to PS2020 in the Privacy settings but the problem remains. I wonder if I should grant access to the whole CC2020 including flash?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jan 28, 2020

Copy link to clipboard

Copied

image.png

The part I do not understand is where your Sphere came from and how you applied a mp4 video material. When I open a MP4 video in Photoshop I get a Video group in Photoshop Layers palette with a Layer 1.  I do not get any 3D layer in the layers palette.  Your layers palette is covered by the your 3D palette that shows you do have a 3D Layer as does your image window.  Where did the 3D layer come from. I do believe a 3D object surface material may be a video.  I do not know the steps one could accomplish that in Photoshop. What steps did you do.  How was the mp4 rendered for a sphere's surface.

image.png

3D is to complex for my tired brain... I took one look at Blenders UI and then un-installed Blender.

 

 

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 28, 2020

Copy link to clipboard

Copied

Hi

It's a while since I did this in Photoshop (I would normally use After Effects) and just tried in two versions v21.0.3 and v19.1.9, neither worked. So I tried back in V21 and it worked once and not since.

I'll try  again tomorrow to see if I can find out why/how it worked once

Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 29, 2020

Copy link to clipboard

Copied

Thank you Dave. That is very kind of you. I feel better now knowing I am not the only one to whom this is happening. Most likely it is a bug and I am sure Adobe will fix it soon enough. Please just let me know what happens on your side - how does the file behave in the timeline so that I am sure it is the same problem.

 

Thank you again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jan 28, 2020

Copy link to clipboard

Copied

is it possible to share this file for testing?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 18, 2020

Copy link to clipboard

Copied

Having the same problem! Any animation .mp4 or just native animation made inside texture window is not rendering on the main 3d mesh. It just displays the still from where the timeline was, when closed the texture editing window. Did you manage to solve this? I tried both cc 2019 and cc2020 on Win. Same...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 08, 2020

Copy link to clipboard

Copied

Same issue for me that i just spent a day attempting to work out.  TBH it was only raised 9 months ago so you can't expect this bug to be fixed for a while yet - especially if its mac only.  My guess would be around late 2022. 

It doesnt appear to work on any of the legit versions that i've downloaded from creative cloud.  Can anyone point me in the direction of a warez copy of an older version with a registration key cos it appears that the only way to achieve this is by downloading a pirate copy.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...