• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Before I give up on Elements for good, can anyone suggest how to fix these glitches please?

Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

I've been using an earlier version of Elements for the last 5 years and it was great, I created over 1000 YouTube videos. But I thought it was probably time to upgrade, so I bought Elements 2022. Some of my videos are quite complex with 50 - 150 segments of B roll.

Here are some of the issues.

  • If I use any of my older video as B roll, there is an awful metalic looking fuzz as the video goes back to 4K footage. 
  • I cannot use static images as B roll for the same reason.
  • Transitions cause the same issue as shown below.
  • Occasionally if I use 4K B roll on the Video 2 line, it will also do the metalic fuzziness. So I now have to cut each section of B roll and then cut the Video 1 line, delete the A roll video (leaving the sound in place) and insert the B roll into it.

I have updated my computer's graphic card driver as kindly suggested by someone in this community.

Does anyone have any other ideas before I go back to the earlier version or give up on Elements altogether?

Many thanks, 

Liz

 

TOPICS
Error or problem , Performance

Views

108

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

I can't imagine why you are seeing any of those issues. Especially if you were doing fine with version 15. The basic function of the program has not changed that much in the last five years.

 

It might be worth trying another program. Premiere Pro is an excellent alternative, if you don't mind a subscription-based purchase. Otherwise, for a one-time purchase, CyberLink PowerDirector might be worth a try.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

I have to add to Steve's reply that I don't see any "metallic looking fuzz" in my system.  There must be a setting or some other mismatch somewhere.   What process did you use to update the graphics card driver and which driver?

 

Switching brands can be a lot of fun, but the learning curve can be steep enough to absorb a lot of time.

 

Are you the Byther Farm producer?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Hi Bill, I updated the graphics card driver by going to Nvidia website and downloading the latest version for my Geforce RTX for Projects, or whatever it's called that is NOT for Gaming.

Yes, I am Byther Farm (presenter, film maker, producer, editor, gardener and everything else!) My most recent video (still uploading) took me 18 hours to edit because of the glitches in my Elements software.

- Liz

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Does it appear in the exported file?

 

If not, just a shot in the dark:

Try a different video cable from the computer to the monitor.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

Hi Peru Bob, it doesn't appear on the timeline, only once it's been exported. So my frustration is that I have to wait an hour or more for it to export to discover whether that video has the problem, then make an adjustment and wait another hour while it exports again to see if it's fixed. In my latest video, I did this six times and it was only fixed when I took out all of the static images and non 4K footage.

I'm using a laptop (built purely for video editing), so no cables to change sadly.

Kindest,

Liz

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

LATEST

I think it's definitely time to move on to another editor. Worst case, you find out the issue is with your source media. Best case, you find the next editor has none of these issues.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines