• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

? Premiere Elements on Mac won't open up

New Here ,
Oct 31, 2018 Oct 31, 2018

Copy link to clipboard

Copied

I have Premiere Elements on a Mac and it has worked fine. Today though when I clicked on the icon, the welcome page opened up fine but when I clicked on the file to be opened, the icon appeared for about two seconds and then disappeared.  I can't get the program to run. Any suggestions? Thanks.

Views

219

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2018 Oct 31, 2018

Copy link to clipboard

Copied

Versions of Premiere Elements and your operating system?  Available RAM?  Anything running in the background like an antivirus?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 31, 2020 Jul 31, 2020

Copy link to clipboard

Copied

LATEST

I am having the same problem - did you get yours resolved?  I am still using OS 10.12.6 - I was thinnking of upgrading to 10.15 - in hope it would resolve the problem - but now read that had discontinued support for 32bit applications, and while  PE is stated to be 64bit it still has some 32bit routines which stop it from working. I have OE 2018 which worked fine to begin with - and only premiere has stopped working.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines