Highlighted

Preview panel in Premiere Elements 11 not working

New Here ,
Feb 26, 2020

Copy link to clipboard

Copied

I'm having problems with Premiere Elements 11 on my laptop running Windows 10. Graphics is AMD Radeon HD 8200 / R3 series with fully up-to-date driver.

 

I've only started using this Photoshop Elements in the last few months. The videos have always been 'choppy' - they play fine in other players. But now, when I'm making a project, the preview panel is blank. The audio plays normally, and I can see a still when I pause it - bu blank when playing, which makes proper editing very difficult.

 

I came across an old thread with the exact same symptoms, https://community.adobe.com/t5/premiere-elements/preview-panel-in-premiere-elements-10-stopped-worki... but the answers suggest that this was very specific to Elements 10 and Nvidia graphics card, which is not my situation.

Any help sorting this very gratefully received -so much the better if offered in 'For Dummies' language!

thanks

Mark

TOPICS
Error or problem

Views

97

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Preview panel in Premiere Elements 11 not working

New Here ,
Feb 26, 2020

Copy link to clipboard

Copied

I'm having problems with Premiere Elements 11 on my laptop running Windows 10. Graphics is AMD Radeon HD 8200 / R3 series with fully up-to-date driver.

 

I've only started using this Photoshop Elements in the last few months. The videos have always been 'choppy' - they play fine in other players. But now, when I'm making a project, the preview panel is blank. The audio plays normally, and I can see a still when I pause it - bu blank when playing, which makes proper editing very difficult.

 

I came across an old thread with the exact same symptoms, https://community.adobe.com/t5/premiere-elements/preview-panel-in-premiere-elements-10-stopped-worki... but the answers suggest that this was very specific to Elements 10 and Nvidia graphics card, which is not my situation.

Any help sorting this very gratefully received -so much the better if offered in 'For Dummies' language!

thanks

Mark

TOPICS
Error or problem

Views

98

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 26, 2020 0
New Here ,
Feb 26, 2020

Copy link to clipboard

Copied

PS I also get this message on start-up: "We have detected an incompatible display driver. To get a better and faster playback performance, please update your display driver" There then follows details of my AMD display driver

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2020 0
Explorer ,
Feb 27, 2020

Copy link to clipboard

Copied

You could try to delete the Baddrivers.txt file in programdata/Adobe/premiere elements/11.0

In my case it solved the 'incompatible display driver' problem. Note you need to have access

to hidden files in windows explorer.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2020 0
New Here ,
Feb 27, 2020

Copy link to clipboard

Copied

Thanks, I'll give that a try.

After posting I found this https://www.youtube.com/watch?v=iOzG8Roh8bU as a temporary workaround. This works for me, it addresses both the error message and blank monitor panel issue - but I have to re-do it every time I open APE11! So not a long-term solution.

Many people have been having a problem with Adobe Premiere Elements, and the occasional display driver error. Here is a work around that's more like a soluti...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2020 0
Adobe Community Professional ,
Feb 26, 2020

Copy link to clipboard

Copied

Premiere Elements 11.0 was released in September 25, 2012.  Your version of Windows 10 and your AMD Radeon driver are so much newer there could be a mismatch.  I can't guess how AMD does it, but you might try backdating to a much older driver.   

You can try a newer version of Premiere Elements with no cost.  If that works, maybe paying for the updated software might be worth it. 

Regarding the choppy play, common players need to do little work at all.  Editing software had to do a lot of work generating the previews and creating the files with your edits.  It takes a much stronger computer to edit than to play videos.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2020 0
New Here ,
Feb 27, 2020

Copy link to clipboard

Copied

Thanks for this. As I just posted above, I've come across a temporary workaround, but not a long-term solution.

 

I had indeed considered upgrading to a more recent version. In the first instance I'd rather find a solution that doesn't require that. I've become reasonably competent doing what I need to do with Elements 11, so reluctant to start again learning a much newer version which probably looks very different. I'm not very techy!

Similarly, I wouldn't know how to begin rolling back to a 7 year-old version of the AMD driver.

I agree the choppy playing is probably just a symptom of the limitations of my laptop. I mentioned it in case if was part of a wider pattern of symptoms that someone had come across before.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2020 0