Index missing from published output

Community Beginner ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

Hello 🙂

 

I'm using RoboHelp 2020.7.46, working with a project consisting of 1 master and 2 child projects. These are set up as prescribed on Peter Grainge's site. I have indexed some of the topics in both child projects, and when I generate and do a test publish to a local directory everything displays correctly:

Index Visible.PNG

 

When I publish to our server, however, the index disappears.

Index Missing.PNG

Between the test local publish and the live server publish, I've made no changes to the output preferences other than the directory to which it should publish. I think there must be something I've done or something in my setup not allowing the index to publish to the live server, as it was always present in previous versions of live. Any suggestions greatly appreciated! 🙂

 

Thanks,

Mikey

Views

83

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 30, 2022 May 30, 2022

A file system transfer should be fine (that's how I'm doing it) although I think FTP has better recovery built in, in case of network glitches.

 

Does the problem occur with only one browser or different browsers (Chrome, Firefox?)

 

You could use a file comparison tool to like Beyond Compare to compare your generated directory with your published directory, to see if something went wrong with the file copy.

Likes

Translate

Translate
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

My first guess would be how you are publishing. Which option are you using for the live server, File System, SFTP etc.

 

I always use SFTP unless publishing to my machine for some reason.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

I'm using File System to publish for both my local test and the live server, as the server is mapped as a network drive on my machine. I've never used any of the other options tbh. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

I'm not sure that having access means you can publish there using the File System. If that is what you have used before, then it should still work unless IT have changed your permissions.

 

I think it's worth speaking to them and trying SFTP.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

A file system transfer should be fine (that's how I'm doing it) although I think FTP has better recovery built in, in case of network glitches.

 

Does the problem occur with only one browser or different browsers (Chrome, Firefox?)

 

You could use a file comparison tool to like Beyond Compare to compare your generated directory with your published directory, to see if something went wrong with the file copy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

I agree that file transfer should be fine. I suggested using another method in the hope it got round whatever is the issue. 

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

Thanks both for the suggestions. I'm trying to get SFTP set up with our IT dept as I think this is probably one of the causes. Since I have to be connected to the corporate network to access the server, and this is achieved through VPN, I don't think the connection is the greatest. 
The file comparison software worked a treat and it highlighted quite a lot of files which hadn't been updated when I had published to the live server, but had been on the local version. Once I copied them all across the index worked perfectly. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

LATEST

Thanks again for the suggestions, both. It was caused by files missing from the final output. Publishing them as a filesystem is the way I was shown, but hopefully I can get FTP set up and get it running that way. In the meantime I'm using Beyond Compare to make sure everything copies correctly. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp