Highlighted

Internet Explorer restricted this webpage from running scripts or ActiveX controls

Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi guys,

When I run my help application, developped with RoboHelp 11 using Responsive HTML5 layout, I have the Ms-Internet Explorer message: 'Internet Explorer restricted this webpage from running scripts or ActiveX controls' If I click on 'Allow blocked content...', that message disappear, and everything works fine. But I want to find a way not showing this message.

Thank you for your help.

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

@Jeff Your client should not see the message if the help is on a web server. If they do, it suggests to me the server is a file server. Different configuration.

@debra Go to Internet Options > Advanced Tab and scroll down to security. Tick Allow Active Content to run in files on My Computer. Your clients should only see the warning if the help is anywhere but a web server. On a web server, they should not see it.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

TOPICS
HTML5 layout

Views

5.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Internet Explorer restricted this webpage from running scripts or ActiveX controls

Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi guys,

When I run my help application, developped with RoboHelp 11 using Responsive HTML5 layout, I have the Ms-Internet Explorer message: 'Internet Explorer restricted this webpage from running scripts or ActiveX controls' If I click on 'Allow blocked content...', that message disappear, and everything works fine. But I want to find a way not showing this message.

Thank you for your help.

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

@Jeff Your client should not see the message if the help is on a web server. If they do, it suggests to me the server is a file server. Different configuration.

@debra Go to Internet Options > Advanced Tab and scroll down to security. Tick Allow Active Content to run in files on My Computer. Your clients should only see the warning if the help is anywhere but a web server. On a web server, they should not see it.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

TOPICS
HTML5 layout

Views

5.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 13, 2017 0
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 1
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Jeff,

Thank you so much for your reply!!

I looked at the thread!! First I checked the update and it's saying all apps are up to date. The robohelp version that I'm using is : 11.0.4.291

Then I went through Tools > Internet Options > security > trusted sites and I added the address that is popping after running my help application and unchecked 'Required server verification (https:) for all sites in this zone' but an error pops up that is saying ' You have entered an invalid wildcard sequence' It seems my path is not acceptable, right? the path is in my C drive somewhere....

Cheers,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

For a local c:\ drive I just use:

file://c

(that's "file" "colon" "two forward slashes" "letter c") in case it gets messed up in the forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Oh Okay!!

I added file://c and generated one more time and open with IE but still the message pops up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

Hmm, I'm getting that warning too when I launch the sample projects in either WebHelp or Responsive HTML5 on my local folder. I wonder if IE11 has tightened things up even more. Since it's really a browser security issue, there's not too much that Adobe can do about it I suspect. Is your help locally installed "in real life?"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

There is an IE setting to allow Active X to run. No good for end users

unless you control their PCs. Solves problem for authors.

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Yes it's installed locally in clients' machines. Is it true that the error will pop up unless the content is rendered from a server?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Peter, Are you talking about ActiveX Filtering in Tools?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

It's a warning, not an error - it's Microsoft trying to protect you from local html files - it has to be coming from a web server to not appear. Our help is installed on our client's server (in a folder) and they get it happening too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 1
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

You are right it's warning not error! Okay I just want to make sure that there is no way to disappear this warning with responsive html5 output when it is locally installed.

Thanks Jeff!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 0
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

@Jeff Your client should not see the message if the help is on a web server. If they do, it suggests to me the server is a file server. Different configuration.

@debra Go to Internet Options > Advanced Tab and scroll down to security. Tick Allow Active Content to run in files on My Computer. Your clients should only see the warning if the help is anywhere but a web server. On a web server, they should not see it.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2017 2
Community Beginner ,
Feb 14, 2017

Copy link to clipboard

Copied

Peter thank you so much! You actually solve my issue in a way that I can add this setting to our software installation guide so that clients can set it while they are installing the software.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2017 0
Adobe Community Professional ,
Feb 14, 2017

Copy link to clipboard

Copied

@Peter – yes, it’s a LAN server, so browsers all consider it the same as your C:\ drive

@debrah – I don’t know about your clients, but mine get really cranky when we tell them to relax their security – much easier to tell them to continue to click the “Allow” button

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2017 0
Community Beginner ,
Feb 14, 2017

Copy link to clipboard

Copied

It's true, but they always complain about this warning, we are gonna go ahead and give this solution to them and wait for  feedbacks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2017 0
Adobe Community Professional ,
Feb 14, 2017

Copy link to clipboard

Copied

So tell them to put the help on a web server if they can.

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2017 1