Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How to properly open 3D models

Explorer ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

Hi,

I am new to Painter.
I am trying to import 3D text from Adobe stager to Painter.
In stager I select and export the object, as GLFT, and open it, in a new set in Painter.

BTW, exporting as OBJ shows the same behavour.

Before & After I bake the texture, when i try to paint on the 3D, instead of painting of a single letter to paint 'spiils' on all layers.

danl42831687_0-1631344305204.png

After baking there are strange patters on the object:

danl42831687_1-1631344411386.png

 

These are the basic import settings I use:

danl42831687_2-1631344499861.png

 

What am i doint wrong here?

 

 

TOPICS
Automatic UV unwrapping, Baking

Views

162

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Sep 12, 2021 Sep 12, 2021
Hi The problem is that your letter surfaces are sharing the same UV space with the parts of the unwrapped surfaces overlapping rather than being laid out as separate islands on the UV map. You could address this in two ways: 1. On import to Painter - use Auto unwrap - with UV Islands set to "Recompute All" in options If you use this method, take the model back to 3D Stager by using Painter's  File > Send to > Send to Substance 3D stager. You will probably need to scale up the painted model to ...

Likes

Translate

Translate
Explorer ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

I noticed that all letters are imported as a single object. Can I split the letter to single letter objects when importing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 12, 2021 Sep 12, 2021

Copy link to clipboard

Copied

LATEST

Hi

The problem is that your letter surfaces are sharing the same UV space with the parts of the unwrapped surfaces overlapping rather than being laid out as separate islands on the UV map.

 

You could address this in two ways:

1. On import to Painter - use Auto unwrap - with UV Islands set to "Recompute All" in options
If you use this method, take the model back to 3D Stager by using Painter's  File > Send to > Send to Substance 3D stager. You will probably need to scale up the painted model to get it back to it's original size.

 

or

 

 

2. In 3D Stager convert the letters to standard models and separate them. to do that:

a. Select the text object and use Object >  Convert to standard model

b. Click away from the letters then click on them to reselect them and use Object > Ungroup. This will give you separate models named Glyph 1 , Glyph 2 ...etc

c. Put a separate material on each glyph object (i.e. each letter) by going to the material properties for each glyph object,  clicking the link symbol under the material which will change it to Default, then giving that letter a basecolor Hue that is different for each letter. See below:

2021-09-12_20-28-08.jpg

 

d. Select all the letters (or just some if you want to export some separately and export to GLTF

e. In painter you should see a separate material for each letter with no overlaps on the UVs

2021-09-12_20-37-35.jpg

You can now carry on and bake as normal

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources