• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Missing Seams on Hard Edges - How to Fix Baking?

Participant ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

I have a simple test mesh created with Blender. UVWs are unwrapped, with only one seam.

PixelFun_1-1703105461682.png

 

After importing it into Substance Painter, I can see in the Baking Preview the UV Seams. Especially, the Missing Seams on Hard Edges. Please see the screenshot below.

PixelFun_0-1703105395436.png

After baking the low poly mesh, I have no issues, and everything seems to be fine.

Now, I am adding a sculpted high-res mesh done with Zbrush, to smooth normals and perhaps add additional details. However, just by adding the new high-res mesh for baking, I am running the issue, to see edges on seams.

The interesting part is the fact, that there are no seams. The UVW Map has only two islands, with one continuous seam.

There are no matching errors, and adjusting the Max Frontal Distance or Rear Frontal Distance doesn't seem to be necessary at all.

PixelFun_2-1703105771307.png

 

However, when the bake is done I am getting nasty bakes, especially on the areas, in which Substance Painter indicates Missing Seams on Hard Edges.

PixelFun_0-1703106370375.png

 

Not sure how to resolve this and what I am missing here?
Thanks for any ideas on getting this fixed.

Please find attached:

  • Low Poly Mesh.fbx
  • High Poly Mesh.fbx

 

TOPICS
Baking , Discussion

Views

501

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Dec 23, 2023 Dec 23, 2023

okay, a quick note here:
I imported the .fbx file again, this time into Blender 4.0 and did the same.

Select all Edges --> and I removed all marked sharp edges.
Exported again, and this time all the sharp edges are gone.

Not sure if this was a Blender 3.6 Bug. Can't tell, but it finally worked.
Thx a bunch for your help Cyrill, appreciate it!

Happy Holidays and keep rocking,
cheers

Votes

Translate

Translate
Adobe Employee ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Hi @PixelFun,

 

Thanks for the message and all the details.

 

This is due to how the Normal from the Low Poly will impact the baking. If you have a sharp Normal defined by a single edge, and a baking process that will try to smooth that sharp edge, it can result with a visible seam.

 

I can see on your Low Poly that you've added sharp edges (cyan lines). I advise you not to. This way, the Normals of the mesh will be more compliant at baking, and the result should be far better.

 

No sharp edges = No missing hard edgesNo sharp edges = No missing hard edges

 

Alternatively, and as mentioned by Substance Painter, you can add a seam on hard edges of the UV map (that's why the warning is named "Missing seams on hard edges").

 

Let me know if you need further clarifications.

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Thank you Cyril,

 

well, I was testing the pudding now again, by removing all marked sharp edges inside Blender. Exported the result of the Low_Poly Mesh. But same issue.

Please find attached the LowPoly Mesh, with the hard edges removed.
To my surprise, Painter still marks hard edges. 

see screenshot below, after removing hard edges within Blender, Painter still marks those edges as hard!

PixelFun_0-1703185421623.png

 



Not sure what I am missing here now?
I attached the .fbx that has clearly no hard edges marked anymore.

PixelFun_1-1703185550182.png

 




 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 22, 2023 Dec 22, 2023

Copy link to clipboard

Copied

In the share 3D file, the model still has edges marked as Sharp.

CyrilDellenbach_0-1703240474689.png

 

The goal is to completely remove the sharp edges (CTRL + E > Clear Sharp), so the normal will be more compliant when baking.

 

CyrilDellenbach_1-1703240603000.png

 

Regards,

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

Hi Cyril,

yes, I agree with you 100%. That's what I did. But when exporting the .fbx file from Blender (I removed all marked sharp edges and exported the .fbx file) - for some reason, Substance Painter still showed the hard edges I posted above.

Are there any specific Blender Export options I have to consider, so the marked sharp edges are gone for real, and Substance Painter will not pick them up again?

It's odd. But again, just to clarify. Yes, I removed all marked sharp edges in Blender and exported the .fbx file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 23, 2023 Dec 23, 2023

Copy link to clipboard

Copied

okay, a quick note here:
I imported the .fbx file again, this time into Blender 4.0 and did the same.

Select all Edges --> and I removed all marked sharp edges.
Exported again, and this time all the sharp edges are gone.

Not sure if this was a Blender 3.6 Bug. Can't tell, but it finally worked.
Thx a bunch for your help Cyrill, appreciate it!

Happy Holidays and keep rocking,
cheers

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2024 Feb 16, 2024

Copy link to clipboard

Copied

LATEST

I also had this issue, I seemed to have fixed it through disabling "Average Normals" as your fix didnt work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources