• 글로벌 커뮤니티
    • 언어:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    일본어 사용자를 위한 전용 커뮤니티
  • 한국 커뮤니티
    한국어 사용자를 위한 전용 커뮤니티
종료

png 알파 텍스쳐 추출시, 검은색 영역 발생 이슈

신입 ,
Jun 29, 2024 Jun 29, 2024

클립보드로 링크 복사

복사됨

9.0버전과 10.0.1버전간 차이가 있어서 문의드립니다.

 

SP 9.0 버전으로 작업한 파일이며, 투명도가 있는 텍스쳐입니다. export texture에서 2D view PNG 파일로 추출했을 때 9.0에서는 깔끔하게 빠졌으나, 같은 파일을 10.0.1에서 추출할 경우 경계에 까만 색이 보입니다. 그러다보니 텍스쳐가 기본적으로 그림자가 진 것처럼 어둡습니다.

 

그래서 Unity 쉐이더에 적용해서 확인해보니, 9.0버전과 다르게 10.0버전에서는 알파 영역에 기본적으로 까만색이 적용되어 있습니다. 그러다보니 Unity에서 알파가 들어가는 텍스쳐에서는 10.0버전의 png 파일의 엣지를 지저분하게 처리합니다.

 

글로 설명하는 것에 어려움이 있어, 이미지를 첨부합니다.

bugfix.png

10.0.1버전으로 9.0처럼 투명한 부분에 까만색이 적용되지 않는 2D view png 파일 셋팅 방법을 알려주세요.



참고

  1. 같은 작업 파일, 같은 셋팅 - 각자 프로그램을 새로 깔아서 기본 셋팅으로 테스트했습니다
  2. 둘 다 pbr-metal-rough-with-alpha-blending 텍스쳐를 사용했습니다.
  3. 추출은 2D VIEW로 출력했으며 padding은 모드 셋팅을 다 적용해봤으나, 해결이 되지 않았습니다.
제목
버그 , 일반 문제 해결

조회수

148

번역

번역

신고

신고
커뮤니티 가이드라인
게시판 이용시 매너를 지켜주세요. 콘텐츠의 원본 출처를 밝혀 주세요. 중복되는 질문이 있는지 확인해보신 후 게시물을 작성해주세요. 자세히 알아보기
community guidelines
Adobe 직원 ,
Jun 30, 2024 Jun 30, 2024

클립보드로 링크 복사

복사됨

내보낸 불투명도 맵이 완전히 검은색입니다.


새 프로젝트를 만들 때 기본 색상은 텍스처가 아닌 셰이더에서 가져옵니다. 따라서 페인트하지 않은 모든 부분을 내보내면 알파 값이 0으로 설정된 검은색이 됩니다(이러한 부분에는 데이터가 존재하지 않기 때문).

 

이 문제를 해결하는 가장 쉬운 방법은 레이어 스택의 맨 아래에 채우기 레이어를 배치하는 것입니다. 그러면 모든 UV가 셰이더의 기본 색상과 동일한 기본 색상으로 채워집니다.

 

문서에 나와있는 해결 방법처럼, 레이어 위치를 변경해서 테스트 해보시겠어요?
그래도 해결되지 않는다면, 답글을 통해 알려주세요! 

참고 문서 :  My exported opacity map is totally black | Substance 3D Painter

투표

번역

번역

신고

신고
커뮤니티 가이드라인
게시판 이용시 매너를 지켜주세요. 콘텐츠의 원본 출처를 밝혀 주세요. 중복되는 질문이 있는지 확인해보신 후 게시물을 작성해주세요. 자세히 알아보기
community guidelines
신입 ,
Jun 30, 2024 Jun 30, 2024

클립보드로 링크 복사

복사됨

답변대로 레이어 스택의 맨 아래에 채우기 레이어를 배치했으나 결과는 같습니다. 여전히 검은색입니다.

화면 캡처 2024-07-01 122338.png

 

검은색으로 설정되는 이유에 대해서는 명확하게 이해를 했습니다만,  제시된 방법으로는 해결이 되지 않네요. 그리고 근본적으로 같은 셋팅값에서 9.0 버전은 알파 영역이 검은색이 아닌데 10.0.1에서는 검은색인 이유가 궁금합니다. 참고를 위해 각각 버전에서 추출한 png파일을 첨부합니다.

 

 

투표

번역

번역

신고

신고
커뮤니티 가이드라인
게시판 이용시 매너를 지켜주세요. 콘텐츠의 원본 출처를 밝혀 주세요. 중복되는 질문이 있는지 확인해보신 후 게시물을 작성해주세요. 자세히 알아보기
community guidelines
신입 ,
Jun 30, 2024 Jun 30, 2024

클립보드로 링크 복사

복사됨

여기저기 해결방법을 찾다보니 비슷한 이슈를 찾았습니다. 

https://community.adobe.com/t5/substance-3d-painter-discussions/how-can-i-export-2d-view-with-alpha-...

2월달에 버그라고 인정한 글을 보았는데요! 다음 업데이트에 해결이 될 예정인 건지 궁금합니다. 현재 사용버전은 10.0.01버전입니다. 이미 해당 버전으로 작업을 해둔 게 있어서 이전버전으로 돌아갈 수는 없고 업데이트를 기다릴 수밖에 없는데요 작업상 중요한 문제라 언제쯤 해결이 될지 궁금합니다.

투표

번역

번역

신고

신고
커뮤니티 가이드라인
게시판 이용시 매너를 지켜주세요. 콘텐츠의 원본 출처를 밝혀 주세요. 중복되는 질문이 있는지 확인해보신 후 게시물을 작성해주세요. 자세히 알아보기
community guidelines
Adobe 직원 ,
Jun 30, 2024 Jun 30, 2024

클립보드로 링크 복사

복사됨

안녕하세요 사용자님, 해당 문제는 확인 후 답글로 안내 해드리겠습니다.

투표

번역

번역

신고

신고
커뮤니티 가이드라인
게시판 이용시 매너를 지켜주세요. 콘텐츠의 원본 출처를 밝혀 주세요. 중복되는 질문이 있는지 확인해보신 후 게시물을 작성해주세요. 자세히 알아보기
community guidelines
Adobe 직원 ,
Jul 11, 2024 Jul 11, 2024

클립보드로 링크 복사

복사됨

최신

안녕하세요. 
찾아보신 것처럼 버그라고 되어 있긴한데 그 다음 버전에 바로 해결되었다는 이야기가 있었습니다만

다시 또 등장을 한걸까요..? 
우선 패치를 기다리는게 가장 확실한 방법인것 같지만 우회해서 해결을 하는게 도움이 되실것 같네요. 

 제가 테스트 를 진행해본 결과 알파의 효과가 나오는  오파시티 채널 작업하신 레이어에서

베이스칼라 채널을  비활성화 하시면 어두운 칼라가 적용되는 현상을 막을수 있었습니다. !! ^^:;
한번 확인해 보시겠어요?

투표

번역

번역

신고

신고
커뮤니티 가이드라인
게시판 이용시 매너를 지켜주세요. 콘텐츠의 원본 출처를 밝혀 주세요. 중복되는 질문이 있는지 확인해보신 후 게시물을 작성해주세요. 자세히 알아보기
community guidelines