• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Problem with my texture when exporting from substance painter

New Here ,
Nov 24, 2023 Nov 24, 2023

Copy link to clipboard

Copied

Hey guys,

I'm kinda lost on what to do at this point and not sure what to even try.

 

I want to use this wood texture, for the seat of the bench model I made, but I can't figure out why it's exporting this way and it's just unusable like this in blender.  

I hope you can see the problem with these two screenshots.

 

Screenshot 2023-11-24 143823.pngimage_2023-11-24_144321759.png

 I really need your help everyone, thanks in advance.

 

TOPICS
Discussion , Import & Export , UV Tiles

Views

166

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 24, 2023 Nov 24, 2023

Hello Valentine,

 

 

Thanks for the message.

 

The stripes in your exported maps are simply Dilation. The Dilation (or padding) is an automatic process at export that uses the last pixels at the border of the UV islands and expand them in the empty spaces of the UV map. It prevents artifacts and are especially important when working with mipmaps.

 

However, this is not related to the problem you're currently facing. My guess is that your model from Painter and your model from Blender don't share

...

Votes

Translate

Translate
Adobe Employee ,
Nov 24, 2023 Nov 24, 2023

Copy link to clipboard

Copied

Hello Valentine,

 

 

Thanks for the message.

 

The stripes in your exported maps are simply Dilation. The Dilation (or padding) is an automatic process at export that uses the last pixels at the border of the UV islands and expand them in the empty spaces of the UV map. It prevents artifacts and are especially important when working with mipmaps.

 

However, this is not related to the problem you're currently facing. My guess is that your model from Painter and your model from Blender don't share the same UV map. Do you have by any chance enable the Auto-unwrap feature when creating the project?

 

Deactivate autounwrap.png

 

If so, it built new UVs for your mesh. Therefore you'll need to export your current mesh from Painter (File > Export mesh) and import it to Blender in order to keep the proper UVs for your textures.

 

Best regards,

 

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2023 Nov 24, 2023

Copy link to clipboard

Copied

I did have the Auto-unwrap feature turned on yes.

Maybe that messed things up. I will try importing the mesh and seeing how that goes.

Thank you very much for the help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2023 Nov 24, 2023

Copy link to clipboard

Copied

LATEST

Tried it,

it worked wonders 🙂

Thanks again. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources