• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Camera clipping plane

Community Beginner ,
May 04, 2022 May 04, 2022

Copy link to clipboard

Copied

Hello

I'm trying to render a shot that I set up in 3ds max to see if we can use Substance Stager in our pipeline, however, I am getting clipping near the camera. On the left is my camera view in 3ds max - the view is set up how I want it and on the right is the same camera imported in Stager. I blurred the image to protect our content but you can clearly see the vehicles and the terrain on the left get clipped out of the view. Is there a way to adjust the near clipping distance in Stager? 

vladimirh07_2-1651715233569.png

 

 

TOPICS
Issue , Question

Views

233

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 06, 2022 May 06, 2022

You need to create camera and switch it on to get the area that can view a new camera and choose the camera before rendering. In this capture you can see the widget of new created camera that you can customize and change field of view of camera. Cameras can be more than one also.

Screenshot 2022-05-06 195041.png

In this second image you can see that new camera is ON in "layer" (that allow to activate camera widget)  and you can see cliped area that can be randered finally.

Screenshot 2022-05-06 195117.png

Hope this can help.

Likes

Translate

Translate
Community Expert ,
May 05, 2022 May 05, 2022

Copy link to clipboard

Copied

Than can be done with changing cameras setting in Stager. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 05, 2022 May 05, 2022

Copy link to clipboard

Copied

Thank you for your reply Ares

 

Could you please be more specific? 

I played with the camera settings and I don't see anything that controls the clipping that occurs. 

I've also read the documentation about camera (substance3d.adobe.com/documentation/sg/camera-213060346.html)  and I do not see anything about clipping distance.

 

vladimirh07_1-1651769588671.png

vladimirh07_2-1651769621696.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 06, 2022 May 06, 2022

Copy link to clipboard

Copied

You need to create camera and switch it on to get the area that can view a new camera and choose the camera before rendering. In this capture you can see the widget of new created camera that you can customize and change field of view of camera. Cameras can be more than one also.

Screenshot 2022-05-06 195041.png

In this second image you can see that new camera is ON in "layer" (that allow to activate camera widget)  and you can see cliped area that can be randered finally.

Screenshot 2022-05-06 195117.png

Hope this can help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 06, 2022 May 06, 2022

Copy link to clipboard

Copied

Thank you Ares

 

Yes I noticed that if I create the camera inside Stager the clipping does not occur.

I was hoping to get the camera I setup in 3ds max to work in Stager but this workaround works.

I just need to match the Stager camera to my 3Ds Max camera.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 06, 2022 May 06, 2022

Copy link to clipboard

Copied

Hi @vladimirh07 Can you provide the file that you're trying to import so we can take a look?  

Stager doesn't expose clipping plane settings, but it looks like maybe the focal length is off too as the scene composition is getting cropped a lot more in your Stager screenshot.  I wasn'ta ble to open the screenshots large size if you can re-attach those as single images maybe?  Thank you!

Senior Product Manager, 3D & Immersive

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

LATEST

Hi, @JMathews 

Thank you for following up on the issue.

Unfortunately changing the focal length does not remove the clipping. 

The stager camera does not have that problem, it's when I import my 3ds max camera the issue occurs.

I recreated my scene and the issue with some dummy objects for you to investigate. 

I hope it helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines