The official community for ColdFusion.
Recently active
We recently upgraded to Coldfusion 10 on our production system, and have been running into issues getting it to remain stable under full load.Initially, the issue was it would run out of memory with the error message: java.lang.OutOfMemoryError: Java heap space...and would stop responding to requests soon after, requiring a restart.Looking for help on this error resulted in suggestions to increase the memory that CF can use for its heap and permanent generation. However, applying these changes to our server (one, the other or both) actually makes the problem worse:The server still locks up just as frequently, but without any error messages; instead, it also prevents Apache from serving even static documents. As before, restarting the coldfusion server fixes this.We've reached the point where we now restart the service nightly, but this feels like a stopgap solution and wasn't necessary a year ago, when we had much less memory available (and were using the much older Coldfus
I have an application that at the end of the day 12:00 midnight I need all session.variables to expire and thus force my users to relogin.WIll this code end all of my user sessions?<cflock scope="Session" timeout="10" type="exclusive"> <cfset structclear(session)></cflock>
First off let me preface this with I'm new to programming in general.I'm working with coldfusion 10 and an access databaseThe problem I am having is regarding a certain form, people that use this web app like to copy and paste into the form fields and sometimes when they paste apostrophes they insert into the database as |-Now its not really a problem until they attempt to open up the form they submitted and it pulls these fields with the strange character, thats when it takes a crap.For the time being i just replace the strange characters with apostrophes in the database and everything is good to go.I have been reading up on rereplace and I'm wondering if that would be the best solution Any help would be greatly appreciated
I have a MS Access database that is accessed over the web via Coldfusion pages developed in Dreamweaver. A big portion of activities concerning the database records is the update of fields within the records to reflect activities performed. The activities are frequent and any record could be subject to updating multiple time each day by any one of 5 staff members. Obviously data integrity is of utmost priority, and I am looking for the means to ensure that if a record is open that another staff can not perform an update until the other party exits the open record. With my intermediate skills, I was thinking of establishing a status check off box and that upon entering the lead the box would be checked and the record updated. In this was the underlying page page displaying available (hyperlinked) records could reflect the status of the record in accordance with a 0 or 1 being present in the "STATUS" field. But I was hoping for a more elegant sol
This question was posted in response to the following article: http://help.adobe.com/en_US/ColdFusion/10.0/Developing/WSe61e35da8d318518-5719eac51353e6bb244-7ff9.html
This question was posted in response to the following article: http://help.adobe.com/en_US/ColdFusion/10.0/Developing/WSe61e35da8d318518-5719eac51353e6bb244-7ffc.html
I need to merge a pdf file that was created as a scanned document, with a normal pdf file, but keep getting the generic Adobe Acrobat error, "An error exists on this page...". I am using cfpdf action="merge" to do this. An example of my code follows below:<cfpdf action="merge" source="c:\PDFdocs\testfile1.pdf,c:\PDFdocs\testfile2.pdf" destination="c:\PDFdocs\testfile3.pdf" overwrite="yes">This method works fine if merging 2 normal pdf files, but if either of them was created as a scanned pdf file, I get the error. The normal pdf file will display ok in the merged file, but the scanned pdf file generates the error when viewing it. If anyone has an idea how to do this another way using coldfusion, if it cannot be done using cfpdf merge, I'd appreciate any help.Thanks in advance!
The lockdown guide for CF10 says to update JVM. After doing that on the machine, the CF administrator information still shows the older CF10 installation version. How do I sync the machine installation with CF10? Do I need a second installation in the ColdFusion10/jre folder?
Hi,Can we use a developer version purely for development purpose? The code set developed using the developer version will be then moved to the live environment where the Standard edition is installed. Mu question is whether we can use the developer version for coding and for which the code will be deployed in a production server which is having Standard edition COldfusion.
Hi All,Can any one pls explan what is memory leak. And how we can find a work around. I am facing this issue while migrating from CF 7 to CF 10. I have migrated my application from CF7 to CF10. We have an instance and in that we have almost 20 applications running. After Cf10 migration we are getting the below error : "Error","tomcat-ajp-179","06/23/13","01:03:42","pmt","Java heap space The specific sequence of files included or processed is: /mnt/cfhacontent/[instance-name]/[app_name]/index1.cfm, line: 565 " java.lang.OutOfMemoryError: Java heap space Your help is well appreciated.Thanks.
My Coldfusion Standard version is 9,0,2,282541Am I fully patched for version 9?
This question was posted in response to the following article: http://help.adobe.com/en_US/ColdFusion/10.0/CFMLRef/WSc3ff6d0ea77859461172e0811cbec22c24-79e4.html
Used VE Kavachart with versions of Cold Fusion, 8 and earlier. Earlier versions used JRun instead of Tomcat to process the .jsp requests.Everything worked great!Then upgraded to Adobe ColdFusion 10.Has anyone configured (ColdFusion 10 on Windows Server 2008 64 bit and IIS 7) to process .jsp files? I have set up the handler script in IIS7 for .jsp to C:\ColdFusion10\config\wsconfig\1\isapi_redirect.dll.I have added and unadded .jsp mime type (html/text) to no avail.I have used the CF Administrator to include the Kavachart class path and jar files.We have appended Kavachart servlet tags to the web.xml file.Cold Fusion .cfm files are processed just fine.However, IIS Continues to throw a 404 error even when the .jsp file is present.Has anybody got Kavachart to work with ColdFusion 10?Any suggestions would be appreciated.Stan
I'm wanting to put together a cfpresentation slide show. I ran into several problems and want to find out if I'm doing something wrong.1. CFPresentation with only 28 slides takes a long time (2 minutes or more) to load.2. As part of the CFPresentationSlide tag, when I give the "src" and "audio" subfolder/filename I get a file not found error message. (When I have the file displayed using img the file shows up just fine.) 3. I'm trying to figure out how I can get the audio to work. Embed doesn't seem to work.What i want most to know is this: Am i wasting my time working with cfpresentation? I'm using Win7, CF9,
I am trying to install the latest versin (CF Builder 2, update 2) on my iMac (2013 model, 8GB RAM, OS X 10.8) The installer launches but the intial screen is blank with only the "next" button visible. It wil not progress from there. I've tried re-booting and re-installing with not luck.Anyone seen this? Given the lack of CF support in Dreamweaver CC, I am trying to install CFB as recommened. Needless to say, a bit frustrating! I also do not see any logs generated for the install attempt, so there is little in the way of clues to help.Thanks in advance for any suggestions.
I use Report builder to build my reports.I make details band same size of my text field, but it still shows space between details line.I see line spacing property for the details band and it has be at least single space.I just wanted to know I can elminatethe space between details.Your help and information is great appreciated,Regards,Iccsi
I have been page caching on my site for years using this code: <cfcache timespan="#CreateTimespan(10, 0, 0, 0)#" directory="D:/websites/mysite/cache/" stripWhiteSpace="true">This worked great - it would keep a cached copy in the cache directory and would stay cached for 10 days. Good stuff!!Now I've had to switch servers and up to CF9. I still want to cache my pages but I just cant seem to get it right.I am now using this code<cfcache timespan="#CreateTimespan(10, 0, 0, 0)#" useQueryString ="true" stripWhiteSpace="true">But the pages dont cache in the cache directory and they dont seem to load faster as if they were cached.Am I doing his right? Am I even caching the pages? I'd like to keep a copy in my cache directory is that possible?
The following tech note for ColdFusion 9.0.1 Cumulative Hotfix 4 has been updated with instructions for jpedal.jar.http://helpx.adobe.com/coldfusion/kb/cumulative-hotfix-4-coldfusion-901.htmlHow does this affect you:If your ColdFusion server was not patched with Cumulative Hotfix 2 prior to applying Cumulative Hotfix 4, you would need to download the JPedal.zip file. See the Step #12 in the tech note link above for more details.If your ColdFusion server was already patched with Cumulative Hotfix 2 before you applied Cumulative Hotfix 4, you already have the correct file and need not do anything.Failing to replace the jar file may lead to a broken Fonts Managment page in the CF administrator.
https://bugbase.adobe.com/index.cfm?event=bug&id=3344353I was reading this weekend in the bug page that the issue was fixed. Such great news I thought. However after running the last update (Update 10 to CF10), we are still seeing the same issue. It says in the bug page that is fixed in build 285129. Do you know if that build is the Update 10? Anyone having the same issue?
We are moving our websites from one server to a new one. We have installed Coldfusion Enterprise 8 on the new computer with the same license number. The 2 servers are supposed to be moved on Friday, June 28th. They will obviously both be turned off for the move and restarted once they are moved. We are continuing to test the new server before we switch the live site from the old server to the new. I am afraid that when it is restarted, I may have an error pop up due to the fact that they both have the same license number on it. Can you tell me what will happen and how to avoid any problems?
The web site you are accessing has experienced an unexpected error. Please contact the website administrator. The following information is meant for the website developer for debugging purposes. Error Occurred While Processing Request Error Executing Database Query.[Macromedia][Oracle JDBC Driver][Oracle]ORA-00913: too many values Resources: Enable Robust Exception Information to provide greater detail about the source of errors. In the Administrator, click Debugging & Logging > Debugging Settings, and select the Robust Exception Information option.Check the ColdFusion documentation to verify that you are using the correct syntax.Search the Knowledge Base to find a solution to your problem.Browser Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0Remote Address 172.27.1.11Referrer http://emanifest.dagangnet.com.my/ems/cuscarCa
Hi,I am going to implement the directory watcher in my application. The web server is using standard edition of coldfusion. When I checked about the description of Standard edition features, I found that DirectoryWatcher is enabled in Standard edition. But it is mentioned as 'Restricted'. I didnt understand about this 'restricted'. Somebody know about this? Please advice.Thanks
Hello.Versions:CF8, MySQL 5.5.27Database record fields:, FirstAttemptByCertNumber <-- same certification number, SecondAttemptByCertNumber, ThirdAttemptByCertNumber <-- same certification number, FourthAttemptByCertNumberScenario:Web based airway management report. Four attempts are allowed per patient. An individual attempts an airway insertion and is not successful. This would be recorded in the first attempt section of the report. A different person does a second and attempt and is not successful. The first person attempts a third time and this time around is successful. So the FirstAttemptByCertNumber and ThirdAttemptByCertNumber DB fields would contain the same certification number. After the information is inserted into the DB and e-mail is generated and sent out. Client would like to have all information in a single DB recordThe goal (if possible) is to only send out one e-mail for each Certification Number in the DB record. I am able to get the last record id inserted, bu
CF9 has been installed on Windows server 2008.Successfull.I can see CF9 files on disk C:\ColdFusion9I have the CFIDE structure installed on disk D:\wwwroot\CFIDEAnd when launching :http://127.0.0.1/CFIDE/administrator/index.cfmcan't find the fileI tried the Sever IP adress :http://85.14.138.81/CFIDE/administrator/index.cfmsame, can't find the file.Can someone help/explain where could be the problem ?It seems to be a problem of IP pointing ?Thanks for any help.I do not have the hand on the IP.Pierre.
Using MYsql How do you find out who did not contribute to a particular fund raiser that we all just did. There are many titles to the different charities that is under the othpaytitle of the Otherpay table, I however just want to extract the non-contributors for a particular charity title. Is there anyway to do this? When I do the the syntax below it comes up as an "empty set". The search is done by way of the table Id matching and left joins. Please see below. SELECT moiid, trim(concat(name.fname,' ' ,name.mname,' ',name.lname)) as Brother, name.moiid as Members_ID, sum(otherpay.othpayamt) as NO_Contribution, quadlt.ltfname as quadFROM name LEFT JOIN OTHERPAY ON name.moiid = otherpay.othpaymoiidLEFT JOIN quadlt ON name.quadlt = quadlt.ltidWHERE Otherpay.othpaytitle like '%food drive%'AND otherpay.othpaymoiid IS NULL AND name.type = 'BOI'AND name.type <> 'jrboi'AND name.city = 'SUFFOLK'GROUP BY brotherORDER BY name.quadlt, brother
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.