Questions
Recently active
Is there a way to connect to an IRC server with ColdFusion? If so any example to get inspired!? thanks!
All other datasource connections are verified OK except one connection to SQL Server and on verification it gives an error Login failed for user".I'm using mixed mode authentication in SQL Server. Can 't seem to think what else to get rid of the error.Please advise,Thanks,Jyoti.
I installed ColdFusion builder and set up the administrator page. I accessed it using http://127.0.0.1:8600/CFIDE/administrator/index.cfm. I logged out.when I attempted to get back in I got "cannot display page" error in the browser.I have not changed any configurations on the machine I installed it on. It does have IIS on it but I shut IIS down.This is frustrating... any suggestions?
We have many existing scripts that don't seem to behave in ColdFusion Builder 3. Wherever we have jQuery selectors that use the id selector $("#..."), the function collapsing stops on the first line where the id selector is used. It becomes annoying since the remainder of the file will not collapse. I'd prefer not to have to wrap every selector in cfoutput so I can escape the pound sign.The javascript is being saved in cfsavecontent tag. Below is a simplified code snippet. Function collapsing stops at the bold line and the remainder of the file does not collapse.<cfcomponent displayname="content">...<cffunction name="getHomeContent" returntype="string"><cfset var html = "" /><cfsavecontent variable="html">...<script>$('#myid').change(function() {$('#myid-nav').val($('#myid').find(':selected').val());});</script>...</cfsavecontent><cfreturn html /></cffunction>...</cfcomponent>
Hi Charlie,How do you show the Source Firefox IE button at the bottom??Message was edited by: Carl Von Stetten after branching from a previous topic. Changed title to match new question.
Hi All,I have a formatting issue when outputting RSS feeds.Here's my page: http://www.ukagriculture.com/farming_news/farming_news_feeds.cfm<br /><h1>Economist - Agriculture</h1><hr / style="width:100%"><cfset rssUrl = "http://www.economist.com/topics/agriculture/index.xml"><cffeed action="read" source="#rssUrl#" query="entries" properties="info"><cfoutput query="entries" maxrows="5"><br /><a href="#rsslink#" target="new"><strong>#title#</strong></a> - <span class="xxsmall">#publisheddate#</span><p>#content#</p></cfoutput>I've been trying to find a way to clean up the results and display images in the feed, any suggestion gratefully received.CheersTrevor
HiI wanted to upgrade our Coldfusion 10 to 11. We are using MongoDB as additional database, so we use Java MongoDB driver. And until this point everything is fine & everything works.All data to Mongo and from Mongo are in JSON format. Problem we have is that serialization changed in CF 11 what broke all queries.Here is an example:CF10: { "VAL1" : 0 , "VAL2" : { "$ne" : false} , "VAL3" : true , "VAL4" : { "$gt" : 5}} CF11: { "VAL1" : "0" , "VAL2" : { "$ne" : "false"} , "VAL3" : "true" , "VAL4" : { "$gt" : "5"}}Problem is that 0 != "0", true != "true", 5 != "5". Mongo can't compare string with int or bool (same issue with floats)When i put data to database have same issue. Something that was before integer or bool now is string.I found a way to make it work Javacast('int',value), Javacast('boolean',value) but changing it in every place in big project will take far too much time. Is there a way to make SerializeJson work like it worked before? Why it changes types now?
Can ColdFusion v.11 Standard be installed and run on a Windows Virtual Server, or must it be installed on a Physical Server ?
I have tried to get this to open within the internal browser and even with the settings, I can't remove the check mark for the default browser, not sure what I'm missing here.
I'm running CF 9,0,0,251028 on Server 2008 R2 x64 with IIS 7.5. I installed APSB13-10 without any issues. I then installed APSB13-03 and after doing so the CF Administrator page returned a 500 Internal Server error. My CF websites continued to function. I rolled back and everything started working again. The problem is I am required to install this patch due to network security requirements. Is there anything I can do to get the Admin page to function after installing APSB13-03? Or am I missing something?I am a little bit confused with the complexity of installing CF updates as I already have hf900-00010.jar and hf900-00013.jar files in my {ColdFusion-Home}/WEB-INF/cfusion/lib/updates folder, and this update puts an hf900-00009.jar in there, which seems like it might be an older file. Currently everything is working since I rolled back, but I have to install this update and after troubleshooting the 500 error I finally had to roll back. I have no idea what could be happening. Thank you
Is something like this planned as an update? When?Currently we have to write really ugly code (script and tag code mixed) to get some legacy module files loaded into our components. I'm not talking about few files here, we have been using CF since version 5 and refactoring everything isn't an option.Only workaround seems to create the ModuleTag java object in the coldfusion.tagext.lang package and call out the module that way. This is really hacky though since cfusion.jar can have class updates. Or perhaps there are some better solutions?
Is anybody using Oracle Dead Connection Detection with ColdFusion? thanks,Chris(also posted to StackExchange)
Is there a way to get ColdFusion Builder 3 to run using Java 8?
Could you please tell me how can I download ColdFusion_11_WWEJ_win64.exe
Running CF Version 9,0,1,274733 One of our error reports showed:----------------------------------------------------------------Error Page: /CFIDE/beta.cfmQuery String: page=quicklyHTTP Referer: [removed for this post]/CFIDE/beta.cfm?page=quicklyDiagnostics: ColdFusion could not delete the file C:\ColdFusion9\runtime\servers\coldfusion\SERVER-INF\temp\wwwroot-tmp\session_log0.txt for an unknown reason.----------------------------------------------------------------This pointed us to that beta.cfm file that was somehow put into the CFIDE root. No FTP access to that directory and they have cleared the CF logs so no real record of what might have been done. Did find a few CF files that had been modified around the same time but nothing in them seemed out of the ordinary. Have removed access to them for now to be safe.Any suggestions on where to start to figure out how they got that file into the CFIDE root? I do have the file (moved out of CFIDE) which I can
I've buy CF11 ancd want to use the PDF server, but i dosn't work.The "Verify all Service Manager" in the PDF Service page say: "Connection verification failed for PDF Service Manager: localhost Check logs for more details."I the log i found only this line (/opt/coldfusion/cfusion/logs/server.log) "Error","ajp-bio-8014-exec-4","11/18/15","14:16:03",,"Connect to 127.0.0.1:8987 [/127.0.0.1] failed: Connection refused http://127.0.0.1:8987/PDFgServlet/verify"After some google serch i found that page: https://helpx.adobe.com/coldfusion/pdf-generation-in-coldfusion.htmlBut .... i've a SLES 12 (Suse Linux Enterprise Server) and i don't find on YAST all the libraries that this Adobe document mention.What i've to do? Whare i can find that libraries?Adobe tell me that CF 11 work on SLES 12 and i want it all work.In need the right library for my operating system and the correct instruction for made PDF server oin CF11 work on SLES 12ByCristian
Hi Team,How do we reset the cold fusion administrator password? Please email me at mandira.dey2@pseg.com
I am setting up a web service on my Coldfusion 10 server.I created this CFC...<cfcomponent> <cffunction name="helloWorld" returnType="string" access="remote"> <cfreturn "Hello World!"> </cffunction></cfcomponent>I try to call it like this...<cfset wsURL = "http://txedtylvms031/cf-bin/Components/hello.cfc?wsdl"><cfinvoke webservice = "#wsURL#" method = "helloWorld" returnVariable = "result"><cfoutput> <H1> #result# </H1></cfoutput>I get this errorCannot perform web service invocation helloWorld. The fault returned when invoking the web service operation is:org.apache.axis2.AxisFault: javax.xml.stream.XMLStreamException: DOCTYPE is not allowedat org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:124)at org.apache.axis2.transport.TransportUtils.createSOAPMessage(Tran
Hello,We have just recently moved our code from CF7 to CF11. We have a huge problem when submitting any forms . The URL parameters gets lost. For example we have productid in the URL parameter and it automatically coverts into html entity ∏uctid. This is just an example, we have many quite a few of them another example is levelid converts to ≤velidAny help will be greatly appreciated , short of changing the URL parameters, as the application is pretty huge. We just wrote sample page like this. And you we get an error saying productid not found ( because it converts into ∏uctid on submit!) This happens on development and production environment. We are running IIS with CF11<cfif isDefined('form.submit1')><cfoutput>#url.productid#</cfoutput></cfif><cfform name="form1" id="form1" ><cfinput name="submit1" id="submit1" type="submit" value="Submit"></cfform>
I'm performing an upgrade from CF8 to CF11, but need to keep CF8 on the server until CF11 is running properly on my production server.Apache 2.2.26, Tomcat 7.0.64Windows Server 2008_R2 (virtual)I have the original CF 11.0.0 file direct from Adobe. I chose a standard install (not JEE) with Apache web server and all sub-components, no servlets. The install proceeds without issue.In Apache httpd.conf, I see the section of code that had been added by my earlier install of CF8:LoadModule jrun_module "C:/ColdFusion8/runtime/lib/wsconfig/1/mod_jrun22.so"<IfModule mod_jrun22.c> ...more code... </IfModule>I also see the line of code that the installer added for CF11:Include "C:\Apache2\conf\mod_jk.conf"I can also find the mod_jk.conf file in the place it references and all of the CF11 files and folders that it references exist.I commented out the section above for CF8 and attempt to restart Apache, but it fails to start. There are no entries in Apache logs to expla
I found a good convo here from 2013 that yielded one recommendation, and a few stay-away-froms. But that was two years ago. Much can change! Who would you recommend for a good hosting partner today?My husband's small business is besieged by what is likely a routing or peering issue at Cogent. Regardless, neither our host, Newtek (previously Crystaltech), nor our service provider are willing to help -- not that these situations can be solved, from what I've heard from networking pros and others on the 'net complaining about similar problems. (And by help, I mean having someone in their network ops group call someone down the line in hopes of getting the attention necessary to solve the problem.)We don't have a choice in service providers due to his location. So, it looks like my best bet in solving the problem is going to be switching hosts. I don't want to -- we've been with them for like 15 years, no kidding! But... this problem has grown from something that popped up briefly once or
Hello,we need to know if compatible version of ColdFusion 11 Enterprise Server on a Windows x64 with server applications IBM Websphere 8 ND.At the next link just yourself appear compatible with Windows x32, but it seems to me very strange:http://wwwimages.adobe.com/content/dam/Adobe/en/products/coldfusion/pdfs/cf11/coldfusion11-support-matrix.pdf
We have a webservice component developed in Coldfusion to handle a data feed from an external system. External system is a java environment feeding data to our application through the webservice component. When a bunch of messages are submitted ColdFusion handles few messages and rejects remaining messages in the server level(like 3 out of 10. There is no patter we could capture with this connection. Message counts are random.). ColdFusion Server runs on IIS. ColdFusion does not throw an error message to the external system for the unprocessed messages. I am not sure if this is an issue with IIS or ColdFusion server. Any help would be much appriciated!
Good morning, I am seeing this warning on all instances of ColdFusion on one of our servers. It was patched to Update 7 this morning and those entries were not there before.Below you will find the excerpts from coldfusion-error.log file before Update 7 was installed and after (I have skipped some lines that show stopping logs for easier readability). After seeing this warning, I did some research that suggested turning on TldLocationsCache logs, which I did by uncommenting this line:org.apache.catalina.core.ContainerBase.[Catalina].[localhost].level = FINEin:${catalina.home}/conf/logging.properties fileHowever, I don't know where to find these logs; they are not in coldfusion-error.log or the coldfusion-out.log files. Can someone point me in the right direction finding those logs? Thank youOriginal log file (Nov 12 - last run before Update 7 was installed, Nov 23 Update 7 was installed):Nov 12, 2015 10:51:30 AM org.apache.catalina.core.AprLifecycleListener initINFO: Loaded APR based Ap
We are in the process of setting up a new CF 11 server. We are getting this error "error javax.mail.AuthenticationFailedException: 451 4.7.0" in the logs when we use cfmail that has been working for years on a CF9 server. Also the mail is in the Undelivered folder. We can drag to Spool, but it just comes back.We do use MS Exchange 2013 and we have added our CF11 servers IP in the Frontend connector that we use to relay mail to allow email from our CF server.Did something change with how ColdFusion processes email from CF9 to CF11?Our current cfmail parameters.<cfmail to="#theSendTo#" cc="#theSendCC#" server="mail.xenegrade.net" from="#theFrom#" username="<ourDomain\ourUsername>" password="<ourPassword>" subject="#theSubject#" replyto="#theFrom#">
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.