Slow 3D rendering in Acrobat Reader DC

Community Beginner ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

Hi,

I've created a PDF doc with a 3D annotation. When I open it in Acrobat Reader (v. 18.009.20044), 3D rendering performance is very poor.  The Preferred Renderer is DirectX 9 in the Preferences but, in fact, I don't see any differences between Software and DirectX 9: rendering is very slow in both cases. BTW, I have only two options: DirectX 9 and Software, no OpenGL.

On the other hand, when I open the same file in Acrobat Pro DC, 3D rendering is much faster with the DirectX 9 renderer. When I select Software renderer in Acrobat Pro, the performance is the same as hardware or software rendering performance in Acrobat Reader (slow).

I've tested it on several PCs with different NVidia graphics cards (GeForce GTX 960, GeForce GTX 970, Quadro M2000M with the latest drivers, Windows 10) and got exactly the same result: Acrobat Pro is fast, Acrobat Reader is slow with respect to 3d rendering.

Is it because Acrobat Reader does not support hardware acceleration?

If it does, how can I enable it? Do I have to do something else in addition to selecting DirectX in the preferences?

Thanks,

Roman

Views

28.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Feb 07, 2019 Feb 07, 2019
Hi All,here is the Solution in German:1. öffne NVIDIA Systemsteuerung2. 3D-Einstellungen verwalten3. Bevorzugter Grafikprozessor: Integrierte Grafiken4. ÜbernehmenThe Problem: NVIDIA-Driver is not supported -> use internal GPU (e.g. Intel)

Likes

Translate

Translate
Adobe Employee ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Hi Roman,

As per above-mentioned description, when opening a pdf file with 3D content in it, rendering performance is slow in Reader, is that correct?

Would you mind sharing one of the pdf files with us to replicate the issue at our end? I have sent you a private message for the same, please check the inbox for the same.

Thanks,

Shivam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Hi Shivam,

That's correct, poor 3D rendering performance in Acrobat Reader, OK performance in Acrobat Pro.

I've emailed the PDF file.

Thanks,

Roman

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 27, 2017 Nov 27, 2017

Copy link to clipboard

Copied

Hi Roman,

Thanks for sharing the pdf file with us.

Could you please try uninstalling Reader by click Start menu > Apps and Features > click Adobe Acrobat Reader DC > Uninstall.

Reboot the machine.

Download Reader DC from here: Adobe - Adobe Acrobat Reader DC Distribution 

Reboot the machine and try opening the file again.

Thanks,

Shivam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2017 Dec 01, 2017

Copy link to clipboard

Copied

Shivam,

Reinstalling did not help.

In fact, this was the first thing that I did during my investigation (among many others, including analyzing GPU activity) before reporting this problem.

I can say for sure that Acrobat Reader (unlike Acrobat Pro) does not use GPU for rendering 3d objects even if DirectX is On in the Acrobat Preferences.

Thanks,

Roman

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

I have the exact same behaviour on 4 HP Zbook Studio G3 machine's

The 3D Rendering i thier 3D System Vertex runs very smoothly but when showing 3D pictures in PDF format it's very, very sloppy/not good.

We've upgraded the system to the very latest Windows 10, very latest Adobe Acrobat DC (18) and are running the very latest graphicdrivers from Nvidia (From 7th of December).  The machine's have Nvidia Quadro M1000M graphiccards and we have the same behaviour in Adobe Acrobat on all of these machines.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2018 Feb 21, 2018

Copy link to clipboard

Copied

Hi, same issue here - HP WorkStaion Z Book G4 Nvidia Quadro M2200 and realy bad performamce from 3D PDF drawings (lags in seconds!!!)...

Windows 10 - OS Build 16299.248

Nvidia driver - 390.65

Adobe Reader DC - 18.011.20036

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

Hi,

I have same problem. - Lenovo P50 i7-6820HQ - 16GB RAM - Nvidia Quadro M1000M 2GB / Intel(R) HD Grapnics 530

Windows 10 Pro

Adobe Acrobat Reader DC 18.009.20044.55097

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2018 Mar 11, 2018

Copy link to clipboard

Copied

Hello,

  Hell, I'm having same troubles. Problem have appeared recently. Opening and viewing models, which I created previously and those that worked fine by that time, now is a big pain, literally unbearable. Probably an update of Acrobat Reader or Windows caused this, I'm not sure.

Windows 10 Pro (1709)  - Microsoft Windows [Version 10.0.16299.248]

Inspiron 7737 - GeForce GT 750M - Driver version 391.01 / Intel HD Graphics 4400, Driver version 20.19.15.4531

Adobe Acrobat Reader DC - Russian, ver. 18.011.20038

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 19, 2018 Apr 19, 2018

Copy link to clipboard

Copied

Hi Igor Grigoryev,

Sorry for the delayed response.

Please try removing Reader using cleaner tool which you can download from here: Download Adobe Reader and Acrobat Cleaner Tool - Adobe Labs , reboot the machine, download Reader DC from here: Adobe - Adobe Acrobat Reader DC Distribution , reboot the machine and check.

Thank You,

Shivam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2018 May 21, 2018

Copy link to clipboard

Copied

Hi all, i have the same issue and tried also with the suggestions but no luck.

My test PC is a Dell Precision 7520 with w10, Nvidia Quadro M2200 with 4GB GDDR5

It works fine on other older machines with w10 and also w7.

Maybe its a driver issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 29, 2018 May 29, 2018

Copy link to clipboard

Copied

I am experiencing the same issues. I have reported it in another thread: PDF warning for malicious content on a 3d PDF I created

Adobe Acrobat Reader DC is definitely rendering in software mode on a PC, even when set to DirectX 9 in the preferences.

Adobe Acrobat Pro DC renders the same exact files perfectly using hardware acceleration.

I noticed at the top of this thread it is "Assumed Answered". It has not been answered and the issue still persists in version 2018.0.11.20040 of Adobe Acrobat Reader DC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2018 Jun 05, 2018

Copy link to clipboard

Copied

I had same issue, very slow and lagging 3D-pdf.

This setup works for me:

Preferences -> Security (Enhanged) -> unbox "Enable Protected Mode at startup"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 06, 2018 Jun 06, 2018

Copy link to clipboard

Copied

Thanks terok96231739.

This security setting does seems to be the issue. However I do not know why having a hardware accelerated 3d view is a security issue.

I can't suggest to clients to disable their security settings. Hopefully I can find a work around somehow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2018 Jul 11, 2018

Copy link to clipboard

Copied

Unfortunately it did not resolve in my situation. Today i saw&applied also an update from acrobat readere but no luck.

Also tried different Nvidia drivers, the same issue is present.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 11, 2018 Jul 11, 2018

Copy link to clipboard

Copied

Hi,

Could you try adding pdf file under privileged location by clicking Edit > Preferences > Security ( Enhanced ) > Add file and check if that helps? You may refer to this help document for the same: Enhanced security setting for PDFs, Adobe Acrobat

Thanks,

Shivam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2018 Jul 11, 2018

Copy link to clipboard

Copied

i tried both adding file, and also adding folder path , no luck

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 12, 2018 Jul 12, 2018

Copy link to clipboard

Copied

Same here. The problem appeared one day to the other. Nothing helps...

On my other Computers the 3D pdfs work normally.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

Thanks terok96231739

The "Security (enhanced)" - Uncheck the "Enable Protected Mode at Startup" worked for me also.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2020 Sep 02, 2020

Copy link to clipboard

Copied

So I got it to work by leaving the mentioned checkbox  checked by uncheking the box to the right.  Run in AppContainer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2018 Sep 22, 2018

Copy link to clipboard

Copied

Works for me. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Thank you!!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 31, 2018 Jul 31, 2018

Copy link to clipboard

Copied

Some problem here.

Disabling "Enable Protected Mode at startup" works for me, but this cannot be the only solution you are offering. Have seen same problem on 6 different computers so far having different hardware software configurations. All using latest available adobe acrobat reader DC releases.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2018 Aug 24, 2018

Copy link to clipboard

Copied

Same problem - Lenovo ThinkStation P320 (i7-7700 3.6G) 16GB - Quadro P400 2GB - Win 10 64 Pro

Uninstall Adobe reader 18

Install Adobe reader 11

! Good !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 30, 2018 Nov 30, 2018

Copy link to clipboard

Copied

Hi All,

Could you try installing the latest patch for Reader using "Check for updates" option under "Help" menu,  You may also download updates from here: Adobe software and product updates

Reboot the machine after installing update and try again.

Also,  check if an update is available for the Graphics card. You can check the same by going into the device manager or on the manufacturer's website.

Also, try replicating the issue in a new user account and check if this behavior continues.

-Shivam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines