• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Unable to delete temporary files

Guest
Aug 27, 2014 Aug 27, 2014

Copy link to clipboard

Copied

I am running Acrobat Reader 11.0.0 in a XenApp 6.5 Environment on Windows Server 2008 R2 SP1.  We have recently started using Mandatory profiles and the option set to delete cached profiles on logoff.  We have started noticing that some of the profiles are not being deleted because of files that are locked by the system.  The files are named Z@*.tmp.  I have done some research into the issue and have found an article on your website that mentions this issue specifically:

http://blogs.adobe.com/dmcmahon/2011/11/08/acrobatreader-tmp-files-left-behind-in-temp-folder-after-...

Please note this article is dated 11/2011 and seems to refer only to XP, NT, and 2003 server.  Also at the bottom of the article it states the following:
Following our testing we have discovered that the issue does not occur in Windows 7, or Windows 2008 Server.  It seems that the updated versions of Windows provide a solution to this issue.  We would therefore recommend updating your OS if possible.

I have found that this is not that case and this issue seems to remain, at least in my configuration.

Views

147.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Feb 28, 2016 Feb 28, 2016

Attention all, the fix is finally here.  I opened a ticket with Adobe last week on this issue and they finally got back to me with an answer.  The issue was corrected in last month's (January 2016) release of Reader 11.0.14.  I already got the release and tested it thoroughly and it works as perscribed.  Hurray!

Thanks to everyone for their contributions to this thread.  I followed this thread miticulously in an effort to resolve my issues, obviously to on avail... it's a shame that this issue we

...

Votes

Translate

Translate
replies 141 Replies 141
Explorer ,
Nov 20, 2014 Nov 20, 2014

Copy link to clipboard

Copied

We are in the process of testing. I expect results in a few days. We don't have a good test environment for this system, so we have to take a live server out of production to do it.

I agree, your concern is valid. I don't mind uninstalling a single patch that fixes a moderate vulnerability, but three patches in three months is excessive. I have extenuating circumstances in that one of my software programs is unsupported by the manufacturer, and it stopped printing due to these patches. This program is also used to access our ERP program. Removing the above patches fixed both issues.

So in the IT world I got a 2fer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2014 Nov 20, 2014

Copy link to clipboard

Copied

After the above procedure the MS tech installed a hotfix KB2998984. I am not convinced this is going to work. I think they are grasping at straws.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 11, 2014 Dec 11, 2014

Copy link to clipboard

Copied

If  you use Res on your Citrix server you can add these.

It's temp option. When i made these the Z@.tmp file came in the c:\temp\%username%.

After users loging off the profile is oke!

So when the real fix is there i can fix it back 🙂

settemp.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2014 Nov 20, 2014

Copy link to clipboard

Copied

Adobe Reader’s Z@….tmp files cannot be deleted | Michael's IT Blog

To sum up – Adobe has to recode Adobe Reader. The CreateScalableFontResourceW function is outdated and not supported anymore. I was able to proof that this API doesn’t release the font file anymore after it has been executed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2014 Nov 20, 2014

Copy link to clipboard

Copied

Interesting. Thank you for sharing that, platinum2014.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2014 Nov 26, 2014

Copy link to clipboard

Copied

It's ok on 2008 without some KB, but it does not work on 2003 server. I still have issue.


(August: KB2982791 / Oct KB3000061 / Nov KB3002885)


Which KB (uninstalled) works for you on 2003?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2014 Dec 10, 2014

Copy link to clipboard

Copied

Hi,

any news regarding this issue? Finally it's not a good idea not to install security updates. At this time I expect a reaction from Adobe....

regards

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2014 Dec 12, 2014

Copy link to clipboard

Copied

There is an update 11.0.10 for the Adobe Reader available. I don't know yet if this issue is solved.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2014 Dec 12, 2014

Copy link to clipboard

Copied

I don't know if this is thanks to Adobe update or Windows Update, but i don't have issue this month.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2014 Dec 12, 2014

Copy link to clipboard

Copied

Hi AEAG,

so you have on a Windows 2008 R2 server all Windows Updates installed? Which Adobe Reader version is installed?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2014 Dec 12, 2014

Copy link to clipboard

Copied

Hi,

Not all Windows Updates, as I said earlier , I have some KB uninstall the previous months (August: KB2982791 / Oct KB3000061 / Nov KB3002885) but this month I have not uninstalled one Update. And yes it's on 2008 R2 server.


My Adobe version is 11.0.10 on this environnement.

But i have also a 2003 environnement, with Adobde 9.5.5 and i don't have issue this month.

So I don't think this is that Adobe has solved the problem , but Microsoft whith this Patch Tuesday

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2015 Jan 06, 2015

Copy link to clipboard

Copied

Hi AEAG,

do you reinstalled those patches (KB2982791 / Oct KB3000061 / Nov KB3002885) with your latest patch day installtion or do you keep them not installed?


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2015 Jan 06, 2015

Copy link to clipboard

Copied

Hi,

yet they are still uninstalled

I'll wait for the patch next month and if there are no worries I think trying to reinstall KB.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2014 Dec 17, 2014

Copy link to clipboard

Copied

All this is very interesting, very have recently updated our XenApp6.5 Farm to the latest hotfixes and MS Patches after 3 years of not running any hotfixes or updates in 6.5.

At same time we updated Adobe to 11.0.07 and ever since the update we noticed all of the above in reference to .tmp files being locked.

We have a script that would go across the servers for a user and clear any left over/stuck profiles, but since the update this scrip is useless due to the locked files.

We are thinking of downgrading to Version 10 of adobe in near future to allow us to clear citrix profiles or even might look at an alternative reader like Foxit if not updates fix this issue soon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2015 Jan 11, 2015

Copy link to clipboard

Copied

I had the same issue it was pain in my %#^ to unable to delete those files

Here is the way I deleted the PDF file:

Open Adobe-XI-PRO

Click File -

Click View All Recent File

Click - My Computer

Click - the unnecessary File (right Click un the pop-up window) and you can delete it.

Hope it helps

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2015 Jan 21, 2015

Copy link to clipboard

Copied

Any updates that are official? Allot of inconsistent fixes in this thread. Love to hear something that works 100%

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2015 Jan 21, 2015

Copy link to clipboard

Copied

Hi,

on a 2008 R2 based machine uninstall of the mentioned 3 updates should solve the problem. I don't think there will be any official statement....

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2015 Jan 22, 2015

Copy link to clipboard

Copied

Like others that  have already posted,  uninstalling all three patches doesn't always resolve the issue. (2 of my servers are not resolved when I uninstalled)

Whos  issue is this?  Microsoft to fix a broken patch or adobe to fix reader to adhere to a new Microsoft change?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2015 Jan 23, 2015

Copy link to clipboard

Copied

We have several terminal server farms (with 2000+ users).

We didn't remove any KB articles, but this fixed this issue for us.

Local profile folder contains USER.DOMAIN.000, 001, 002

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2015 Jan 23, 2015

Copy link to clipboard

Copied

thx, will give it a try and will report here after that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2015 Jan 23, 2015

Copy link to clipboard

Copied

As described in the article, we could reproduce the problem by logging in; Print a PDF document and then log off. The profile folder was not removed because of the TMP files. After the fix, i did exact the same and the local profile folder was successfully removed from the server.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 23, 2015 Jan 23, 2015

Copy link to clipboard

Copied

After what fix? There are lots of different fixes mentioned in this post and its hard to keep track of what is working or not. Does anyone have a fix for XenApp 6.x that does work regardless of MS patches.

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2015 Jan 23, 2015

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2015 Jan 24, 2015

Copy link to clipboard

Copied

I did what you mentioned but, still have the temp files. Any other options?

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 24, 2015 Jan 24, 2015

Copy link to clipboard

Copied

The fix only works for new profiles. You have to delete the already existing double profiles.

This is possible after a reboot. Then the 000, 001, 002  profiles are unlocked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines