Fillable form. Active field is filled with black. Can't see what you are typing.

Explorer ,
Dec 13, 2017

Copy link to clipboard

Copied

When choosing the option "Replace Document Colors" Acrobat always fills in the active (blinking cursor) text field with black. The user cannot see what they are typing, and they do not want to change their text to white just to be able to see. Users here like to change their background to yellow. This has worked fine in Acrobat Pro 9, 10, and 11. But since upgrading to Acrobat Pro DC 17, the users can no longer change their background color because it blacks out their textfields as they are typing. After deselecting a text field, it no longer is filled with black. Only when editing a field does it turn black and unreadable.

Anyone having similar issues?

Thanks

Topics

PDF forms, Windows

Views

6.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Guide ,
Dec 16, 2017

Copy link to clipboard

Copied

Are you able to provide a screenshot of the Accessibility preference settings you are applying that cause this issue?

Also let us know what Operating System (and version) you are on. E.g. Mac OS High Sierra, Windows 10.

I'm unable to simulate it (Mac OS High Sierra) with a test text field I created in Acrobat Pro DC form (Continuous Release |  Version 2018.009.20050):

  1. I can see the field highlight colour in the form (Preferences > Forms has settings to adjust these colours).field-highlight-colour.png
  2. I can see the yellow text on black background as I type.field-active-typing.png

I tested with the following settings:accessibility-settings.png

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 23, 2018

Copy link to clipboard

Copied

Windows 7. Adobe Acrobat Pro 17. 2017 Release (classic) | Version 2017.011.30070. Checking for updates says no updates available.

Screenshot of preferences. I also noticed you did the opposite of what I was saying. The background is set to bright yellow, and the text is black. It is easier on the eyes for our employees and is why they choose to change the background from the harsh white and black contrast. Setting the background to yellow forces the text fields to turn black, thus the user cannot see what they are typing.

adobepref.PNG

This is what the user sees when they click on a text field and enter information.

pdfblack.PNG

As you can see. My text is not legible and I do not know what I am typing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 25, 2018

Copy link to clipboard

Copied

Our entity is having the same issue with our fillable forms.  Our users have the background to yellow with black text for easier read and to ensure the document is a text searchable document.  We are migrating ALL staff over to Adobe Acrobat Pro 2017 and this problem is coming up for our staff and outside users required to use our fillable forms.  We really need an answer to this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 16, 2018

Copy link to clipboard

Copied

I have had that same issue. It sounds like there still hasn't been any resolution. My workaround has been typing on a Word doc and then cutting and pasting into those boxes. It's a pain, but it's better than crossing your fingers, hoping that you don't have a misspelling or typo and have to go back to fix it without being able to see what you're doing. And I using Adobe Acrobat Pro DC

Likes

2 Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 16, 2018

Copy link to clipboard

Copied

I have just figured it out! Yeah! Because that was really bothering me. If you go to edit...preferences...accessibility...uncheck the box for "replace document colors". I feel as though a weight has been lifted from my shoulders.  So happy.

Likes

3 Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 03, 2018

Copy link to clipboard

Copied

Thank you, thank you thank you.....!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 15, 2018

Copy link to clipboard

Copied

How does this correct your issue? If I uncheck the box for "replace document colors" then my page background goes back to white, defeating the purpose of this post.

Replace document colors has to be checked in order to avoid the white and black contrast. Users here want their background yellow and their text black. Unchecking replace document colors just resets adobe back to default settings which have always worked from the beginning.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
May 09, 2019

Copy link to clipboard

Copied

As far as I understand it, the replace document colors functionality works for the document, but not for Annotations (such as form fields). So, what you can try is to change the fill color of the field to transparent, and/or to yellow, and see what happens now.

You might also deactivate the Hover color in the Forms tab of the Acrobat Preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 09, 2019

Copy link to clipboard

Copied

How would I change the fill color of the field to transparent? I see no fill color in Adobe preferences.

Deactivating "Show border hover color fields" does not rectify the issue either.

I appreciate the attempt though! Any other suggestions would be great.

And as far as "This is not a good way to get in touch with Adobe." I have been in touch with them directly, and they were unable to give me an answer. It is also awkward that this has gotten over 2,000 views with no answer, and there is still nothing from Adobe reps.

When I design forms for our internal users, I ensure I set the fill color / background of all fillable fields to white, to ensure our users can see it. But I should not have to engineer a solution from the ground up and make a form from scratch. There is no reason why Adobe Acrobat should ever fill a fillable box with ALL black. That just does not make any sense.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 20, 2018

Copy link to clipboard

Copied

Thank you! That was a big help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 15, 2019

Copy link to clipboard

Copied

SOLUTION: go to Properties > Appearance > Fill Color - make fill color white.

@taylorr99346932

Screen Shot 2019-02-15 at 11.03.13 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 09, 2019

Copy link to clipboard

Copied

There is still not a solution to this problem. Surprised not a single Adobe rep has commented on this, as I know this is a problem for many organizations. Most likely because they only care about AEM Forms, which do not have this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
May 09, 2019

Copy link to clipboard

Copied

It looks as if there is a confusion about these forums.

These forums are "user-to-user", where users more experienced in a topic help users with less experience in that topic. There are people from Adobe following the forums, but they very rarely comment. Therefore, these forums are not a channel to pass things to Adobe, or to get in touch with Adobe representatives.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 10, 2019

Copy link to clipboard

Copied

I am not sure what program or OS that is. Is that Acrobat for Mac? But there is no option to change "fill" color in  Acrobat 17 for Windows 7.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 04, 2020

Copy link to clipboard

Copied

wow, thank you so much for figuring that out!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
One Stop Solution for Acrobat
Edit a PDF
Add a group