• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Unable to delete linked components from the component panel in XD.

New Here ,
Jul 15, 2019 Jul 15, 2019

Copy link to clipboard

Copied

Hello,

I can not delete some of my components any more. Right click on a component, the only options I have are 'highlight on canvas' and 'relink' or 'edit master in source document'. The component is not in my document any more, so I don't know why I can't delete them. Anyone has the answer?Schermafbeelding 2019-07-15 om 10.49.39.png

 

<The title was renamed by moderator>

TOPICS
Product performance

Views

9.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 23, 2020 Oct 23, 2020

Hi All,

 

We are sorry for the trouble deleting the linked component. Unfortunately, we currently don't allow you to make local or delete a linked nested components because that impacts dependent parent components.

 

The team is working on it to make improvements in the future.

 

We are sorry for the inconvenience.

 

Thanks,

Harshika

Votes

Translate

Translate
New Here ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

It doesn't solve the issue if we aren't in your case, which is mine 😕

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 12, 2019 Dec 12, 2019

Copy link to clipboard

Copied

The December release is supposed to be focused on bug fixes and perfomance. Let's see if they fixed this.

https://twitter.com/ashorten/status/1205133282263744513

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 22, 2020 Jan 22, 2020

Copy link to clipboard

Copied

Not fixed. And it's not a hidden component either. In addition, it randomly shows the option 'delete', but upon selecting delete, it just doesn't delete it. Very frustrating. Does anyone know if Sketch is as buggy?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2020 Jan 15, 2020

Copy link to clipboard

Copied

Have had the same issue today. My master file with all icon components is now broken and meaning all masks have broken also so the previews in the component menu are now just grey boxes. I rely on my design system to provide work accurately and efficiently. I can't work with it if I have to keep repairing it. My designs are now broken and files are visually wrong so I can't present any of my work.

 

This has caused a major issue for my work. How do I explain this to the people I'm working for

 

Very frustrating. I switched from Sketch (after 4 years) to XD because of all the bugs they were releasing into their software. I hope I don't regret the switch. As a community we shouldn't be having to hack around bugs in software that as customers we are paying for. We need reliable software that empowers us, not software that hamstrings us and makes life difficult.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2020 Feb 14, 2020

Copy link to clipboard

Copied

It's still not fixed, I'm having same issue now, and I do have latest version of XD.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

While not a complete solution, I believe I do have some answers regarding the root cause of these issues. 

 

Having experienced all  (or most) of the symptoms described in this thread at one point or another, I've come to connect the issues with the creation and copying of nested components. In a nutshell, if you copy components that contain components from one document to another, you create a hierarchical structure of dependencies. 

The result is that you won't be able to delete, or make local the internal (building block) components unless you delete or make local those components that are built from them. 

 

For those of us who have created some fairly intricate compound components, this can make it a little difficult to narrow down which component (or components) contain the most building block components; these are the ones that must be deleted or made local. The best way I've found is to simply right-click down the components list until you find one that will allow you to Delete and/or Make Local. The ones that allow this are the "key" components that contain the building-block components we are trying to Delete or Make Local but find ourselves unable. 

 

Good luck, everyone. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 27, 2020 Feb 27, 2020

Copy link to clipboard

Copied

Thank you for the detailed info. This is a known issue, and the team is working towards improving the experience for complex component workflows in future updates. But I encourage everyone to keep posting here so that we are aware of how much still needs to be done.

 

Thanks,

Preran

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2020 Mar 10, 2020

Copy link to clipboard

Copied

[moved into a separate reply; can't delete this one]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2020 May 24, 2020

Copy link to clipboard

Copied

This problem still exists after the May 2020 Update of Adobe XD !!!

 

We are talking about a tool to create UI which should be easy to use.

And for a problem that exists now nearly over a year there is still no describtion in the offical xhelp.adobe.com or a hint in the UI of XD.

I don´t have any understanding for that.

It takes too much time to find out about these unnecessary undocumentet issues (search in XD, search the Web....)

Makes me feel like beta-testing for Adobe without being asked or paid.

And I wonder how much longer it will take for a team (not one or two people) to "work towards improving the experience for complex component workflows"

The only reason I prefer XD over figma so far,  is the workflow with Ai and Ae, otherwise I would be gone by now.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Here we are a year later and still not fixed. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2020 Mar 11, 2020

Copy link to clipboard

Copied

Components really can't be "made local". You have to start over and create a new master and make child components from that master. If you import assets from another document and place 50 instances of a master component in your document you only get the option to unlink each instance from the master. There's no option to create a new master for all those instances which is local only to your document. All 50 instances have to be deleted and new ones placed based on your new local master.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2020 Mar 10, 2020

Copy link to clipboard

Copied

Thanks for letting us know that it will be looked into. I can confirm that the issue is still there on 27.2.12.

 

I copied a navigation bar from a UI Kit, which automatically imported some linked components. Then I deleted a few of the icons that I don't need, but they remain stuck in the Components list, where I can only "Edit Master in Source Document" or "Highlight on Canvas".

 

IAlreadyHadAScreenName's solution does work, however. I found the navigation bar in the Components list, and after deleting that one, I could also delete the individual icons.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2020 Apr 05, 2020

Copy link to clipboard

Copied

I also had this problem - can not delete a component copied from elsewhere! - extremely frustrating. I'm by no means an expert on Adobe XD so I am uncertain of this, but I think I found a solution. 

 

I wass copying components from Wires.XD. I was trying to remove unwanted components, tried unlink, edit master component etc... nothing worked. 

 

What i did notice was when pasting into the new document (a nav bar), a new component would appear (along with the individual elements with the group). When i right-clicked on the new component a new option appeared - 'make local component'. Once I did this I was then able to delete the unwanted components from the assets list. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

I have tried that - however I have some linked components that are not giving me the option to make them into a local component as well. This is RIGHT AFTER I have copied them from another document - so I did not change the name of the component in the document they originated from.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2020 Mar 11, 2020

Copy link to clipboard

Copied

The best solution at the moment is to avoid importing assets. Copy and paste assets from other documents and turn them into new components.

 

Recently we completed a project and I had to send XD source files to the client. If the now former client wants to make changes to the design they could easily do "Edit Master in Source" for a linked component and change the master component that exists in our cloud documents without us knowing. Altering our version of the design because of a change they needed to a master component. We would have no record of the final designs before the XD files were sent to the client.

 

There's no way to give them a document with a separate master component that doesn't affect our source files. Ultimately I just unlinked all the components and made them local before sending the files to the client.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 14, 2020 May 14, 2020

Copy link to clipboard

Copied

I had this problem too but what I did was click on the "+" button beside the "Components", then you'll be able to delete the other symbols!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2020 May 24, 2020

Copy link to clipboard

Copied

This problem still exists after the May 2020 Update of Adobe XD !!!

 

We are talking about a tool to create UI which should be easy to use.

And for a problem that exists now nearly over a year there is still no describtion in the offical xhelp.adobe.com or a hint in the UI of XD.

I don´t have any understanding for that.

It takes too much time to find out about these unnecessary undocumentet issues (search in XD, search the Web....)

Makes me feel like beta-testing for Adobe without being asked or paid.

And I wonder how much longer it will take for a team (not one or two people) to "work towards improving the experience for complex component workflows".

The only reason I prefer XD over figma so far,  is the workflow with Ai and Ae, otherwise I would be gone by now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

It's july 2020 and I also have this same problem. The component and asset system is not working as intended at all. And it ruins any copy document as well. It's a nightmare.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2020 Jul 30, 2020

Copy link to clipboard

Copied

I am still having this same issue too which makes my design system overcrowded.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2020 Jul 30, 2020

Copy link to clipboard

Copied

I had the same issue but managed a work-around! Here's how it went -

Screenshot 2020-07-30 at 23.38.39.png

Previously when I selected only one component at once, it showed me just these two options, and no delete option.

 

Then I held the shift/command button and selected more than one components at once, the delete option appeared! 

Screenshot 2020-07-30 at 23.40.57.png

Hope this helps! 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jul 30, 2020 Jul 30, 2020

Copy link to clipboard

Copied

Goes to show how incredibly inconsistent XD is cause that doesn't work here. I'm on W10. Adobe should really take a long hard look in the mirror and start iterating XD based on the user respons. There's a ton of errors to fix and instead of releasing buggy software they should adress all the problems before anything else. The "this approach may work for you" thing is hopeless.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Same here, still no solution. This umpteenth workaround is just wasted time. 

I'm still having the same issue on the latest macOS Catalina update and the latest Windows 10 pro update.

 

Also the autosave function (I guess) literally broke 2 files (Xd couldn't open it and was still showing errors) which I had to restore from a previous version and I lost hours of work.

 

I've spent the entire day fighting against major & critical bugs that keeps users from working. 

None of the workarounds described here worked and I currently cannot work on my files without crashes, lags, or files that just broke. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Hi there,

 

We are sorry for the frustration. We would feel the same in your situation. Could you please record a video with a complete workflow on your machine and share with us here? Please share the XD version of your machine.

 

We will try our best to investigate the issue and escalate it to the team.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

This topic has started on Jul 15, 2019, and this bug is still not fixed (Autumn 2020).  I have the same issue. So I just stack them at the bottom of my panel to see them less. Thank's Adobe.

Screenshot 2020-09-18 151349.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

I have this problem as well but I quit trying to understand how it works

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines