After Effects (Beta) error: Cached Preview needs 2 or more frames to playback

Participant ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

Hello. Loving the beta for the past few weeks. But when I upgraded today, I could only get ram previews to work new projects. Old projects yield:

 

"After Effects (Beta) error: Cached Preview needs 2 or more frames to playback"

 

This seems to be a very old bug wich has resurfaced. I purged all, increased cache size, trashed prefs... Restarted. No luck. Same project/comps ram preview correctly when I launch 22.2.0... even when current and beta AE are launched concurrently.

 

AE (beta) 22.3.0 build 90

Apple M1 Max, 64 GB RAM, MacOs 12.2.1

TOPICS
Bug , Error

Views

606

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Update: I reverted to AE 22.2.0 (Build 105) and can once again ram preview as expected -- without encountering bug. Project/comp & cache settings are identical.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

I should have stated initially, that the workaround was using 22.2.0 non-beta, while today's workaround is using 22.2.0 (Beta). I assumed incorrectly that Beta and non-beta had different version numbers. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Hi BGPictures,

 

What is your memory preference set to in Preferences -> Memory & Performance? We just made a change on Monday's beta build, version 22.3 build 89, where After Effetcts should honor this preference which we had been exceeding at times previously. First try increasing the amount of memory available to After Effects in this preference.

 

Thank you,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Hi Jason. Thanks for looking into this. After effects never had less than 52GB in all of my testing. I've attached a screenshot of my current settings in 22.2, but this is what 22.3 looked like as well. Please let me know if I can provide any further info. Cheers!

 

Screen Shot 2022-03-02 at 11.02.04 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

After Effects (Beta) error: Cached Preview needs 2 or more frames to playback still exists in the latest version of (Beta) After Effects.


System info
    Application: After Effects (Beta) v22.4.0.17
    OS: macOS v12.2.1, RAM: 64.00 GB GB, CPUs (logical): 10

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

@jason_bartell  any ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

One clue is that "cache frames when idle" does nothing on the effected comps. I see no green render frames sticking around no matter what settings I haveScreen Shot 2022-03-24 at 6.29.50 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

Here's a video showing timeline scrubbing drawing green render frame indicators that then disappear. And it also shows speedy response as I scrub, followed by the Cache Preview bug when I try a ram preview:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

Hi @Tom Olsen. Any thoughts on this? I have uninstalled / reinstalled all adobe apps with a new user and get the same results with this project. I don't ususally change versions of AE / CH mid-project, but was so excited by the performence of the current builds in my testing, and did not detect the project-killing ram bug until a few days into working on a project started on a non-beta AE within the Beta version. Shall I just chalk it up to no backwards compatibility? Thanks!! Benjamin 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 05, 2022 Apr 05, 2022

Copy link to clipboard

Copied

UPDATE: New project, no CHproj. Same ram bug.  @jason_bartell @Tom Olsen

Please let me know if I can help.

 

Thanks,

Benjamin


    Application: After Effects (Beta) v22.4.0.32
    OS: macOS v12.2.1, RAM: 64.00 GB GB, CPUs (logical): 10

Screen Shot 2022-04-05 at 4.49.07 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

Hey @JohnColombo. Any thoughts? Cheers, Benjamin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

Apologies for the offtopic, but could you tell me what's the experience like with your 64GB M1 Ultra?

I'm asking because I have gotten an M1 Ultra 48-Core 128GB Ram, but I'm still withing the return period and I'd like to know how AE (beta) runs on the M1 Max.

Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

Sorry, I meant your "M1 Max", not "Ultra".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Hi @Filippo Marchetti. I would load the beta and run it through it's paces. AE under Rosetta on my setup is underwhelming, especially with illustrator files. AE beta (running without rosetta) has an incredible boosts in performence, but there are specific bugs I'm running into regarding ram previews and solid creation which no one has been able to adress for me just yet. Good luck and feel free to message me through my adobe profile for more specific questions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Hi Benjamin,

 

The two frame error maybe coming from After Effects' thinking it doesn't have enough memory to store frames for preview. We've identified one issue internally around Cinema 4D memory use but we're continuing to test and look for more issues. Can you send us a project that demonstrates the Two Frame issue you are encountering? It does not need to have footage if the bug will reproduce without it.

 

Thank you,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Hi @jason_bartell . I tried to collect a proj for you to look at -- but collecting the project seems to fix the RAM bug experience. (good workaround!) I also tried unlinking all the media by renaming my source folders, and the color-bar version also seems to fix the RAM bug experience.

 

I would guess that it has something to do with dynamically linking Character Animator projects in my After Effects Project. Please let me know if there is any other way I can help. Would a log of the non-functional project be helpful? 

 

Cheers, 

Benjamin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Hi BGPictures, 

Do you still have the AE project including the Character Animator (CH) Dynamiclink scene to see this issue? 

If so, could you please share it? 

Before sharing, please “zip” the entire CH project folder. 

 

Steps: 

  1. In AE, select Dynamiclink CH scene footage item. 
  2. File > Reveal in Finder 
  3. In Finder, “chproj” is selected and revealed. 
  4. In Finder, go one up to the parent folder of “chproj” file.  
  5. Compress that folder.

 

Plaes share this compressed file with AE project you see this problem.

 

Thank you,

Keiko

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 11, 2022 May 11, 2022

Copy link to clipboard

Copied

Hi @keiko.yamada . Thanks for looking into this. I just sent you a private message with download links to the files requested. Hope this helps. For anyone else visiting this thread, here's a link to a video of the bug in action.

 

Best,

Benjamin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

Hi @BGPictures

 

We have fixed a number of issues with After Effects' memory handling, including an issue when using Dyanmic Link. Thank you for this clue; it helped us home in on the root cause! We made a change to force a minimum preview length so the "needs 2 or more frames" error should be gone as well.

 

Please re-test with AE beta 22.5 build 28 or later. Build 31 is currently available for install.

 

Thank you,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

Hi @jason_bartell. I've finally had time to test. I'm on v22.5.0.43, and the ram bug is different: instead of bringing up an error dialog, it just plays 2 or 3 frames. I tried all configurations I could think of in the Preview panel, but get the same results. Even on quarter res and wireframe. Also, collecting the project does not fix the issue now.

 

Also, there was a fledgling alpha interpretation bug that I could fix by reinterpreting chproj to go from "straight" to "premultiplied". Now this workaround does not work and all my chproj seem to have "straight" alpha no matter what I set it to. I'll post this in a new thread -- just wanted to type it here in case you can refer me to a workaround. 

 

Thanks! 

Benjamin

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 03, 2022 Jun 03, 2022

Copy link to clipboard

Copied

Thank you for testing and getting back. The symptom would indicate AE doesn't have enough space to cache frames. AE is now consuming enough space for five frames to preview or the setting in Preferences > Memory and Performance, whichever is greater. This limit is now strict to prevent over consumption of memory. How much memory has been set aside for AE and can you bump it up?

 

I'm not familiar with the issue of straight vs premultiplied and Character.

 

Cheers,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

I am experiencinig the same issue with a max of 4 frames for ram previewing. Regardless of the composition -- A comp with just a solid, full or quarter quality. I have a 32GB M1 Max MacBook Pro. Currently set to have 20GB for AE. Using 22.5.0 Build 53.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

LATEST

@jason_bartell Any updates on this ram preview issue for M1?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources