• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Updated system requirements for After Effects Beta 24.0

Adobe Employee ,
Aug 21, 2023 Aug 21, 2023

Copy link to clipboard

Copied

We will update our system requirements with the next major release of our video applications. This includes the 24.0 versions of After Effects, Audition, Character Animator, Media Encoder, and Premiere Pro.

 

This change goes into effect with today’s Beta build, 24.0x37.

 

We update our system requirements each year, which allows After Effects to take full advantage of these platforms and helps ensure optimal performance for you.

 

Minimum OS Requirements 
To run After Effects Beta version 24.0x37 and above, Mac users need to be on macOS Monterey (version 12) or later. Windows users need to be on Windows 10 (64-bit) v22H2 or Windows 11.

 

We recommend running our applications on the latest operating systems:

  • macOS Ventura (version 13) 
  • Windows 10 (64-bit) v22H2 or Windows 11 V22H2

 

Please note that support for macOS Big Sur (version 11) is discontinued. It will not be possible to install the 24.0 versions of our video applications on macOS 11 or older. 

 

Minimum GPU Requirements 

After Effects Beta versions starting from 24.0x37 will no longer support NVIDIA Kepler generation cards (Kepler Geforce desktopKepler Geforce notebooksKepler Quadro desktopKepler notebook). To continue using GPU-accelerated rendering on supported NVIDIA cards, please install the latest NVIDIA Drivers (522.25 or newer). 

 

Minimum CPU Requirements

After Effects Beta version starting from 24.0x37 will require computers with Intel and AMD processors with Advanced Vector Extensions 2 (AVX2) support. 

 

Rosetta support on macOS

The final non-beta release of After Effects 24.0 will not support Rosetta on Apple silicon. Mac users will be able to continue to use the architecture specific 24.0 version on Apple silicon and Intel-based Mac machines.

TOPICS
Performance

Views

2.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

LATEST

Adobe is aging our Macs so quickly 😞

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources