• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

AE H.264 Exporter - Awful Audio Quality

5 Votes
Community Beginner ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

The new H264 encoder out of AE is a welcome addition, but am I the only one experiencing absolutely horrible audio quality?  Even if I set the AAC bitrate to 512kbps, music still sounds heavily compressed.  Video quality is solid; not sure why the audio is so bad.

 

If I send it through to Media Encoder, audio is fine, even at a lower bitrate.

 

Is this a bug of some kind, or is there some hidden setting I can change?

Bug Fixed

Views

434

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Dec 02, 2022 Dec 02, 2022

This issue is fixed in the current beta and will be available in the next After Effect release.

Status Fixed

Votes

Translate

Translate
25 Comments
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Without any info about your system, your audio devices, the relevant prefs, exact render settings and so on we can't tell you much. You need to be much more specific.

 

Mylenium 

Votes

Translate

Translate

Report

Report
New Here ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

Hello, I've exactly the same problem. When I analyse the .mp4 file afterwards, the bitrate is not the one indicated in the Output Module, and, actually, it's kind of random (it goes from 40kbps to the actual wanted bitrate).

It's independant of the audio device (it 's the same when I use any of my external cards or my internal cards). I also cleaned my preferences, it change nothing. It happen with a brand new installation and the default H.264 presets, in hardware and software encoding. It's the same on 3 of my computers, with nvidia 3080 and 3090 (even if it should not change anything for software rendering). For now, I still use mediaencoder, and still looking for a solution if it exists!

Votes

Translate

Translate

Report

Report
Community Expert ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

Interesting. Does it make a difference if you use VBR or CBR? At least in VBR modes it could simply be AE getting the math wrong or the caches needed for the passes getting botched.

 

Mylenium

Votes

Translate

Translate

Report

Report
New Here ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

No, it makes no difference. One thing I tried is tu use MPEG instead of AAC, and it seem to work fine. Maybe I didn't tried it long enough though, iPhone can't read those files anyway and I use them as previews on my web server so that's not a solution for me.

Votes

Translate

Translate

Report

Report
Community Expert ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

Fair enough. Just throwing out ideas to narrow down the possibilities. 🙂

 

Mylenium

Votes

Translate

Translate

Report

Report
New Here ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

Sorry for the double post but it also seem to work fine when I empty my cache first, but due to the randomness of the bug, I'm not sure either.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

It seems that if I change anything in the output module between 2 renderings, the bug does not occur. For exemple, I do a first rendering in 48kHz (emptying cache), it's ok, I do a second one, it bugs, I switch to 44.1kHz, it works, I render a second time in 44.1kHz, it doesn't. So maybe there is a bug with audio cache or something.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

Hi, me again ! I actually found that the bug starts when you render 2 files, one with 2 output modules or 2 different renderings (even 2 different comps). Then, one of the rendered file is corrupted. After that, every file is corrupted until you change a parameter in the output module options. 

Votes

Translate

Translate

Report

Report
Community Expert ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

I've re-classified this as a bug, as it seems you're on to something here. Sounds liek an initailization problem where the renderer is re-using some setting or buffer instead of refreshing it and then things go sideways.

 

Mylenium

Votes

Translate

Translate

Report

Report
Community Expert ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

Additional info provided by user via PM:

 

I made a short video showing the bug if it can help. You can find it here :

https://clients.dubon.fr/Adobe/Rec.mp4

 

First render, only one file, no bug.

Second render, first file has a problem, the 2nd is ok.

For some reason, the 3rd render is ok, but usually it's not, it's still a bit random 

4th render, both files are wrong.

 

It's not obvious in this record, but it doesn't change anything if I open or not the output module options, or audio options before rendering.

 

Mylenium

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

Hi @Aaron5FB0 and @Dubon,

 

Thank you for reporting this issue along with the key details. We're looking into it.

 

Cheers,

Jason

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Just wanted to chime in here and also agree that it's after a second render of the same output module.  I had a client come back and tell me my audio on a second render was bad.  I had changed some text in the comp and re-rendered using the "duplicate with filename" function in the render queue. the same exact settings as the first, and the second one sounded super compressed.  I'm moving back to AfterCodecs for my h.264 encoding the time being.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

I have this same issue too. I render a bunch of mp4's and half of them have corrupt audio. I tried switching to MPEG instead of AAC but it didn't resolve the issue. Having the ability to render mp4 is great, but this audio issue is frustrating.

 

Mac Monterey

2.3 GHz 18-Core Intel Xeon W

128GB Memeory Radeon Pro

AE 23

Votes

Translate

Translate

Report

Report
New Here ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

When using the Native H.264 Rendering option in After Effects 23, I'm able to set the video and audio bitrates in the output module, but after pressing OK, the audio bitrate will often reset itself to a much lower number. This happens completely at random.

 

For example, I'll set the bitrate to AAC 320kbps, press OK, then press OK again to exit the Output Module settings, then go back into them, and it will have set itself to 40kbps. This happens both when changing the settings manually and when using a saved preset. The video bitrate settings are unaffected by this and seem to work as they should but it's impossible to reliably export H.264 audio - sometimes you get what you want, other times AE gives you what it wants.

 

After Effects version 23 (Build 59)

MacOS Monterey 12.6

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Nov 19, 2022 Nov 19, 2022

Copy link to clipboard

Copied

This appears to be releated to another issue where multiple consecutive renders cause bad audio quality. If the bitrate indeed changes arbitrarily, this could explain the bad quality on a second or third render of the same project. The devs are aware of the latter issue, so I'm sure they would have a look at this problem as well.

 

Mylenium

Votes

Translate

Translate

Report

Report
New Here ,
Nov 21, 2022 Nov 21, 2022

Copy link to clipboard

Copied

I'm having the same issue, but i've noticed that sometimes when I need to change something in my project and render it again, the audio becomes better. 
But sometimes, when I need to change something again, the audio get worse too. 

Votes

Translate

Translate

Report

Report
New Here ,
Nov 22, 2022 Nov 22, 2022

Copy link to clipboard

Copied

Thanks for responding. At first I thought this had something to do with multiple renders being started at the same time, but the problem still exists when rendering single files. I need to render every file multiple times (with the same settings) and then compare their sizes to confirm which one is the largest/has the proper quality audio.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

Hi @Aaron5FB0 @Dubon @del_razor @kc127 @gabriel5E9E ,

 

We have fixed the H.264 audio export issue and the fix available now in beta builds in the Creative Cloud Desktop application. Please give it a shot and let us know if you see any further issues.

 

Thank you again for taking the time to let us know.

 

Cheers,

Jason

Votes

Translate

Translate

Report

Report
New Here ,
Nov 30, 2022 Nov 30, 2022

Copy link to clipboard

Copied

It works like a charm. Do you have any idea when it will be released ?

While we are here, it's no really correlated but the other issue I have is that I can't render two mp4 simultaneously when I use hardware encoding (tested on up-to-date nvidia RTX 2080, 3070, 3080 or 3080Ti). Only one of the two renders works. It's the same in AME. I tell you that because when I tested the beta, I forgot to remove hardware encoding and AE simply crashed. Usually it's just the render that doesn't work.

 

Thanks !

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 01, 2022 Dec 01, 2022

Copy link to clipboard

Copied

@Dubon,

 

The fix will be in the next release which is not far off.

 

Cheers,

Jason

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

This issue is fixed in the current beta and will be available in the next After Effect release.

Status Fixed

Votes

Translate

Translate

Report

Report
New Here ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

We are having this issue across several computers now. All Apple boxes. Doesn't matter if I use the default H264 output module templates or I make my own. For the attached screenshots, I setup my template with audio set to 224K as in the screengrab. When I select the output module, sometimes it doesn't change and other times is resets to 40K as default. This doesn't matter what setting I use for the audio bitrate settings. It changes to 40K randomly. I could load 8 files into the render queue at the same time and 6 will be correct and 2 will not be. This is the same with the stock built in H264 templates. It always changes to 40K as well. I have to manually go check every output before I render and it is a nightmare workflow. This just started in the past week. No issues with any other formats so far. It is also doing the same thing when we send to media encoder. Randomly changes the audio. Video setting stay perfectly set and populate like expected. 

Votes

Translate

Translate

Report

Report
New Here ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

Meant 48K - not 40K. 

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

This issue has been reported already and is under investigation/ being worked on. For the time being render an intermediate file as ProRes or such and encode it in AME, which apparently handles it correctly.

 

Mylenium 

Votes

Translate

Translate

Report

Report
New Here ,
Dec 02, 2022 Dec 02, 2022

Copy link to clipboard

Copied

LATEST

Going to go with ProRes as we are getting the same issue via dynamic linking when using H264 and Media Encoder. Noticed it is doing the same thing over there but I'm seeing different bitrates as sometimes it's 48K, other times it's 64K, and then 56K at other times. Luckily it's very seldom, but when you're outputing 20-30 files at a time, it's a little bit of a pain.  At least it's a workflow! Thanks for the quick response!

Votes

Translate

Translate

Report

Report