• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

3D camera tracker delivers static tracker points

Participant ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Hi all,

New strange bug in After Effects: I track a shot as usual, analyzing seems to go fine but the solve seems to be done too quick and I am presented with a handfull of static trackerpoints. There is almost always a horizontal row of points in the top left corner, as shown in attached image.

To my knowing I changed nothing since a week or so, when I last used tracking successfully.

Any ideas?

TOPICS
Dynamic link

Views

238

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , May 16, 2024 May 16, 2024

Hi @Lewiz,

No worries, we appreciate you reporting this issue. Did the previous version of AE produce the same static tracked points with footage on the network? If not, we might still have a bug to address.

 

Thanks for any further info,

- John, After Effects Engineering Team 

Votes

Translate

Translate
Participant ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

And sorry to disturb you all: what obviously all of a sudden changed in After Effects is the ability to work directly with network files. this worked until last week or so, now I have to copy the files I am tracking from the networrk location to a local folder on my pc.

No idea why or what, but this is a reasonable workaround.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Hi @Lewiz,

No worries, we appreciate you reporting this issue. Did the previous version of AE produce the same static tracked points with footage on the network? If not, we might still have a bug to address.

 

Thanks for any further info,

- John, After Effects Engineering Team 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Hi JohnColombo, thanks for making the time for this.

I was jumping to conclusions earlier, further examination shows now that the problem is not simply solved by moving files to my local pc. It might have something to do with the shot, because I tried different shots (all MXF) and some work, some don't.

I should try it with some more source material to narrow the search. I will share my findings!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Okay, as far as I can conclude now (tried both network and local source files) the 3d camera tracker problem has to do with file characteristics. To compare, I used exactly the same shot in two versions: an MXF format, being not colorgraded yet, and a QT colorgraded one. Specs for the QT mov:

 

General
Complete name : A:\XXXX.mov
Format : MPEG-4
Format profile : QuickTime
Codec ID : qt 0000.00.01 (qt )
File size : 17.9 GiB
Duration : 15 min 37 s
Overall bit rate mode : Variable
Overall bit rate : 164 Mb/s
Frame rate : 25.000 FPS
Encoded date : 2024-05-03 11:22:35 UTC
Tagged date : 2024-05-03 11:22:35 UTC

Video
ID : 1
Format : ProRes
Format version : Version 0
Format profile : 422 HQ
Codec ID : apch
Duration : 15 min 37 s
Bit rate mode : Variable
Bit rate : 164 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:2
Scan type : Progressive
Bits/(Pixel*Frame) : 3.158
Stream size : 17.9 GiB (100%)
Writing library : avi1
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

Other
ID : 2
Type : Time code
Format : QuickTime TC
Duration : 15 min 37 s
Frame rate : 25.000 FPS
Time code of first frame : 00:01:55:00
Time code of last frame : 00:17:32:10
Time code, stripped : Yes

ReportBy : MediaInfoLib - v24.04
CreatedOn : UTC 2024-05-16 15:05:55

 

This one worked flawless, and these are the specs for the MXF, which I cannot get to work:

 

General
Complete name : A:\XXXX.mxf
Format : MXF
Commercial name : XDCAM HD422
Format version : 1.3
Format profile : OP-1a
Format settings : Closed / Complete
File size : 5.47 GiB
Duration : 15 min 37 s
Overall bit rate : 50.2 Mb/s
Frame rate : 25.000 FPS
Package name : WNL AANGEHAAKT S02A03 STOCKHOLM GRADED
Encoded date : 2024-05-04 12:50:26.900
Writing application : Blackmagic Design DaVinci Resolve 18.6.6
Writing library : DaVinci Resolve

Video
ID : 2
Format : MPEG Video
Commercial name : XDCAM HD422
Format version : Version 2
Format profile : 4:2:2@High
Format settings : BVOP
Format settings, BVOP : Yes
Format settings, Matrix : Default
Format settings, GOP : Variable
Format settings, picture structure : Frame
Format settings, wrapping mode : Frame
Codec ID : 0D01030102046001-0401020201040300
Duration : 15 min 37 s
Bit rate mode : Constant
Bit rate : 50.0 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Active Format Description : 0
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:2
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Top Field First
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.965
Time code of first frame : 00:00:00:00
Time code source : Group of pictures header
GOP, Open/Closed : Open
GOP, Open/Closed of first frame : Closed
Stream size : 5.46 GiB (100%)
Title : WNL AANGEHAAKT S02A03 STOCKHOLM GRADED_v1
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

Other #1
ID : 1-Material
Type : Time code
Format : MXF TC
Frame rate : 25.000 FPS
Time code of first frame : 01:00:00:00
Time code of last frame : 01:15:37:10
Time code settings : Material Package
Time code, stripped : Yes
Title : TC1

Other #2
ID : 1-Source
Type : Time code
Format : MXF TC
Frame rate : 25.000 FPS
Time code of first frame : 01:00:00:00
Time code of last frame : 01:15:37:10
Time code settings : Source Package
Time code, stripped : Yes
Title : TC1

Other #3
Type : Time code
Format : SMPTE TC
Muxing mode : SDTI
Frame rate : 25.000 FPS
Time code of first frame : 01:00:00:00

ReportBy : MediaInfoLib - v24.04
CreatedOn : UTC 2024-05-16 15:11:56

 

Could be as simple as the interlaced/progressive difference, but I don't have a clue. Setting interpret footage to progressive didn't make a difference. 

I hope this information is useful.

 

Best regards, Tom Lewiz Verweij

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Thanks for sharing the details, Lewiz.

 

Could you share both the footages as well? I tested a interlaced footage with similar properties to yours, but After Effects tracked it without any issues.

Looking forward to your response. Moving this thread from Bugs to Discussions for troubleshooting.

 

Thanks,

Nishu

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Hi Nishu, thanks for your contribution!

Unfortunately both shots are too long, I tried shortening them but the unavoidable re-encoding changes the 3d tracker behaviour totally, so that is not a good workaround.

Is there a way to send you something like 500 mb?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 31, 2024 May 31, 2024

Copy link to clipboard

Copied

Sure, you can upload it to any cloud (Google Drive, Dropbox, etc) or a file sharing service like Wetransfer and share the download link here. If you don't want to share it publicly, feel free to DM me.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 31, 2024 May 31, 2024

Copy link to clipboard

Copied

Clever. Thanks! This is a WT link > https://we.tl/t-lXGHcvd51p

Thanks for taking the time!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 11, 2024 Jun 11, 2024

Copy link to clipboard

Copied

Thanks for sharing the file. I didn't find the same shot as you have shared a screenshot of. I tested the files and tracked 2 sections (0-2 sec. and 11-12 sec.). The tracking was almost the same with both footage.

As basic maintenance, can you try clearing the cache and running After Effects in Safe Mode? See if that brings any change.

 

Thanks

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 17, 2024 Jun 17, 2024

Copy link to clipboard

Copied

Hi guys -- I'm having the exact same issue on a PC running AE 24.4.2 build 2.  MXF files exported from Media Composer (both ProRes & DnxHR) and camera tracked show a bunch of static markers exactly as you describe.  Exporting the exact same shot as Quicktime allows them to be able to be tracked....

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

Hi, what happens when you export MXF in a 10-bit depth? I expect this to be a codec problem indeed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

Hi Nishu, thanks for your patience. I was on holidays last week, kept me from reacting.

I tracked the exact same footage again that I sent you, using the same time codes you did. Even after clearing cache and starting in safe mode, I get the same result: the MXF does NOT work, the MOV does. 

Just for info I attached a screenshot of the specs of this MXF as seen by VLC player. Not sure if this could be a cause. Hope you have another suggestion, I will try to fiddle around a bit with these clips to see if I can tackle the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 20, 2024 Jun 20, 2024

Copy link to clipboard

Copied

LATEST

That's strange!

Are there any third-party plug-ins installed for After Effects or Premiere Pro? Also, could you share your system specs? I am positive that system specs will not affect the quality of the track, but I'd like to test in a similar environment.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines