audio stops playing when I add any keyframe to a 3D layer

New Here ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

contacted Adobe support, who tried to troubleshoot the issue over 1 hour plus, but couldn't find anything to resolve the issue. 

I previously and him, had checked settings within AE, and locally within my Macbook M1 whilst going through other common troubleshooting steps like checking for audio volume, audio hardware settings under preferences, and so on. 

The only way I found to resolve this is keep copying all layers, when this happens, then close the comp and paste all said layers into a new comp. But this is not workable for a workflow at all. 

The audio track(s) would play fine on their own within After Effects (when double clicked within layers panel to open up in their own live preview window) or locally within the MacOs's Finder. 

Adobe support guy tried pre-composing all layers and the audio plays fine but once he goes into the layers by clicking on the pre-comp, then the same issue persists. 

Anyone faces this on their M1 Macbook and know a way to resolve this? I think this is a bug within After Effects that Adobe team has overlooked or haven't gotten to resolve especially given the new M1 Macbook machines. 

TOPICS
Audio , Error or problem

Views

50

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

so, I found what's causing the issue. When I'm working on 1 view, no error at all to playing said audio. The issue crops up soonest I have 2 views simultaneously. 

Going to email Adobe if they don't respond here, to see what turnaround they can come up with, to resolve this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

Do you have your audio set to mute if playback is not real time?  I would also try tweaking anything that directly related to rendering and performance playback...disabling hardware acceleration, multi frame rendering, disabling and reeneabling your audio drivers.

~Gutterfish

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

Hey, so the audio comes back whenever I switch back  to 1 view and not 2 views. All my settings in AE and my local machine are as shipped, save for 1 setting within AE which has nothing to do with rendering or playback/preview in real-time.


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

Hi songspursuit

 

Sorry for your issue.

Is it only the 3D layer that losses the audio or all of the layers in the comp? Which 3D renderer is selected? Please try switching between Classic 3D and Cinema 4D renderer and see if that brings any change.

Let us know.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

all layers in the comp loses the audio. This only happens when I'm having 2 views versus 1 view at any time. 
I'm using Classic 3D and have switched to C4D renderer but the same error persists. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

LATEST

Had a similar issue but mine wasn't keyframing. I had a clip, camera, null, text (ofc all 3d) with audio and was using 2 views to figure out where to place the text and whatnot. It would play a split second of audio then silence, so I tried precomping this and that and it worked (although I needed those layers in the same comp to work with them). Changed it to 1 view and it worked perfectly fine. 

 

Seems a little strange since I never had issues with this in the past (although I'm clueless about types of renderers, I just used whatever was default) 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines