Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Bug After Effects : import sequence of images

Community Beginner ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Bug import sequence of images in after effects CC 2017 : the last images of the sequence are not imported. For example, for a sequence of 500 images, images are transparent from image 417 to the end. This bug exists with every sequence I import.

Sorry for my bad English, I'm french.

Views

4.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 06, 2016 Dec 06, 2016
Ok, it works by following exactly this procedure: 2. When you import JPEG footage, in the Import dialog changes the Enable option to "All Files" and the Format option to "JPEG" (instead of "ImportJPEG"). Previously, I tried replacing in the import dialog 'all files visible' with 'jpg' instead of 'all files' and it did not work. So this is the same problem already listed with jpgimporter. Thank you very much Roei Tzoref. You helped me a lot. I hope this bug will be resolved quickly.

Likes

Translate

Translate
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

are these jpg sequences? there is a known bug with the jpegimporter causing framerate mismatch and there is also the issue you are describing. Known issues in After Effects CC 2017

many workarounds are described here: Re: AE CC 2017 - BIG Bug interpreting the FPS of the sequence of images

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Unbelievable ! I encode the sequence of images with AME in mp4 to do a test. I import the mp4 file into after effects. It's the same thing. The sequence has only 417 images instead of 500! While it is normally seen in a player like VLC.
I can not work !!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

I encode the sequence of images with AME in mp4 to do a test.

if you encode a wrongly imported sequence (because of this bug) to an mp4 container and play it - you should expect seeing the same result as the sequence.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

I'm having no issues with image sequences. Please give more details. What type of image? How are they numbered?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Thank you for your answers.
Roei Tzoref: I have seen the link of your first post but this is not exactly my problem. The solution recommended in the link does not solve my problem.
The sequence is not bad, it is composed of 500 images jpg and it is read normally in other software than after effects. The mp4 file is read normally in VLC.

Rick Gerard: It's a sequence of jpg images numbered tree02_0000.jpg at tree02_0499.jpg.
I did tests with other jpg sequences and I have the same problem. So it worked before. These are sequences used in older projects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

The sequence is not bad,

the sequence is not, but Ae 2017 Jpeg importer is. show us a screenshot of your project panel with the sequence highlighted so we can take a look. have you tried to import the sequence using Jpeg format and not Jpegimporter?

here's a thread that I think had a similar issue and the jpegimporter was the problem: Last Frames of my Footage are Black

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Yes, I tried to import the sequence using jpeg format instead of jpgimporter and it does not work either. Yet my problem is exactly the one described in your link. And the problem is a jpg problem because it works with png sequences.

I also often have another bug: when I do a preview or sometimes when I move the playhead to the timeline, it crashes and I get the error message: After Effects (error). Denominator zero report product (17§17).

Is it related?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Yes, I tried to import the sequence using jpeg format instead of jpgimporter and it does not work either.

try again after deleting your cache in preferences->media&disk cache

when you import try to select "force alphabetical order"

also show us the project panel with the sequence highlighted. see if it imports at the right frame rate. click on it twice and see if you see all the frames.

about that other issue - can't be sure. you are using 14.0.1 right? make sure your GPU is updated and try to reset preferences and also try to see if you can check hardware acceleration off in the display options and if that makes a differences

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Ok, it works by following exactly this procedure:
2. When you import JPEG footage, in the Import dialog changes the Enable option to "All Files" and the Format option to "JPEG" (instead of "ImportJPEG").
Previously, I tried replacing in the import dialog 'all files visible' with 'jpg' instead of 'all files' and it did not work.
So this is the same problem already listed with jpgimporter.
Thank you very much Roei Tzoref. You helped me a lot.
I hope this bug will be resolved quickly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

yes it could get tricky. you know something? I actually wanted to post the exact pose where I wrote the exact procedure but thought to myself - he will figure it out because it's there in the thread I sent I am posting it here for all to see because I could not get it right the first time too. and I remind to all seeing this thread - there are also other workarounds. for example setting your interpret footage default in the preferences which is the easy option if you are only dealing with one type of fps per project.

one workaround is this:

1. upon import set the file type to "all files" like this:

2. now change the format to Jpeg and import as normal

now the changed interpret footage frame rate won't return to the preferences default upon saving and behave as normal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

Thank you again for these details and for the screenshot Roei Tzoref.
I didn't follow the exact procedure the first time because I don't understand the English language well enough.

For framerate, I always work at 25 fps and it's this framerate that is set in import preferences. Despite that, I had the bug.

Have a good day.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 06, 2016 Dec 06, 2016

Copy link to clipboard

Copied

For framerate, I always work at 25 fps and it's this framerate that is set in import preferences. Despite that, I had the bug.

that's helpful to know. thanks for clarifying that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

LATEST

This worked with 2021 cc version - mine were pngs and I dragged and dropped into project from file explorer (win 10 64). All black. Imported using steps above and chose png instead of jpg and BAM! I can see them!! Thank you so much for this!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines