Consistently crashing when working in 3D

Contributor ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

I'm working in a project that is not overly complex or intensive, but has a couple comps with 3D elements in them -- some shape layers, text and a camera in one and video elements and a camera in another. With both, working on them is causing consistent crashes for seemingly no reason.

 

Anyone else experiencing this?

 

Mac Pro, 3.2 GHz, 16 core, 192 GB RAM, Pro Vega II 32 GB GPU

AE 22.1.1

TOPICS
Crash , Error or problem

Views

53

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Hi nyfeman,

 

Sorry for the crash.

Does it happen in a particular project or all of them? Do you see any error message or crash report? Also, are you using any third-party plug-ins?

For basic maintenance, reset the preferences of After Effects. Here's how: https://community.adobe.com/t5/after-effects-discussions/faq-how-to-reset-trash-preferences-in-after...

Let us know.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

What format and resolution  are all footage items in the problem comps?  Aree you able to provide a screengrab of the problem comp, with all adjusted parameters visible on the timeline?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

This project appears to be the only cursed one. 


Both comps are 1920x1080, 30 fps

Comp 1 (this is the one screen shotted):

There are three video objects which are each 1172x780, 59.84 fps (and 2.7, 3 and 5.2 MB in size)

A rig composed of 4 shape layers, one ellipse and three placeholders (which are the parents of the video objects).

A null controller containing a slider to store the number of items on the rig.

A 1-node camera

All of the above are 3D.

 

Also, there's a text layer and shape layer behind that text layer -- in 2D.

 

Screen Shot 2022-01-14 at 9.04.54 PM.png

 

There is another comp that's literally just 3 precomps (composed of a shape layer and text object in each) 3D'd and a camera with some movement.

And another text layer and shape layer behind that text layer -- in 2D.

There are no expressions

There's one comp in the project that is running a simple Form effect as a background

 

The crashes happen most frequently when in one of those comps, but not exclusively.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

LATEST

 

There's a reasonable amount of mathematics going on in the expressions there.  I'd just work through a process of elimination on a copy of your project.  Delete layers one by one and keep working until the crashing stops.  Start with the Form layer, as its a third party plugin and fairly memory hungry.

 

And, as always, make sure you're using the latest versions of AE, Form, any graphics drivers, OS etc.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines