Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


drop down menus and RIGHT-CLICKING not working

New Here ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Mac OS High Sierra 10.13

latest version of After Effects 15.0.0

I can't drop down the inner drop down menus on the timeline.  For example, changing a matte from ADD to SUBTRACT.  They won't work.  Nor will RIGHT Clicking any menu.  This works in the latest Premiere software..  I tried restarting multiple times, and switching mouses.  Nothing works.

I'm freelancing at a facility that has Adobe CC, so I'm not fully in charge of my world.

Can anyone help?

Views

5.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

This is a known issue in After Effects (all versions) on macOS High Sierra (10.13) when the After Effects interface is on a secondary monitor.

The problem does not happen when the After Effects interface is on the primary monitor. It does not happen on macOS 10.12 and earlier.

Our apologies about the problem. We are working on a fix for a future update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2017 Nov 06, 2017

Copy link to clipboard

Copied

I also have this problem (2015 iMac 5k, latest version of AECC 15.0.0 build 180).

Any idea on when you'll have an update? This is making work pretty difficult, and have already lost a lot of time to troubleshooting this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2017 Nov 24, 2017

Copy link to clipboard

Copied

Hey, I have Windows and have the exact same issue, is there workaround for Windows version?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 18, 2018 Jan 18, 2018

Copy link to clipboard

Copied

Has this been patched? Should I upgrade?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

not sure, but this fix from a comment above worked for me -

"

In the Mission Control preference panel, you have to uncheck the "screens have their own spaces" (sorry, I'm French, I don't know the exact terms used in the English version of MacOS). That's the last checkbox in the list.

After a restart, the right click drop down menus are back on my second screen (on both After Effects CC 2017 and 2018)"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

Honestly, that is more of a hack than a fix. While it does solve the right click problem in after effects it takes away some pretty core OS functionality for me - it removes the dock on all non-primary screens as well as the top bar.

Still looking for a real solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 23, 2018 Jan 23, 2018

Copy link to clipboard

Copied

The After Effects update that came out last night (might take up to 24 hours to propagate to Adobe's servers around the world) fixes this issue. (And several others - it also adds some new functionality.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Yes! Very necessary update. I just reverted to cc 2017 until this happened. Thanks for the heads up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

I have just encountered this too, and it is very irritating and slowing me down BIG TIME.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Try the workaround in this thread.

I had the exact same issue with After Effects.

I ended up finding a way to deal with it.

In the Mission Control preference panel, you have to uncheck the "screens have their own spaces" (sorry, I'm French, I don't know the exact terms used in the English version of MacOS). That's the last checkbox in the list.

After a restart, the right click drop down menus are back on my second screen (on both After Effects CC 2017 and 2018)

Hope it will work for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 17, 2017 Nov 17, 2017

Copy link to clipboard

Copied

Note: this workaround means you'll lose the taskbar on the second monitor.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

thank you for the work around - I started a freelance gig today - and this bug cost me around 3 hours of frustration.  Disappointed that this has not been patched yet... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 23, 2020 Aug 23, 2020

Copy link to clipboard

Copied

SOLVED FOR ME

I hope this works for everyone - but it did work for me.

The issue is not due to it being a second monitor, rather it has to do with Mission Control "Spaces".

This was a two-part solution for me.

Part 1 - in the System Preferences > Mission Control settings, uncheck "Displays have different spaces", then log out.
Part 1.5, I launched After Effects, and was like "yay - it works now, but BOO/Hissssss why can't I use spaces if I want to use AE??" I will explain why I chose Part 2 AFTER Part 2 for you impatient folks...
Part 2 - I went back in and checked the box to allow displays to have their own spaces and rebooted again...

Problem fixed for me. I have spaces, as well as work spaces, as well as right-click whereEVER the hell I want 🙂

After finishing Part 1, I recalled someone else reportedly fixed the problem in 2017 by deleting their personal AE Workspaces/preferences.. and so, I thought... hmmm... I wonder if it just needed to reset its expectations about the coordinates on the screen? because right-click did work SOMEtimes.. just not consistently... and only on certain areas of my screen (like the XY the mouse that it was at was different than what AE thought it was showing)... 

What I find interesting is the defensive posts from Adobe on the topic ("I dunno - Apple apple Apple" is I think the direct quote). Adobe - you were there for me when Apple @%$#ed everyone over with Final Cut X and told me that my thousands of dollars spent on third party tools and software were basically garbage. I thank you for that. Sincerely. 

But you are now blatantly disregarding me (your customer) in equal measure. I remember when you used to call me up once per year asking me to beta test for you. Good times on the QA front, yeah? Remember the good old days when you shipped software that was, by and large, "bullet-proof?"

I will make you a deal - I will beta test your stuff for free again in exchange for some software that isn't a @%$#ing pain in the @%$# making me consistently angry as well as late on my deadlines - because of @%$# software. It's REALLY REALLY BAD. like REALLY BAD. This morning alone - 4 hours spent trying to fix this problem. 

Yesterday, I spent three hours trying to get Adobe Media Encoder to render, finally giving up and exported directly from Premiere, which costs me more time because i cannot work while rendering... thanks for that. Every day it's some new thing I need to figure out a @%$#ing workaround for when the real workaround is right in front of me... but I do not want to do it... the workaround is to go back to Apple because you now hate your customers in the same way Apple did back then.

But since you both appear to hate us equally - I can honestly say that these sorts of issues do not happen with Apple - but I REALLY DO NOT WANT TO LEARN Apple Motion - - that @%$# is more backward than After Effects which says a lot.

Sigh - thanks.. I feel better.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

This is happening to me now on macbook pro, latest system latest AE, i uninstalled and reinatlled an older version but same thing happens, i disconnected secondary monitor and still its happening, i cant access many vital things, is there any solution?

Rick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

I am having this same issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Same, and I don't even use a secondary monitor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Same problem - do you have any solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Basically I solved this by opening preferences>click on random sh*t (without making any changes)> close preferences.

If it doesn't work the first time, repeat. I know it sounds stupid but work for me 🤷‍:male_sign:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

LATEST

I had this problem for a couple of days, I just solved it by randomly switching to the learn workspace in the bar and that fixed it, I switched back and drop down menus are working again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines