Puppet Pins Greyed Out

New Here ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Hello! I'm not sure if I clicked a wrong button, but my puppet pins for just one layer is greyed out and the pins don't move, I assume because thye're greyed out? Puppet pins that I have in other layers do move, but those aren't greyed out, I'm not sure how to get my pins back to normal?

This is what I mean by greyed out, normally they're just in white, but it's like these are blocked. Any advice? Thank you.

Screen Shot 2022-04-13 at 9.55.11 AM.png

TOPICS
Crash , Error or problem , FAQ , How to , Performance , User interface or workspaces

Views

141

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Moved from the Premiere to the After Effects forum.

 

Can you post a screenshot of your entire UI? showing the layer expanded in your timeline, the Effects Control panel open with the Puppet effect selected, and your Comp panel visible. Also, make sure the "Show Mesh" box in the top toolbar is checked and that your layer controls are visible (Ctrl/Cmd+Shift+H).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Is this what you mean?

Screen Shot 2022-04-13 at 11.19.13 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Yes, but it looks like you have a different layer selected in the Timeline, so the Effects Control panel isn't showing your butterfly layer. It's possible the auto-trace you did is causing an issue, but also, the Continuously Rasterize switch and Puppet effects don't work well together, you should disable that. 

If the pins are still grayed out, try switching the engine from Advanced to Legacy and back again. You might want to copy your keyframes first since the Advanced pin doesn't exist in the Legacy engine and they will get wiped out. I can't remember if they'll get restored when you switch engines back, but either way, you'll be able to hit Undo, if needed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

When I disable the Continuously Rasterize switch, it doesn't let me see the butterfly layer in the comp panel anymore, almost like it's been recmoved from the animation. I tried switching from Legacy to Advanced and back like you suggested, but it didn't seem to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Can you post a screenshot with the butterfly selected and the mesh showing on that layer? Just like the one above, but showing the butterfly in the ECP, as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

I tried having the mesh show, but it isn't popping up. I tried it on one of my other layers and those are working, just not on the butterfly. 

Screen Shot 2022-04-13 at 12.48.16 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Do the other layers have Continuously Rasterize turned on? In order for the mesh to show, the effect must be selected, then a pin, and the "Show Mesh" box must be checked. Right now you have the box checked for the tool itself, so the next set of pins you create will show a mesh, but it doesn't mean the box is checked for the butterfly mesh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Yes, the other layers have Continuously Rasterize turned on, I can add and take away pins from them. But for the butterfly, even when I try to add pins, it doesn't show up. I'm not completely sure what you mean with "but it doesn't mean the box is checked for the butterfly mesh"? Do you mean as in the layer selected for the butterfly?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

LATEST

Well, again, using Continuously Rasterize with the Puppet tool is going to cause problems. If you're not scaling your layers past 100% then you don't need it on, but at this point, I would remove the effect and recreate it since there appears to be a problem that's not easily fixable. Sometimes this is the easiest solution with the Puppet tool. I don't have problems with it often, but I think it has something to do with the mesh data that's created and stored when you apply your first pin; if that gets messed up or if you try to do something unusual (like replace the contents of a layer with the Puppet effect applied), this data can get messed up and cause you problems.

 

As for the mesh, yeah, the layer needs to be selected in the Timeline, the Puppet effect needs to be selected in the Effects Controls panel, then the Puppet tool needs to be selected with the box checked. It's several steps to show the mesh, but again, if you're doing all these and still having issues, removing the effect and starting over (with Continuously Rasterize turned off) will hopefully solve your problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines