• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

"Missing MFPlat.DLL" with windows Enterprise N, all updates installed. After Effects wont open

New Here ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

title pretty much says it all.

- I followed adive here https://support.microsoft.com/en-ca/help/4516397/media-feature-pack-for-windows-10-n-november-2019

- restarted

but no luck.

 

Its a complete new install the adobe software is the first software I installed

Photoshop works, but premiere and after effects not

 

I installed all windows updates 

I copied it from another PC and put it into `C:\Windows\SysWOW64`, its by default lowercase so I even renamed it to the weirdo case of the adobe error message

 

 

TOPICS
Error or problem , Freeze or hang

Views

5.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

For those who haven't figured it out yet, here's what worked for me.

 

1. Download appropriate media feature pack. Find the proper version here: https://support.microsoft.com/en-us/help/3145500/media-feature-pack-list-for-windows-n-editions

2. Run command prompt as admin. Enter this command:

    dism /online /enable-feature /featurename:MediaPlayback

 3. Restart pc. Pr and Ae should run by now.

 

Reference/s:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 26, 2022 Aug 26, 2022

Copy link to clipboard

Copied

LATEST

On my W10 LTSC N 1809 the above didn't work.

I did manage to install the media-feature-pack but it didn't help directly.

But I did a search for "mfplat.dll" in c:\windows and got two hits.

Both were version 10.0.17763.1, but the one was 1568KB and the other 2051KB. 
I copied the lagest one to the program-folder of my Adobe program, in this case Adaobe Premiere 2022 (C:\Program Files\Adobe\Adobe Premiere Elements 2022),  and now it works 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines